Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-03-2016, 12:54 PM   #1
Site Supporter




Join Date: Dec 2012
Location: Montréal QC
Photos: Gallery | Albums
Posts: 1,765
Liveview: Can't Disable Exposure Preview

Hi all,

So I hope no one's planning to shoot manual flash in liveview mode on the K-1...

I'm not a K-1 owner, but I played with one today at Lozeau, one of the larger photo stores in Montreal, where the K-1 has landed. I wanted to see how the K-1's behavior compares with my K-3. Result: I believe they behave exactly the same. Meaning that (unless I missed something) it's impossible, in liveview, to disable exposure preview in the LCD screen. In fact, the K-1 goes further than the K-3. While the K-3 will only dim the LCD by up to -2 eV when it thinks your shot will be underexposed, the K-1 goes at least to -5 eV, and an almost totally black screen. The impossibility to turn this off is very irritating when shooting manual flash in liveview! In such circumstances, the camera artificially dims the LCD because it thinks the shot will be underexposed. But it won't, since the (manual) flash will fire!

With the K-3, I run into this all the time shooting macro in liveview with a manual (Yongnuo) flash. The artificial dimming of the LCD is really irritating (see a previous discussion). On the K-3, the only workaround I know of is to set aperture using the aperture ring on the lens rather than controlling it from the body. (Of course, this assumes you're using a lens with an aperture ring. Otherwise you are S.O.L..) Setting the aperture with the aperture ring disables exposure "preview" in liveview mode on the K-3. I did not have a chance today to test if this workaround also works on the K-1, but I would think it probably does. Of course, this workaround has drawbacks: 1) No aperture value in the EXIF, and 2) often there are fewer stops on the aperture ring than possible values when controlling aperture from the body.

So, Pentax, if you're reading this, please allow the option to disable exposure preview in liveview mode on your new flagship camera. This should be a simple firmware fix.


Last edited by Doundounba; 05-03-2016 at 01:00 PM.
05-03-2016, 01:05 PM   #2
Site Supporter




Join Date: Aug 2014
Location: Texas
Posts: 131
Hmm, I'm sorry to hear that that's an issue.

I don't have a K-3 so I'm just spit-balling here... what if you set your camera to manual mode and maintained your exposure trio exactly as you planned - but to prevent the dimming, you used the exposure compensation function to trick the camera into thinking that its native (non-flash) state isn't as underexposed as it thinks it is?

Example:
You have a setting where you are adding +3 stops of exposure by flash.
When preparing the shot, the live view meter thinks you are at -3, so it applies the dimming you mentioned.
If you incorporate an exposure compensation of -2, it doesn't change your manual exposure settings, but the live view meter will only think you're -1 under proper exposure, thanks to the exp.comp.

Have you tried that? Obviously it isn't going to solve all situations like exclusion of ambient light by overpowering with strobes, but maybe it's a stopgap?
05-03-2016, 01:08 PM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 42,252
Doesn't exposure preview go away in M mode though?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

05-03-2016, 01:23 PM   #4
Site Supporter




Join Date: Dec 2012
Location: Montréal QC
Photos: Gallery | Albums
Posts: 1,765
Original Poster
QuoteOriginally posted by disasterfilm Quote
You have a setting where you are adding +3 stops of exposure by flash.
When preparing the shot, the live view meter thinks you are at -3, so it applies the dimming you mentioned.
If you incorporate an exposure compensation of -2, it doesn't change your manual exposure settings, but the live view meter will only think you're -1 under proper exposure, thanks to the exp.comp.
No dice on K-3. Dialing in some exposure compensation changes the "eV bar display" but doesn't change the LCD's brightness. But I did not test this on K-1. (BTW, this workaround was also suggested in the previous thread... ;-) )

QuoteOriginally posted by Adam Quote
Doesn't exposure preview go away in M mode though?
Nope. The meter is still active and the camera will tell you if it thinks your manual settings will cause underexposure by dimming the LCD. That's precisely what I'd like to turn off. Tested on K-3 and K-1.

I'll probably go back to Lozeau later this week with a lens that has an aperture ring so I can test the workaround on the K-1...

05-03-2016, 01:27 PM   #5
Site Supporter




Join Date: Aug 2014
Location: Texas
Posts: 131
QuoteOriginally posted by Doundounba Quote
No dice on K-3. Dialing in some exposure compensation changes the "eV bar display" but doesn't change the LCD's brightness. But I did not test this on K-1. (BTW, this workaround was also suggested in the previous thread... ;-) )
My apologies, I hadn't read the other thread. I should have done that before jumping in and responding.
05-03-2016, 01:30 PM   #6
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,097
QuoteOriginally posted by Doundounba Quote
So, Pentax, if you're reading this, please allow the option to disable exposure preview in liveview mode on your new flagship camera. This should be a simple firmware fix.
Everything is a simple firmware fix

I was not sure what you mean by "exposure preview" and it took me a few trips through your post to realize that you are talking about the automated dimming/brightening of the LCD that provides an estimate of over/under exposure due to intentional over/under exposure.

For the understanding of folk who don't use manual flash, flash exposure is done by balancing flash intensity against lens aperture. It is not unusual to shoot at f/11 and 1/60s and if shooting in Live View, the viewfinder becomes very dim as a result. This is a huge issue for those using the rear LCD or a field monitor for flash-illuminated macro or even on-tripod studio work.

Ideally, Pentax should provide the means to disable this feature. I agree with Doundounba that this is a setting that should be very easy to implement in firmware and should be added to the list of bugs, problems, and operational issues being forwarded to Ricoh to be addressed in future firmware revisions.


Steve
05-03-2016, 01:31 PM - 1 Like   #7
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 42,252
QuoteOriginally posted by Doundounba Quote
Nope. The meter is still active and the camera will tell you if it thinks your manual settings will cause underexposure by dimming the LCD. That's precisely what I'd like to turn off. Tested on K-3 and K-1.
Oops, looks like I misunderstood what you meant.

Pentax changed the K-3 and later to reflect the actual exposure in M mode in live view, which is something people had been requesting for a while. I agree that having a setting to toggle this behavior would be nice.

Try this workaround, though: put the camera in TAv mode and limit the auto ISO to a narrow range. Does the LV exposure remain constant in that mode?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

05-03-2016, 01:59 PM   #8
Site Supporter




Join Date: Dec 2012
Location: Montréal QC
Photos: Gallery | Albums
Posts: 1,765
Original Poster
QuoteOriginally posted by stevebrot Quote
I was not sure what you mean by "exposure preview" and it took me a few trips through your post to realize that you are talking about the automated dimming/brightening of the LCD that provides an estimate of over/under exposure due to intentional over/under exposure.
Right, sorry I wasn't clear. I mean the "feature" whereby the brightness of the LCD screen in liveview reflects whether your settings will produce under/over-exposure. So an under-exposed shot results in a dimmer rear LCD. Only it won't actually be under-exposed if you're shooting manual flash...

QuoteQuote:
For the understanding of folk who don't use manual flash, flash exposure is done by balancing flash intensity against lens aperture. It is not unusual to shoot at f/11 and 1/60s and if shooting in Live View, the LCD becomes very dim as a result. This is a huge issue for those using the rear LCD or a field monitor for flash-illuminated macro or even on-tripod studio work.
Exactly.


QuoteOriginally posted by Adam Quote
Try this workaround, though: put the camera in TAv mode and limit the auto ISO to a narrow range. Does the LV exposure remain constant in that mode?
Very cool! Seems to work on the K-3! I tried a situation where in M mode, the camera thought 1/160s, F/2.8 and iso 250 was properly exposed. I then switched to TAv with 1/160s, F/2.8 and a possible iso range of 200-250. I then proceeded to smaller apertures (larger aperture values) and the LCD display did NOT get any dimmer. I will definitely go back to test this on the K-1 in the store, unless a K-1 owner gets to it before I do and reports here... Looks like this is a viable workaround! Thank you!


Last edited by Doundounba; 05-03-2016 at 02:04 PM.
05-03-2016, 02:00 PM   #9
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 42,252
QuoteOriginally posted by Doundounba Quote
Very cool! Seems to work on the K-3! I tried a situation where in M mode, the camera thought 1/160s, F/2.8 and iso 250 was properly exposed in M-mode. I then switch to TAv with 1/160s, F/2.8 and a possible iso range of 200-250. I then proceeded to smaller apertures (larger aperture values) and the LCD display did NOT get any dimmer. I will definitely go back to test this on the K-1 in the store, unless a K-1 owner gets to it before I do and reports here... Looks like this is a viable workaround!
That's great! I'm sure it will also work on the K-1.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

05-03-2016, 02:12 PM   #10
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,097
QuoteOriginally posted by Doundounba Quote
Very cool! Seems to work on the K-3! I tried a situation where in M mode, the camera thought 1/160s, F/2.8 and iso 250 was properly exposed.
Very COOL!

I will have to remember this one.


Steve
05-03-2016, 03:07 PM   #11
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,751
QuoteOriginally posted by stevebrot Quote
I will have to remember this one.
Certainly looks like a setting worth saving as a User Mode, if you do lots of manual flash and LiveView.

Agreed that this LV behaviour should be under user control [LiveView Exposure Dimming On | Off | Auto] in the K-3 and later firmware.
05-05-2016, 12:13 AM   #12
New Member




Join Date: May 2016
Posts: 4
I have the same issue on K-S2 and I confirm that the TAv method (read: hack) works well on K-S2 fw 1.11, it solves effectively the problem, with the only minor issue that you are not able to use ISO100 (the narrowest option is setting ISO 100-200 -- so the camera will use ISO200 as it is convinced there is low light) -- I can live with it. Thanks you!
However, if someone from Ricoh is reading this thread, a firmware update with clear option for disabling the "exposure preview" feature will be highly appreciated.
05-05-2016, 02:12 PM   #13
Site Supporter




Join Date: Dec 2012
Location: Montréal QC
Photos: Gallery | Albums
Posts: 1,765
Original Poster
So, for the record, the TAv workaround also works on the K-1. I tested it today at a local store.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
aperture, bug, dslr, exposure, firmware, flash, full frame, full-frame, k-1, k-3, k1, lcd, liveview, pentax k-1, workaround
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
P-TTL on AF540 GZII - Can you disable preflash? petrakka Flashes, Lighting, and Studio 23 03-10-2016 07:03 AM
K5iis disable exposure lock (AE-L) sansfin Troubleshooting and Beginner Help 8 11-29-2015 01:00 AM
disable or lock exposure compensation? konraDarnok Ricoh GR 3 11-25-2014 12:52 PM
Can I get onscreen exposure preview? MrSkelter Pentax K-01 50 03-27-2013 09:11 AM
Help, can't my K5II image preview in windows bdparker Pentax K-5 6 03-15-2013 11:31 PM



All times are GMT -7. The time now is 02:52 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top