Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-19-2016, 02:33 PM   #1
New Member




Join Date: Feb 2016
Posts: 3
K-1 tethering with Lightroom CC on Windows 10

Hi everyone,
I just downloaded the latest Lightroom plugin for K-1 tethering. Unfortunately, it doesn't work. The Lightroom tethering toolbar doesn't recognize the camera. On the left side of it there is a dropdown to choose the camera and there's only one option: "No Camera Detected".
I was wondering what might be causing the problem. The camera's firmware is up-to-date (1.10) and USB connection in camera settings is set to PTP.
When I connect the camera to the PC and turn it on it says "PcP" on the top plate display and the camera is not functional at all.
I reviewed the system's device manager. It recognizes the camera as "Other devices -> PENTAX K-1" and indicates that the device's drivers are not installed. When I try to automatically install the drivers, it fails.

My system is Windows 10 Pro N.

Any ideas?

05-19-2016, 02:52 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,000
I'd try the usual methods: restart, install and updates (if available), and possibly plug the camera in to a different port.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

05-19-2016, 03:16 PM   #3
Pentaxian




Join Date: Mar 2010
Location: Frankfurt am Main
Posts: 1,045
From Windows XP through Windows 7, I found sometimes I had to run a newly installed program at least once with full admin rights, before it would work correctly also without these.
This may happen when new kernel drivers can be initialized for the first use only after a re-start, and during this process are too far back in the start-up queue and then are refused system rights for initialization. However, I dont know whether procedures have changed with Windows 8/10.
05-19-2016, 04:53 PM   #4
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,603
QuoteOriginally posted by matewka Quote
I was wondering what might be causing the problem.
Probably best to ask the plugin users in this thread what their settings are:

https://www.pentaxforums.com/forums/190-pentax-k-1/321485-lightroom-tethering-k-1-a.html

05-19-2016, 05:05 PM   #5
Senior Member
fwbigd's Avatar

Join Date: Jun 2007
Location: Fort Worth TX
Posts: 299
Have you downloaded and installed Image Transmitter 2?. It works in conjunction with the Lightroom plugin.
05-19-2016, 05:23 PM   #6
Loyal Site Supporter
clackers's Avatar

Join Date: Jul 2013
Location: Melbourne
Photos: Albums
Posts: 7,747
QuoteOriginally posted by fwbigd Quote
Have you downloaded and installed Image Transmitter 2?. It works in conjunction with the Lightroom plugin.
But the plug-in doesn't need it, right?
05-19-2016, 05:37 PM   #7
Site Supporter
dakight's Avatar

Join Date: Sep 2014
Location: Phoenix, AZ
Photos: Albums
Posts: 1,138
I hate to state the obvious, but have to downloaded and installed the firmware update for the K-1?
05-19-2016, 05:38 PM   #8
Senior Member
fwbigd's Avatar

Join Date: Jun 2007
Location: Fort Worth TX
Posts: 299
QuoteOriginally posted by clackers Quote
But the plug-in doesn't need it, right?
I had to download and install it to get the plug in for Lightroom to work. Here is the download link. IMAGE Transmitter 2 Update for Windows : Software Downloads | RICOH IMAGING

05-19-2016, 06:21 PM   #9
Site Supporter




Join Date: Jan 2009
Location: Edmonton, Alberta Canada
Posts: 546
Do we have to purchase a USB cable from Pentax? My K1 did not come with a USB connector.
05-19-2016, 06:24 PM   #10
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,000
QuoteOriginally posted by clackers Quote
But the plug-in doesn't need it, right?
It does not need IT2. You can use the Lightroom plugin as a standalone product.

QuoteOriginally posted by DDoram Quote
Do we have to purchase a USB cable from Pentax? My K1 did not come with a USB connector.
Not necessarily from Pentax, but one isn't included with the K-1.

The K-1's USB port is the micro E type, which is shared with nearly all Android phones. So if you have one of those lying around, the USB/charger cord will work

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

05-19-2016, 06:31 PM   #11
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,000
If you're curious about how this works but don't have a K-1 or 645Z, or for an installation guide, check out this article:

Tethering Guide for the Pentax Lightroom Plugin - Articles and Tips | PentaxForums.com

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

05-19-2016, 11:32 PM   #12
New Member




Join Date: Feb 2016
Posts: 3
Original Poster
QuoteOriginally posted by dakight Quote
I hate to state the obvious, but have to downloaded and installed the firmware update for the K-1?
You probably missed it. In the original post I said that I have the latest firmware in the K-1 (1.10).

QuoteOriginally posted by fwbigd:
Have you downloaded and installed Image Transmitter 2?. It works in conjunction with the Lightroom plugin.
I can't install IT2 update if I don't have the IT2 itself.

So far, none of provided solutions helped

Maybe someone who has it all working on Win 10 could check the device manager on their PC and see if the drivers are also not installed correctly? This could help to narrow the problem.
05-19-2016, 11:34 PM   #13
Site Supporter
dakight's Avatar

Join Date: Sep 2014
Location: Phoenix, AZ
Photos: Albums
Posts: 1,138
You have to change the USB port in the K-1 to "PTP." As soon as I did this Lightroom recognized the camera and I was able to complete a tethered capture.
05-19-2016, 11:51 PM   #14
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 41,000
QuoteOriginally posted by matewka Quote
You probably missed it. In the original post I said that I have the latest firmware in the K-1 (1.10).


I can't install IT2 update if I don't have the IT2 itself.

So far, none of provided solutions helped

Maybe someone who has it all working on Win 10 could check the device manager on their PC and see if the drivers are also not installed correctly? This could help to narrow the problem.
I ran it on windows 10 without issues (well, I was confused for a while until I realized I was plugging in and unplugging my mouse instead of the camera's USB cord, but after that, smooth sailing).

1. Does the K-1 show up as a media device in My Computer? If not, check your USB ports / media device drivers. If the memory cards show up as drives, you need to change to PTP mode.
2. Is the Pentax plugin showing up in Lightroom? If not, run as administrator if you installed the plugin as administrator, or reinstall it as not an admin then restart Lightroom.
3. Are any other programs accessing your camera while it's connected? "Photos" will by default scan connected media devices, and this prevents LR tethering.
4. If the camera is locked up while connected, this means it's busy and that another program is communicating with it.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

05-20-2016, 12:29 AM   #15
New Member




Join Date: Feb 2016
Posts: 3
Original Poster
QuoteOriginally posted by dakight Quote
You have to change the USB port in the K-1 to "PTP."
I also stated in the original question that I have it set to PTP.

QuoteOriginally posted by Adam Quote
I ran it on windows 10 without issues (well, I was confused for a while until I realized I was plugging in and unplugging my mouse instead of the camera's USB cord, but after that, smooth sailing).

1. Does the K-1 show up as a media device in My Computer? If not, check your USB ports / media device drivers. If the memory cards show up as drives, you need to change to PTP mode.
2. Is the Pentax plugin showing up in Lightroom? If not, run as administrator if you installed the plugin as administrator, or reinstall it as not an admin then restart Lightroom.
3. Are any other programs accessing your camera while it's connected? "Photos" will by default scan connected media devices, and this prevents LR tethering.
4. If the camera is locked up while connected, this means it's busy and that another program is communicating with it.
Thank you for your advices. I think that 1. (missing media drivers) is the problem.

I connected the camera to a different PC (with Win 8.1) and everything worked like a charm. As I said before, my Windows 10 is a special N version. It doesn't include Windows Media Player and some other stuff. I guess the "other stuff" includes some PTP camera drivers. I'll investigate this later when I'm back home.

Last edited by matewka; 05-20-2016 at 12:36 AM.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, cc on windows, drivers, dslr, full frame, full-frame, k-1, k1, lightroom, lightroom cc, pentax k-1, windows
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lightroom CC gets new features ... Lightroom 6.1 doesn't Quicksand Digital Processing, Software, and Printing 33 03-12-2017 04:35 PM
Lightroom Tethering with K-1 fwbigd Pentax K-1 14 07-29-2016 05:58 AM
Lightroom CC 2015.5.1 and v6.5.1 support K-1 rawr Pentax K-1 11 04-29-2016 03:32 PM
Lightroom compatability with Windows 10 bugman Digital Processing, Software, and Printing 10 03-09-2016 02:01 PM
Tethering 645z with Lightroom CC? xpixel Pentax Medium Format 4 04-29-2015 07:55 AM



All times are GMT -7. The time now is 06:10 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top