Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-26-2016, 11:34 PM - 1 Like   #31
Senior Member




Join Date: Feb 2012
Posts: 147
QuoteOriginally posted by nater Quote
Does anyone have any experience with pre-HSM Sigma EX and EX DG lenses on the K-1?
Yes. Usually, they work without problems. I've got two - a 12-24 and a 24-70, both sporting a diaphragm ring (lockable in 'A' position).

You can check yourself - the bayonet ring on the "affected" lenses, that is those with the mechanical problem, ist really huge. Check the image above posted by noelpolar, here you can see the bayonet contacts in relation to the ring's diameter.

Older Sigma lenses used normal-sized bayonet rings (at least the ones I know of), so there's no problem.

The firmware problem (causing camera body lockups) might be related to SDM/HSM lenses only, since the KAF3 protocol clearly is different from the KAF protocol.

From all the Sigma glass I've got only one is problematically, that's the 70-200/2.8 APO EX DG HSM Macro II, and that one's currently being serviced by Sigma.


Last edited by funktionsfrei; 06-26-2016 at 11:35 PM. Reason: removed double quote
06-27-2016, 04:37 AM   #32
Site Supporter
Site Supporter
Erdž's Avatar

Join Date: Aug 2010
Location: SEQ
Posts: 297
QuoteOriginally posted by nater Quote
Does anyone have any experience with pre-HSM Sigma EX and EX DG lenses on the K-1?
I can confirm that there is no issue with mounting the 100-300mm f4 EX DG on the K-1, and it works as expected.
06-27-2016, 08:38 AM   #33
Senior Member




Join Date: Feb 2012
Posts: 147
QuoteOriginally posted by funktionsfrei Quote
From all the Sigma glass I've got only one is problematically, that's the 70-200/2.8 APO EX DG HSM Macro II, and that one's currently being serviced by Sigma.
It was being serviced - today I got it back -- for free!
06-27-2016, 09:20 AM   #34
ahw
Junior Member




Join Date: Feb 2011
Location: Fresno, CA
Photos: Gallery
Posts: 31
Anyone see a problem with just putting a thin strip of tape over the part of the K-1 body that gets scratched?

06-27-2016, 10:51 AM   #35
Senior Member




Join Date: Feb 2012
Posts: 147
Won't help. If there is not enough clearance between lens and camera body, inserting something between them does not improve anything.

The lens will press against the "thin strip of tape" resulting in additional shearing on the lens mount.

No, I would not consider this a good idea.
06-27-2016, 11:24 AM   #36
Veteran Member




Join Date: Aug 2009
Location: New England
Photos: Albums
Posts: 691
QuoteOriginally posted by funktionsfrei Quote
Yes. Usually, they work without problems. I've got two - a 12-24 and a 24-70, both sporting a diaphragm ring (lockable in 'A' position).

You can check yourself - the bayonet ring on the "affected" lenses, that is those with the mechanical problem, ist really huge. Check the image above posted by noelpolar, here you can see the bayonet contacts in relation to the ring's diameter.

Older Sigma lenses used normal-sized bayonet rings (at least the ones I know of), so there's no problem.

The firmware problem (causing camera body lockups) might be related to SDM/HSM lenses only, since the KAF3 protocol clearly is different from the KAF protocol.

From all the Sigma glass I've got only one is problematically, that's the 70-200/2.8 APO EX DG HSM Macro II, and that one's currently being serviced by Sigma.
Thank you for confirming what I had inferred/expected. I'll be very happy if my efforts to avoid owning any HSM lenses work out well in the end with regards to the K-1.
06-28-2016, 04:50 AM   #37
Pentaxian
jackassp's Avatar

Join Date: Apr 2010
Location: Adelaide, South Australia
Photos: Gallery
Posts: 795
I sent off my 35/1.4 Art, and 85mm/1.4 DG HSM, and got them both back within 1 week (Australia). Problem solved, and both work better on the K-1 than they ever did on the K-3.
Now waiting for 24-70 and 50-500 to come back.

JP
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
damage, dslr, full frame, full-frame, k-1, k1, lens, pentax k-1, question, sigma, sigma damage
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
HD 1.4xTC damage to lens? UserAccessDenied Pentax SLR Lens Discussion 7 05-11-2016 08:26 AM
For Sale - Sold: Sigma 50mm f1:2.8 K-A Mount 1:1 Macro Manual Focus Lens $85 shipped to US Archimedes the Dog Sold Items 7 11-28-2015 09:46 AM
Excessive wear or damage to tripod socket? bwDraco Pentax K-3 15 07-14-2015 05:53 AM
Slight damage to K-30, plastic cover for pop-up flash, anywhere to get a new one? JesterPrime Pentax DSLR Discussion 16 02-02-2013 02:24 PM
Sigma extends warranty to cover Hurricane damage from Sandy interested_observer Pentax SLR Lens Discussion 2 11-09-2012 08:36 AM



All times are GMT -7. The time now is 11:55 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top