Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-06-2016, 10:15 AM   #1
Forum Member
MichaelErlewine's Avatar

Join Date: Feb 2016
Location: Big Rapids, Michigan
Posts: 62
Pentax K1 Suddenly Just Goes Blank

I am sure there is a button and a reason, but I will be working along and suddenly the camera just goes blank and nothing works. I have to turn the camera off and back on to keep going on what I am doing. What is this and how can I prevent it? Please.

07-06-2016, 11:05 AM   #2
csa
Loyal Site Supporter
csa's Avatar

Join Date: Aug 2014
Location: Montana mountains
Posts: 8,573
Sorry to hear this; have you tried a different battery; or charged this one?
07-06-2016, 11:15 AM   #3
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 9,827
QuoteOriginally posted by MichaelErlewine Quote
I am sure there is a button and a reason, but I will be working along and suddenly the camera just goes blank and nothing works. I have to turn the camera off and back on to keep going on what I am doing. What is this and how can I prevent it? Please.
Please forgive me if this is an insultingly basic question - it is not intended to be so.
When you say it goes blank, and you have to turn it off and on, have you tried pressing the shutter down halfway or more? I ask because the camera has a sleep timer that puts it to sleep to conserve power. Again - sorry if that is not what is going on.
07-06-2016, 12:15 PM   #4
Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 27,415
QuoteOriginally posted by MichaelErlewine Quote
What is this and how can I prevent it? Please.
QuoteOriginally posted by UncleVanya Quote
When you say it goes blank, and you have to turn it off and on, have you tried pressing the shutter down halfway or more? I ask because the camera has a sleep timer that puts it to sleep to conserve power.
Assuming our dear Uncle Vanya is correct, you can set "Auto Power Off" to a longer value (default is one minute) or completely off using the Set-up (wrench) menu #2.

That being said, normally a half-press of the shutter button will wake the camera up. Having to power-cycle is not the norm. I seem to remember a few similar reports, but can't say for sure. Perhaps @Adam will weigh in since he is sort of keeping track of this sort of thing.


Steve

07-06-2016, 01:46 PM   #5
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,032
Assuming it's not just auto off, could there be an electrical issue related to the lens mount, or low battery voltage? What lens were you using?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

07-07-2016, 05:12 AM   #6
Site Supporter




Join Date: Jul 2013
Location: Cumming, GA
Posts: 559
I see this behavior sometimes even with the older bodies. K-5ii and K-01 that is. I turn it back on and it turns back on but then shows the battery is depleted from 50% to near 0 and barely starts up to allow me to see the empty battery icon. If it turns back on then it is most likely a bad battery. Some non-branded batteries have poor cells in them and they just do not hold up well after 50% charge and depletes so rapidly that the camera shuts off abruptly making you think "what just happened...".
It may not be your case though but it may very well be.

If it is an electrical issue then it should happen consistently and should be reproducible.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dslr, full frame, full-frame, k-1, k1, pentax k-1, pentax k1
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello - I have just bought the Pentax K1 Rutti66 Welcomes and Introductions 12 05-06-2016 03:33 PM
Pentax 645NII Autofocus suddenly stopped working Wolfeye Pentax Medium Format 2 12-20-2015 05:13 PM
Pentax ME occasional blank negatives Squirrelu Troubleshooting and Beginner Help 5 07-20-2015 01:43 PM
DIY grid (also: suddenly, Pentax) rrstuff Flashes, Lighting, and Studio 2 05-06-2015 03:02 AM
Monitor goes blank with cable release installed gaweidert Pentax K-5 4 05-31-2012 05:23 AM



All times are GMT -7. The time now is 03:27 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top