Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-07-2016, 12:24 AM   #1
Loyal Site Supporter
Bengan's Avatar

Join Date: Nov 2012
Location: Stockholm
Photos: Gallery | Albums
Posts: 315
SD card formating necessity firmware 1.0 and 1.10

I have never pre-formatted a SD-card in either the K-5II or the K-3. When upgrading the brand new K-1 to firmware 1.10 I inserted a blanc SD-card my computer and copied the bin file to the card. When inserting the card in the K-1 I got a memory card error message. OK, I formatted the card in my computer and copied the file. This time I got the message that the card wasn't formatted. Did what's generally recommended and formatted the card in camera. This time everything worked as it should and the update went OK.


Now the interesting thing. After upgrading to v1.10 I can insert a blanc card and it is automatically formatted and everything works as with previous bodies.

07-07-2016, 12:40 AM   #2
Pentaxian
fs999's Avatar

Join Date: Jul 2008
Location: Luxembourg
Photos: Gallery
Posts: 3,445
Did you eject the drive of the SD Card prior removing the card from your computer ?
07-07-2016, 12:40 AM   #3
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 40,945
I don't think the firmware is to blame, though it could be. I've had this happen a couple of times too with other bodies. Usually an in-camera or a full PC format solves the problem; it's the quick formats that can be problematic.

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

07-07-2016, 01:23 AM   #4
Loyal Site Supporter
Bengan's Avatar

Join Date: Nov 2012
Location: Stockholm
Photos: Gallery | Albums
Posts: 315
Original Poster
QuoteOriginally posted by fs999 Quote
Did you eject the drive of the SD Card prior removing the card from your computer ?
Yes, always do.

07-07-2016, 08:18 AM   #5
Pentaxian
fs999's Avatar

Join Date: Jul 2008
Location: Luxembourg
Photos: Gallery
Posts: 3,445
I never remove the card from the camera. I always connect the camera to the computer...
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
card, card formating necessity, computer, dslr, firmware, full frame, full-frame, k-1, k1, necessity firmware, pentax k-1, sd card, sd-card, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-1 and SD card issues FtYoU Pentax K-1 31 07-11-2016 12:45 AM
New firmware 1.10 for K-1 released funktionsfrei Pentax K-1 2 05-19-2016 10:55 AM
Problem Formating SD card X-Raycer Troubleshooting and Beginner Help 11 07-20-2013 12:33 PM
SD card purchase with k7 1.11 firmware installed? oahutodd Ask B&H Photo! 6 01-27-2011 08:10 PM
Firmware 1.0 to 1.3 deludel Pentax DSLR Discussion 6 04-24-2008 08:35 PM



All times are GMT -7. The time now is 11:33 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top