Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-13-2016, 04:22 AM   #31
Senior Member




Join Date: Jul 2008
Posts: 112
Original Poster
Sure, here's the picture of the mount. I'm not exactly sure what it is that you're trying to find, but here you go.



The lens was bought new in 2011, and I bought it used in 2014, so long time before the arrival of K-1.

10-13-2016, 08:09 AM   #32
Senior Member




Join Date: Mar 2013
Posts: 291
QuoteOriginally posted by deepbluish Quote
Sure, here's the picture of the mount. I'm not exactly sure what it is that you're trying to find, but here you go.


The lens was bought new in 2011, and I bought it used in 2014, so long time before the arrival of K-1.
Thank you. I didn't know that, I thought that lens came from the same owner as K-1.

Because of that I wanted to check is that original lens mount or replaced one.
Second I wanted to check does it have any signs of previous servicing or not.

Lens was bought in 2011, so it was probably for a combo with K-5.
K-5 have 2 problems with original firmware of this lens: liveview focusing (hunting and no focus confirmation) and freezing because of battery level (camera freezing when it is low).
When freezing occurs it looks like camera malfunction.
That looks very bad because when it happens you can't even turn your camera off. Removing battery is the only solution.
For most of the people that behaviour will be a service alarm.
I can't imagine what kind of person after that would continue to use that lens for 3 years without servicing (except a few members of this forum).
99% will a) try to replace lens while it is new b) send lens to service before warranty expires c) get rid of it asap if warranty has expired

At this point I will close this discussion, there is a high probability that firmware of your lens was changed but there is not enough evidences to prove that.

Thank you for your help and happy shooting with your K-1 and 70-200
10-13-2016, 08:22 AM   #33
Senior Member




Join Date: Jul 2008
Posts: 112
Original Poster
I'm not saying that you're wrong, but if you're right, wouldn't it be safe to assume that the majority of K-5 owners who have this lens would have had the lens updated in order for it to be functional, thereby making it functional on a K-1 as well? So far, every single owner of this lens with LensID 8 255, apart from me, reported that their lens was not functional with the K-1. I'm sure at least some of them have moved from K-5 to K-1, skipping the K-3/K-3II.

Are you saying that this lens has never functioned as supposed to on any K-5 camera? I'm sure there would have been a lot of discussion about the issue at the time the K-5 was released, but I do not recall such an issue. Maybe others have better memory.
10-13-2016, 09:55 AM   #34
Senior Member




Join Date: Mar 2013
Posts: 291
I am a member of this forum since 2013.
So I could be wrong regarding K-5, but regarding K-1 I'm sure that you are the only person on this forum which has that combo working with original lens firmware IF 8 255 means original firmware.
I assume that because every owner of that lens who updated lens firmware reported that lens id has been changed.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
approach, camera, dslr, experience, firmware, focus, frame, full frame, full-frame, hsm, k-1, k-5, k1, lens, lenses, pentax, pentax k-1, sigma, tamron lenses
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
My 2015 Tax return has landed me.... Auzzie-Phoenix Pentax K-3 7 02-19-2016 01:11 PM
Nature eagle has landed dezertzebra Post Your Photos! 5 12-16-2015 02:20 AM
The Eagle has landed. HELP ME SPEND MY MONEY EarlVonTapia Pentax Q 5 05-30-2013 05:47 PM
Finally- my K-X has a grip.... forensicscientist Pentax DSLR Discussion 15 02-04-2013 05:21 AM
The 30/1.4 has landed pingflood Pentax SLR Lens Discussion 12 10-28-2008 03:57 PM



All times are GMT -7. The time now is 02:09 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top