Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-08-2017, 11:59 AM   #1
New Member




Join Date: Dec 2017
Posts: 8
D-BG6 battery grip not fire shutter on Pentax K-1

Dear Forum, just got a Pentax K-1 silver edition with grip which I am truly delighted with. Not sure what I am doing wrong but shutter will not fire when using the grip. All the other buttons and dials appear to work. Any ideas what I am doing wrong? best wishes Mike

12-08-2017, 01:11 PM   #2
Site Supporter
Site Supporter




Join Date: Feb 2015
Photos: Gallery | Albums
Posts: 7,117
QuoteOriginally posted by summiteverest Quote
Any ideas what I am doing wrong?
What you are doing wrong is to assume that this is a user error while it is something to deal with the after sale service of who sold you the equipment.
12-08-2017, 01:30 PM   #3
New Member




Join Date: Dec 2017
Posts: 8
Original Poster
QuoteOriginally posted by biz-engineer Quote
What you are doing wrong is to assume that this is a user error while it is something to deal with the after sale service of who sold you the equipment.
Worried I have made a truly obvious mistake and not set something. Just wanted to ask forum before I contact camera shop. Any ideas and help much appreciated. best wishes Mike
12-08-2017, 01:38 PM   #4
Site Supporter
Site Supporter




Join Date: Feb 2015
Photos: Gallery | Albums
Posts: 7,117
QuoteOriginally posted by summiteverest Quote
Any ideas and help much appreciated.
Problems with battery grips are typically related to bad contact between the grip and camera connection. Cleaning could help. Other than that, I'd have the grip checked with another camera, to confirm if the problem is on the grip or on the camera, camera shop could do the check if they have a K1 in spare.

12-08-2017, 02:10 PM   #5
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 48,987
QuoteOriginally posted by summiteverest Quote
Dear Forum, just got a Pentax K-1 silver edition with grip which I am truly delighted with. Not sure what I am doing wrong but shutter will not fire when using the grip. All the other buttons and dials appear to work. Any ideas what I am doing wrong? best wishes Mike
Is the power switch on the grip set to "on"?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

12-08-2017, 02:14 PM   #6
Site Supporter
Site Supporter




Join Date: Feb 2015
Photos: Gallery | Albums
Posts: 7,117
QuoteOriginally posted by summiteverest Quote
All the other buttons and dials appear to work
QuoteOriginally posted by Adam Quote
Is the power switch on the grip set to "on"?
If the power switch was Off, other buttons of the grip wouldn't work (tested on my own K1+grip).
12-09-2017, 04:37 AM   #7
New Member




Join Date: Dec 2017
Posts: 8
Original Poster
QuoteOriginally posted by biz-engineer Quote
Problems with battery grips are typically related to bad contact between the grip and camera connection. Cleaning could help. Other than that, I'd have the grip checked with another camera, to confirm if the problem is on the grip or on the camera, camera shop could do the check if they have a K1 in spare.
Thanks you are quite right. I tightened it a bit more and it worked. Have spotted a very slight gap between the grip and camera base plate where I can see all the way through. Is this usual? best wishes Mike
12-09-2017, 04:38 AM   #8
New Member




Join Date: Dec 2017
Posts: 8
Original Poster
QuoteOriginally posted by Adam Quote
Is the power switch on the grip set to "on"?
Thanks had set both to on. Suspect it was just not tight enough.

12-09-2017, 04:39 AM   #9
New Member




Join Date: Dec 2017
Posts: 8
Original Poster
QuoteOriginally posted by biz-engineer Quote
If the power switch was Off, other buttons of the grip wouldn't work (tested on my own K1+grip).
Yes totally right. Do you have any gap between your grip and the K-1 body? I can see a slight gap and can see all the way through.
12-09-2017, 07:39 AM   #10
Site Supporter
Site Supporter




Join Date: Feb 2015
Photos: Gallery | Albums
Posts: 7,117
QuoteOriginally posted by summiteverest Quote
Have spotted a very slight gap between the grip and camera base plate where I can see all the way through. Is this usual?
Yes it is.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
d-bg6 battery grip, dslr, fire, fire shutter, full frame, full-frame, grip, grip not fire, k-1, k1, pentax, pentax k-1, shutter, shutter on pentax
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Pentax Battery Grip D-BG6 For The K-1 (With Accessories) hgbisel Sold Items 2 08-29-2017 12:29 PM
Issues with my Pentax K-1, D-BG6 Battery Grip Let me know if yours is like mine? kraigg007 Troubleshooting and Beginner Help 15 07-09-2017 07:35 PM
Pentax BG6 battery grip JENSEN7474 Troubleshooting and Beginner Help 4 04-18-2016 09:47 PM



All times are GMT -7. The time now is 07:22 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top