Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-19-2019, 04:15 PM   #16
Junior Member
tonyzoc's Avatar

Join Date: Jul 2018
Posts: 29
In general Wifi function on the K-2S is useless. Even when it worked in the earlier version it was so slow it was only good for transferring a few pics at a time. Now I have an Android 9 phone (OnePlus 6T) and v.2.0.1 doesn't work at all. This is really bad. I was able to get ver.1.1.6 on Atpoide thanks to vrolok post above, and it works as long as I connect to wifi with the phone first...else it crashes. I can't see myself spending any more money on Pentax digital when they put out crap like this.I really hate when a company advertises a selling point and it turns out to be a fraud. I'd rather they just say..."we can't do wifi, we're just not good enough".

Also...in general...the way wifi works on DLRs is stupid. I don't want the camera to be a wifi hotspot...I want the camera to connect to wifi hotspots so I can transfer directly to cloud storage. I know that take a little more computing power, but if I can buy an android tv box for $29, surely that can add the hardware needed to connect to a wifi hotspot...select a cloud storage url, login and drop folder, and do a transfer. Am I missing something, or is Ricoh?

01-20-2019, 05:32 AM   #17
Loyal Site Supporter
Loyal Site Supporter
clackers's Avatar

Join Date: Jul 2013
Location: Melbourne
Photos: Albums
Posts: 12,131
QuoteOriginally posted by tonyzoc Quote
In general Wifi function on the K-2S is useless. Even when it worked in the earlier version it was so slow it was only good for transferring a few pics at a time. Now I have an Android 9 phone (OnePlus 6T) and v.2.0.1 doesn't work at all. This is really bad. I was able to get ver.1.1.6 on Atpoide thanks to vrolok post above, and it works as long as I connect to wifi with the phone first...else it crashes. I can't see myself spending any more money on Pentax digital when they put out crap like this.I really hate when a company advertises a selling point and it turns out to be a fraud. I'd rather they just say..."we can't do wifi, we're just not good enough".

Also...in general...the way wifi works on DLRs is stupid. I don't want the camera to be a wifi hotspot...I want the camera to connect to wifi hotspots so I can transfer directly to cloud storage. I know that take a little more computing power, but if I can buy an android tv box for $29, surely that can add the hardware needed to connect to a wifi hotspot...select a cloud storage url, login and drop folder, and do a transfer. Am I missing something, or is Ricoh?
All the brands work the same way. They're all slow. They all use WiFi modules that use up very little power.

02-01-2019, 09:35 AM   #18
Pentaxian
Tjompen1968's Avatar

Join Date: May 2012
Location: Norrköping, Sweden
Photos: Gallery | Albums
Posts: 1,380
WORKING! 2.0.2 works with Android 9 on my Xperia XZ1 compact. =)
02-01-2019, 11:40 AM   #19
Pentaxian




Join Date: Apr 2014
Location: Baltimore
Posts: 961
QuoteOriginally posted by Tjompen1968 Quote
WORKING! 2.0.2 works with Android 9 on my Xperia XZ1 compact. =)
Where are you finding v2.02?

02-01-2019, 11:57 AM   #20
Senior Member




Join Date: May 2009
Location: Finland
Posts: 209
New 2.0.2 has been on Google Play since yesterday. I got it working with Nokia 6.1 and K-1 ONCE. No connection after that.

Still a lot better than other 2.0.x versions which never connected to K-1. Have to try again later. Reboot phone etc.

---------- Post added 02-01-19 at 09:02 PM ----------

They added this note to Google Play "In some cases, it would take time until connected."

My guess is they simply added more time to connection build. At least with my phone it tries longer before timeout.

Last edited by Jyrkira; 02-01-2019 at 12:03 PM.
02-01-2019, 12:09 PM - 1 Like   #21
Pentaxian
Tjompen1968's Avatar

Join Date: May 2012
Location: Norrköping, Sweden
Photos: Gallery | Albums
Posts: 1,380
QuoteOriginally posted by Jyrkira Quote
New 2.0.2 has been on Google Play since yesterday. I got it working with Nokia 6.1 and K-1 ONCE. No connection after that.

Still a lot better than other 2.0.x versions which never connected to K-1. Have to try again later. Reboot phone etc.

---------- Post added 02-01-19 at 09:02 PM ----------

They added this note to Google Play "In some cases, it would take time until connected."

My guess is they simply added more time to connection build. At least with my phone it tries longer before timeout.
It connected and worked. I lost contact, tried to connect but it did not connect again. Removed the app from the list of recent apps. Tried again after restarting the camera and it connected.

What I do is first to connect with the phone wifi. Not via the app. Then starting the app. Sometimes it does not work and the app wants me to enter network and password. I do so but then it never works... So if it happens, I enter any password, just one letter or so, let it sit for a few second before I press the cross in the upper right corner and it connects.
02-01-2019, 12:48 PM   #22
Senior Member




Join Date: May 2009
Location: Finland
Posts: 209
QuoteOriginally posted by Tjompen1968 Quote
What I do is first to connect with the phone wifi. Not via the app. Then starting the app. Sometimes it does not work and the app wants me to enter network and password. I do so but then it never works... So if it happens, I enter any password, just one letter or so, let it sit for a few second before I press the cross in the upper right corner and it connects.
Thanks for the tip. I got it working again.
02-02-2019, 07:54 AM   #23
Pentaxian




Join Date: Apr 2014
Location: Baltimore
Posts: 961
QuoteOriginally posted by Tjompen1968 Quote
It connected and worked. I lost contact, tried to connect but it did not connect again. Removed the app from the list of recent apps. Tried again after restarting the camera and it connected.

What I do is first to connect with the phone wifi. Not via the app. Then starting the app. Sometimes it does not work and the app wants me to enter network and password. I do so but then it never works... So if it happens, I enter any password, just one letter or so, let it sit for a few second before I press the cross in the upper right corner and it connects.
It is strange to me how buggy all this is---at the end of the second decade of the 21st century! I remember reading a story about a somewhat famous photographer who began learning from an even more famous photographer. The lesson was loading film into a developing canister. First, he had to load it into the canister 100 times with the lights on. Then, 100 times with the lights off.

I don't understand why this stuff doesn't get tested more thoroughly. And if the vagaries of wifi/bluetooth connections are simply inherently iffy, then why isn't there a written description about how to trouble shoot it? Just nonsense!

02-02-2019, 06:22 PM   #24
Junior Member
DirkWitten's Avatar

Join Date: Mar 2018
Location: Ruhrgebiet / Germany
Posts: 28
Version 2.0.2 is working now tested with Pentax KP and Android 9+Sony Xperia ZX1 Compact.
Maybe it´s better to disable the updates for this application
02-02-2019, 11:08 PM   #25
Loyal Site Supporter
Loyal Site Supporter
clackers's Avatar

Join Date: Jul 2013
Location: Melbourne
Photos: Albums
Posts: 12,131
QuoteOriginally posted by DirkWitten Quote
Version 2.0.2 is working now tested with Pentax KP and Android 9+Sony Xperia ZX1 Compact.
Maybe it´s better to disable the updates for this application
What breaks is not the code of the app but the code of your Android. Those would be the updates to disable.

But then you're holding back bugfixes and new features on your phone.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
android, apk, app, connection, copy, dslr, full frame, full-frame, google, image, image sync, k-1, k1, pentax k-1, phone, sync, sync for android, thread, version
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Image Sync 1.15 available for Android rechmbrs Pentax News and Rumors 4 08-07-2017 09:58 AM
Dumb question re: no flash on android image sync in liveview Erictator Pentax K-1 4 04-17-2017 02:09 PM
Image Sync update and problems after update asahi man Pentax News and Rumors 23 03-17-2017 10:01 AM
Image Sync Android version 1.1.3 available at Google Store. rechmbrs Pentax DSLR Discussion 3 02-06-2017 12:46 PM
Image Sync update to version 1.1.2 Android and ios rechmbrs Pentax News and Rumors 34 11-23-2016 06:14 PM



All times are GMT -7. The time now is 12:13 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top