Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-01-2019, 02:22 PM   #1
Site Supporter
Site Supporter




Join Date: May 2010
Posts: 125
Please help K1 II debug mode.

Hi, after update my K1 to K1 II it has a terrífic frontfocus, most or the lens needs a -10 . How to enter in debug mode ? Thanks

02-01-2019, 02:45 PM   #2
Loyal Site Supporter
Loyal Site Supporter




Join Date: Sep 2011
Location: Nelson B.C.
Posts: 3,722
QuoteOriginally posted by pasorro Quote
Hi, after update my K1 to K1 II it has a terrífic frontfocus, most or the lens needs a -10 . How to enter in debug mode ? Thanks
I'd talk to the shop who did the update. Something likely got moved or not set up properly.

Last edited by derekkite; 02-01-2019 at 04:26 PM.
02-02-2019, 12:27 AM   #3
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 11,644
QuoteOriginally posted by derekkite Quote
I'd talk to the shop who did the update. Something likely got moved or not set up properly.
Indeed.

The upgrade should basically only involve changing a circuit board on the camera body, as one can see from the pictures below which show the whole procedure:

The Pentax K-1 upgrade service: detailed*description*of the different steps with pictures - Pentax Rumors

Aside from opening up the camera back, no camera body hardware near the lens mount or the AF assembly needs to be touched. However any AF and lens settings stored in the original K-1 camera will, of course, be lost.

My guess is that the shop took it upon themselves to do a few extra tune-ups, clean-ups and adjustments while they had the camera in front of them. This may have had an impact on how your lenses now relate to the upgraded camera body. Even if the shop just fractionally tightened up a loose screw or two on the lens mount, it could have an impact on all of your lenses.

Last edited by rawr; 02-02-2019 at 12:35 AM.
02-02-2019, 04:41 AM   #4
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 6,462
You're not the first person to notice a shift in front/back focus after the upgrade. That's all I recall. You'll have to search through the various upgrade threads to see what was done.

I could be wrong but as I recall the debug mode has been inaccessible since the K-3.

02-02-2019, 11:14 PM   #5
Site Supporter
Site Supporter




Join Date: May 2010
Posts: 125
Original Poster
QuoteOriginally posted by Not a Number Quote
You're not the first person to notice a shift in front/back focus after the upgrade. That's all I recall. You'll have to search through the various upgrade threads to see what was done.

I could be wrong but as I recall the debug mode has been inaccessible since the K-3.
Thanks.
Do you remember wich thread thread told about it? I can’t find it.
02-03-2019, 01:34 AM   #6
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 6,462
QuoteOriginally posted by pasorro Quote
Thanks.
Do you remember wich thread thread told about it? I can’t find it.
Look at any of the threads on the SDM to screwdrive conversion which requires accessing the debug mode to do the modifications. Also search on PK_TETHER or PKTETHER which is often used to enter debug mode - as I recall the K-5 family was the last model that this works with PK_Tether.

Here we go (not in an upgrade thread, but as I recall someone mentioned having to redo all their focus adjustments after upgrade elsewhere):
https://www.pentaxforums.com/forums/190-pentax-k-1/373010-k-1ii-back-focus.html#post4408434

Last edited by Not a Number; 02-03-2019 at 01:45 AM.
02-10-2019, 08:42 AM   #7
Pentaxian




Join Date: Dec 2011
Posts: 2,333
QuoteOriginally posted by pasorro Quote
How to enter in debug mode ? Thanks
Resurrecting Pentax firmware hacking - Page 9 - PentaxForums.com
post #623

That at least works for a K-1.
02-11-2019, 01:51 PM   #8
Senior Member




Join Date: Apr 2011
Location: Munich
Photos: Gallery
Posts: 176
So, no one actually knows the answer to the topic's question, i.e. how to enable Debug Mode on a K-1 II? I came here for that answer.

(Beholder3 - no, your linked solution does not appear to work on a K-1 II, not in my attempts, anyway)

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
debug, dslr, full frame, full-frame, ii, k-1, k1, k1 ii debug, pentax k-1
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! How to access debug mode on Pentax K-5 on a Mac OS X (sdm lens to screwdrive) NW_Legacy Pentax DSLR Discussion 5 11-08-2018 05:03 PM
K3-II fw 1.10 DEBUG MODE Gian Pentax K-3 10 05-04-2017 07:46 AM
Pentax K3 II debug mode. acbc Pentax K-3 5 08-17-2016 10:27 PM
Help me please ! I can not enter debug mode K20D (follow up pentaxhack$ dasboot88 Troubleshooting and Beginner Help 2 02-02-2015 09:53 AM
K-x debug mode w/pics please mlatour Troubleshooting and Beginner Help 9 01-26-2011 11:26 AM



All times are GMT -7. The time now is 11:22 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top