Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-24-2020, 12:33 AM   #1
New Member




Join Date: Oct 2017
Location: Ukraine, Mariupol
Posts: 9
The problem with switching AF / MF autofocus to K-70.

Hello! I had the following problem. The autofocus lens mode does not turn off. When I switch the switch from AF to MF mode, the lens continues to focus in automatic mode. This happens with the lens smc FA 50 f/1,7 and smc DA 18-135 DC WR. Autofocus drive does not shut off. How to solve this problem? Maybe someone has already encountered this?
Thanks!

01-24-2020, 12:39 AM   #2
Site Supporter
Site Supporter




Join Date: Jan 2019
Location: Geelong, Australia
Photos: Gallery | Albums
Posts: 315
I have not heard of this issue.
I have a K-70 however I do not own either of the lenses mentioned.
I have many lenses and have never had this issue with my K-70.
Maybe it is possible that the switch isn't working.
Does the manual/auto switch work with other lenses?
01-24-2020, 12:47 AM   #3
New Member




Join Date: Oct 2017
Location: Ukraine, Mariupol
Posts: 9
Original Poster
I only have these two lenses. I think the problem is not with the lenses.
01-24-2020, 05:22 AM   #4
Veteran Member




Join Date: Feb 2019
Posts: 1,023
It's odd especially since the FA lens is screw drive like all other FA lenses, and the DA 18-135 has an internal motor.

Take out the lens, notice where the screw drive is on the body mount, turn the AF switch on and off. The screw drive pin should go back and forth. If it's not, you probably have a defective button.

01-24-2020, 01:10 PM   #5
New Member




Join Date: Oct 2017
Location: Ukraine, Mariupol
Posts: 9
Original Poster
Yes, I did. Most likely the breakdown of the AF / MF button. I send to the service center. Thanks.
P.S. But why did she break ???
01-24-2020, 01:56 PM   #6
Veteran Member




Join Date: Feb 2019
Posts: 1,023
I know that the screw drive can be broken, for example when mounting lens with the "Ricoh pin", but that's not the case since AF do work.

When opening a body to do something like replacing the aperture solenoid one has to be extra careful with the AF button, but I'm sure you would have told us if you attempted this kind of repair.

I have no idea how this could have happened without a hard fall or body opening.
01-25-2020, 09:13 AM   #7
Site Supporter
Site Supporter




Join Date: Apr 2015
Location: Winterthur
Posts: 702
Check without lens:

If you turn the AF-M-switch, does the screwdrive move in and out of that tiny hole:


M: Screwdrive should retreat
AF: Screwdrive should poke out!


If this does not happen, the the inner part of the AF-M-switch got dislocated!
This usually happens if you or a previous owner or even a dealer who found out the solenoid was stuck repaired it but didn't take
care in aligning the external part of the AF-M-switch with the internal part.

Almost impossible that it goes out of alignment just by itself!
But sometimes the impossible becomes possible, so we never know for sure.

What puzzles me is that you have this problem with the DA18-135WR. This lens has its own DC-motor.

I only have the DA20-40WR limited which has the DC-motor as well, but in M-position the motor does not autofocus.

If the AF-M-switch doesn't move the screwdrive, then you need either send your body in for repair or, which is pretty easy, open and follow the steps in my tutorial
If this isn't the problem, I would first try out a reset.

Last edited by photogem; 01-25-2020 at 11:24 PM.
01-26-2020, 05:42 AM   #8
New Member




Join Date: Oct 2017
Location: Ukraine, Mariupol
Posts: 9
Original Poster
Thanks so much for the detailed answer!

Bertrand3000, two months ago I was repairing the diaphragm solenoid.


Last edited by Yrii; 01-26-2020 at 06:05 AM.
01-26-2020, 07:00 AM   #9
Veteran Member




Join Date: Feb 2019
Posts: 1,023
QuoteOriginally posted by Yrii Quote
Bertrand3000, two months ago I was repairing the diaphragm solenoid.
Yes, so this explains why you have problems with the AF button. Luckily, this means that it should be easily repairable.
01-26-2020, 08:37 AM   #10
New Member




Join Date: Oct 2017
Location: Ukraine, Mariupol
Posts: 9
Original Poster
Yes, I hope so.
01-26-2020, 09:36 AM   #11
Site Supporter
Site Supporter




Join Date: Apr 2015
Location: Winterthur
Posts: 702
QuoteOriginally posted by Yrii Quote
Thanks so much for the detailed answer!

Bertrand3000, two months ago I was repairing the diaphragm solenoid.
Hopefully you used the white solenoid!?
Much has been written about wrong solutions.
Opening the body too often makes the threads (plastic) weaker, so be careful
and if needed take precautions.

And if ever you chose to do the lazy sanding method, correct it and do it right!
01-26-2020, 10:49 AM   #12
New Member




Join Date: Oct 2017
Location: Ukraine, Mariupol
Posts: 9
Original Poster


The solenoid is not changed. I asked and they answered that white solenoids do not release or they are not in Ukraine. Of course, I would change the solenoid, but unfortunately there is no way.
Thanks. These are very valuable tips and I have learned a lot.
02-05-2020, 12:50 PM   #13
New Member




Join Date: Oct 2017
Location: Ukraine, Mariupol
Posts: 9
Original Poster
The problem is resolved. It was not a correctly installed AF / MF switch after assembly after repair of the solenoid. Your advice helped in solving this problem. Thanks!
Regards, Yrii.
02-05-2020, 02:01 PM   #14
Veteran Member




Join Date: Feb 2019
Posts: 1,023
That's wonderful. Enjoy your K-70 and happy shooting!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
af, af / mf, autofocus, k-70, k70, lens, mf, mf autofocus, mode, pentax k-70, smc, switch
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
For Sale - Sold: Full frame AF and MF 'A' lenses - 17-35, 18-35, 24-70, 28, 28-105, 28-200, 135,70-210 scottDee Sold Items 9 02-13-2019 06:57 AM
A rare pair! MF and MF-1 rosettaquarrier Pentax Camera and Field Accessories 12 08-31-2018 09:42 PM
Focus issues and odd auto AF / MF switching pgamble Pentax K-3 30 05-07-2014 11:54 AM
k100d MF/AF toggle switch stuck in MF summatusmentis Pentax DSLR Discussion 9 11-26-2009 03:52 PM
Help! Autofocus switch stuck on AF.S and will not autofocus! pauldiebel Pentax DSLR Discussion 3 09-19-2009 08:59 PM



All times are GMT -7. The time now is 05:08 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top