Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-20-2021, 10:10 AM   #1
Pentaxian




Join Date: Feb 2019
Posts: 1,672
Manual flash (Godox TT600) does not fire in Manual mode

Hi,

I'm discovering flash photography.

I bought a Godox TT600, which is a manual flash (no P-TTL support), mounted on the hot-shoe of my Pentax KP


The flash is fired when the KP is in Auto mode. But whatever I try to do, the flash is not fired when the KP is in M mode. I'm trying to follow the advice here : Flash Photography Camera Settings for Beginners - Improve Photography with F/8, speed 1/200,ISO 200 and Flash power set to 1/16.

I've tried several settings in the internal Flash settings in the KP, but they are probably for the internal flash.

Edit: I think I have found the solution. Reducing speed to 1/160 allowed the flash to fire. I guess 1/200 was already too fast.


Last edited by Bertrand3000; 04-20-2021 at 10:45 AM.
04-20-2021, 11:40 AM   #2
Otis Memorial Pentaxian
Loyal Site Supporter
stevebrot's Avatar

Join Date: Mar 2007
Location: Vancouver (USA)
Photos: Gallery | Albums
Posts: 39,938
QuoteOriginally posted by Bertrand3000 Quote
I guess 1/200 was already too fast.
1/180s is the X-sync speed on the KP.


Steve
04-21-2021, 06:55 PM   #3
New Member




Join Date: Sep 2020
Posts: 19
I strongly disagree with those numbers especially as the KPís sync speed isnít that high.
Try flash on manual, 1/4 power
ISO 100
Shutter 1/125
F-stop f/5.6
04-21-2021, 11:26 PM   #4
Pentaxian




Join Date: Feb 2019
Posts: 1,672
Original Poster
QuoteOriginally posted by Mastiff Quote
I strongly disagree with those numbers especially as the KPís sync speed isnít that high.
Try flash on manual, 1/4 power
ISO 100
Shutter 1/125
F-stop f/5.6
Thanks for the hint, I'll try those settings as well.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
flash, flash godox, godox, kp, mode, pentax kp, photography, settings
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K1 not firing flash with Godox Xpro-P trigger on 3 second remote mode... hoodyy Troubleshooting and Beginner Help 14 10-15-2020 07:57 AM
Radio Triggering a Godox TT600 from a TT350p Kobie Flashes, Lighting, and Studio 15 10-11-2019 06:13 PM
Godox TT600 overheats easily? Zafar Iqbal Flashes, Lighting, and Studio 4 08-31-2018 04:52 PM
Yongnuo yn585ex vs Godox tt600 vs ??? Steve Grosvenor Flashes, Lighting, and Studio 8 01-26-2018 04:32 PM



All times are GMT -7. The time now is 10:35 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top