Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-10-2021, 09:35 PM   #1
Senior Member




Join Date: Jan 2008
Location: Salt Lake City UT
Photos: Albums
Posts: 168
New phone, Theta SC2 wont connect

I recently upgraded my phone from an iPhone XR to an iPhone 13. I tried to connect my Theta SC2 to the new phone and I keep getting the message to "Check that the wireless LAN function of the camera is turned on" (it is). I tried to register the camera to the new phone and get the same message. Even through I did a full factory reset on my old phone, I was able to download the theta app again and connect instantly.

The help guide suggests to check the following: "Is the camera connected to a different smartphone?" Do I need to unregister the camera from the old phone? If so, does anyone know where?

Anyone else experience anything like this?

12-16-2021, 11:30 AM   #2
Site Supporter
Site Supporter




Join Date: May 2014
Location: Minnesota
Photos: Gallery
Posts: 1,810
Did you search for updates on the camera ?
01-11-2022, 08:04 PM   #3
Site Supporter
Site Supporter
Elroy Jetson's Avatar

Join Date: Apr 2012
Location: Eastern Ontario
Photos: Albums
Posts: 42
I'm having a similar issue with a Theta V and a Samsung S21 phone. The V worked ok in spite of irregular connection issues with my previous phone, an LG, but the Samsung (5 months old now) is completely unreliable. I've tried to connect via Wireless LAN and, while the phone indicates it has connected to the camera via wifi, the Theta phone disagrees. I may get a single still image after connecting, more often it refuses to connect even when the phone insists it has connected to the camera. The camera has the latest firmware update and I uninstalled the Ricoh Theta app and reinstalled it. Again, the phone shows the camera being connected, but the camera refuses to acknowledge the phone. Connecting the camera to the computer doesn't help as the computer says there are no image files to see. Not sure if this is an issue with the Samsung, Theta, or the app, but it looks as if my Theta V has become a paperweight.
01-11-2022, 08:23 PM   #4
Pentaxian




Join Date: Oct 2018
Location: Tokyo
Photos: Gallery
Posts: 1,255
QuoteOriginally posted by PentaxScott Quote

The help guide suggests to check the following: "Is the camera connected to a different smartphone?" Do I need to unregister the camera from the old phone? If so, does anyone know where?

Anyone else experience anything like this?
I remember having the same problem but not remember what I exactly did to make it works!
I don't think I unregister the camera from the old phone.
I remember to register the camera to the new phone by turn on the camera first, then make sure the phone Wi-Fi is connected to the camera.
Next open the app on the phone. Then the app asked me to register the camera to the phone. I used the numbers at the bottom of the camera to register and use the default password.
I will come back if I happen to remember exactly what did I do. Usually I make note for every problem I ran to, but the problem is...I don't know where is my note!

01-11-2022, 09:42 PM   #5
Senior Member




Join Date: Jan 2008
Location: Salt Lake City UT
Photos: Albums
Posts: 168
Original Poster
I eventually got the camera to connect to the new phone. I end up reinstalling every app, updating everything, and it still took several attempts to get it to connect. However, after the initial pairing/connection, it seems to connect everytime I use it without incident.

/shrug.
01-12-2022, 05:16 PM   #6
Site Supporter
Site Supporter
Elroy Jetson's Avatar

Join Date: Apr 2012
Location: Eastern Ontario
Photos: Albums
Posts: 42
Glad to hear someone got things running. I've uninstalled and reinstalled the Theta app (Google store), reregistered the camera, and the phone says the Theta is connected -- and maybe one in ten tries the phone functions properly and shows live camera images. To check the phone I've installed Image Sync and tried connecting my K-1 Mk2, but it isn't impressed with the S21 either. It seems as if the phone sees the device, connects via wifi, then the app (Theta or Image Sync) tries to reconnect to the device and crashes the show. The same phone connected to my Chevy in about 2 minutes and has been reliable as rain ever since, but that's BlueTooth. Maybe I have a wifi problem? Oh well, I was planning to go back to my film roots anyhow!
01-12-2022, 05:36 PM   #7
Pentaxian




Join Date: Oct 2018
Location: Tokyo
Photos: Gallery
Posts: 1,255
QuoteOriginally posted by Elroy Jetson Quote
... Maybe I have a wifi problem? ...
Android? It sounds like your phone try to auto connect to the Wi-Fi you often use.
There is a Wi-Fi set up in your phone when you slide from the top down, you will see wifi icon.
When you go in there, it will show you lists of available Wi-Fi. Select the Theta's Wi-Fi and select "Advance" then make sure "Auto-connect" is On.
Not sure if it can help but it is worth trying.

01-13-2022, 10:08 AM   #8
Site Supporter
Site Supporter
Elroy Jetson's Avatar

Join Date: Apr 2012
Location: Eastern Ontario
Photos: Albums
Posts: 42
QuoteOriginally posted by tokyoscape Quote
Android? It sounds like your phone try to auto connect to the Wi-Fi you often use.
There is a Wi-Fi set up in your phone when you slide from the top down, you will see wifi icon.
When you go in there, it will show you lists of available Wi-Fi. Select the Theta's Wi-Fi and select "Advance" then make sure "Auto-connect" is On.
Not sure if it can help but it is worth trying.
Thanks, tokyoscape, but I've tried that with no luck. At best the Theta will connect, capture a single image, then loses the connection. Android says the current wifi network is the Theta, but the Theta app says "Connection offline" at the same time. I've checked my K-1 Mk2 with Image Sync and it does exactly the same, so I'm guessing there's an issue with Samsung's flavour of Android. Looks as if the Theta will be taking up space in the sock drawer for a long rest and maybe a future variant of Android or a new phone will be more cooperative?
01-13-2022, 10:55 AM   #9
Loyal Site Supporter
Loyal Site Supporter
Mikesul's Avatar

Join Date: Sep 2009
Location: Phoenix, AZ
Posts: 6,933
connection with these phone apps on many cameras is sometimes a pain. My Samsung Note Ultra connects without problems to My K-1ii and K3iii. I haven't used my Theta V for a couple of months but it connected and worked well when I last used it. I doubt that the problem is Samsung. most likely there is some setting on phone or camera which is still interfering. It is a hassle to trouble shoot but you should be able to sort it out eventually.
01-13-2022, 05:05 PM   #10
Pentaxian




Join Date: Oct 2018
Location: Tokyo
Photos: Gallery
Posts: 1,255
QuoteOriginally posted by Elroy Jetson Quote
... so I'm guessing there's an issue with Samsung's flavour of Android. Looks as if the Theta will be taking up space in the sock drawer for a long rest and maybe a future variant of Android or a new phone will be more cooperative?
Another option is reset your phone to a factory setting. As you know, sometime things get messy after using electronic device for years and years. Factory reset could clear a lot of issues but it could be a hassle thing to do too! Just make sure you back up your setting and file first.
01-14-2022, 08:18 AM   #11
Site Supporter
Site Supporter
Elroy Jetson's Avatar

Join Date: Apr 2012
Location: Eastern Ontario
Photos: Albums
Posts: 42
Thanks for the suggestions. My old Samsung tablet does talk to the Theta, so the latter isn't a brick (yet). Eventually I'll retry getting the phone to behave and maybe even communicate with my K-1 MkII and K3 iii.

UPDATE: shutting down my VPN fixed the issue between the Theta and my Samsung phone. It even worked for the K-1 MkII although the K-3 iii needs some more persuading.

Thanks for your input!

UPDATED UPDATE: Got the K3 iii talking to the phone. Not sure how (it took several sessions), but it works now so I won't complain.

Last edited by Elroy Jetson; 5 Days Ago at 07:49 AM. Reason: new information
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
360, camera, iphone, message, phone, ricoh theta, spherical, theta
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Theta SC2 - Editing and Viewing options PentaxScott Ricoh Theta 360 Cameras 2 07-14-2021 01:03 AM
Ricoh Theta SC2 for Business Mistral75 Pentax News and Rumors 17 07-02-2021 08:38 AM
Theta SC2 Pictures Posted FozzFoster Pentax News and Rumors 37 06-30-2021 09:12 AM
TR-1 Bluetooth remote control (Theta Z1/V/SC2) Mistral75 Pentax News and Rumors 1 02-26-2021 02:26 AM
Ricoh Announces the Theta SC2 PF Staff Homepage & Official Pentax News 0 11-24-2019 02:20 PM



All times are GMT -7. The time now is 09:40 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top