Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-02-2021, 05:32 AM   #46
Site Supporter
Site Supporter




Join Date: Nov 2006
Location: Norway
Photos: Gallery | Albums
Posts: 607
QuoteOriginally posted by mtkeller Quote
My phone can be idle for extended periods of time without disconnecting. It seems the key is not to let your camera go to sleep for more than five minutes. Perhaps you could develop a fidgeting problem like I have and keep half pressing the shutter button?
I suppose this is phone dependent. I watched my camera's gps icon on the info screen and it places an exclamation mark next to it about 3-4 minutes after the screen on the phone turned off.

06-04-2021, 07:38 AM   #47
Unregistered User
Guest




QuoteOriginally posted by StigVidar Quote
I suppose this is phone dependent. I watched my camera's gps icon on the info screen and it places an exclamation mark next to it about 3-4 minutes after the screen on the phone turned off.
Same here. Any idea on where to find info on what the different icons mean? I cant find anything on the gps with a yellow ! next to it...
06-05-2021, 09:11 PM   #48
Site Supporter
Site Supporter




Join Date: Feb 2019
Location: Sioux City, IA
Photos: Gallery
Posts: 938
QuoteOriginally posted by Tjompen1968 Quote
Same here. Any idea on where to find info on what the different icons mean? I cant find anything on the gps with a yellow ! next to it...
I think I get that when Bluetooth is still connected but the camera is no longer receiving GPS data because Image Sync timed out for background location transmission. I will say, I’ve been using my iPhone 8 with latest iOS for a day and a half in Badlands National Park for geotagging, and it’s going very smoothly. I have run into zero of the issues that folks have been reporting here.
06-06-2021, 10:26 AM   #49
Unregistered User
Guest




QuoteOriginally posted by mtkeller Quote
I think I get that when Bluetooth is still connected but the camera is no longer receiving GPS data because Image Sync timed out for background location transmission. I will say, I’ve been using my iPhone 8 with latest iOS for a day and a half in Badlands National Park for geotagging, and it’s going very smoothly. I have run into zero of the issues that folks have been reporting here.
Probably, but it should be stated in a manual what all icons means.

06-07-2021, 03:04 PM - 1 Like   #50
Site Supporter
Site Supporter
Kobie's Avatar

Join Date: Oct 2014
Location: Bowmanville
Photos: Albums
Posts: 1,078
QuoteOriginally posted by mtkeller Quote
I think I get that when Bluetooth is still connected but the camera is no longer receiving GPS data because Image Sync timed out for background location transmission. I will say, I’ve been using my iPhone 8 with latest iOS for a day and a half in Badlands National Park for geotagging, and it’s going very smoothly. I have run into zero of the issues that folks have been reporting here.
I went out today to test an issue others have reported of geolocation timing out/loss of Bluetooth connection when turning the camera off for a bit, then back on. The phone doesn't seem to re-connect.
The little exclamation point showed up beside the satellite icon, I checked my phone first and I had lost location services. When it came back on (my phone re-gained location services) the exclamation went away.
Other than that, I had no issues turning the camera off and on. The phone always connected and geolocation was always being transmitted as long as I had Image sync running (even with the phone in my pocket in sleep mode).
08-07-2021, 08:37 AM   #51
Site Supporter
Site Supporter




Join Date: Dec 2012
Photos: Gallery | Albums
Posts: 2,531
Reviving this thread, I decided to try again with my Google Pixel I and the K-3 Mark III, with the latest updates for the ImageSync app, and firmware 1.10 on the K-3 III.

The results were... well... fiddly. And frustrating.


First I tried to connect the camera and the phone with the ImageSync app. Didn't work. It gets in an infinite loop where it says that the camera connects via WiFi, but immediately goes back to trying to connect via WiFi and fails and gives me an error message that unfortunately I didn't write down. This continues until I cancel the attempt. Using ImageSync to try to connect via Bluetooth didn't work, either. It eventually times out.

If I instead use the phone's WiFi and Bluetooth settings to connect to the camera that works. The camera indicates WiFi, Bluetooth, and GPS connections. But as soon as I go into ImageSync and hit the Camera Images icon it takes me to the action to connect to the camera (despite the fact it already is connected) and then it fails.

The one thing I could eventually get to work is to connect via the phone's apps, go into ImageSync, then go to settings and hit "synchronize time and date", that works, and then I finally went to Camera Images and it pulled the thumbnails from the camera. And it also appears that the camera is still receiving GPS coordinates from the phone after 10+ minutes. Previously, if I could get teh connection to work, the GPS would time out after less than five minutes.

So... three steps back, two steps forward, and it's still teetering on the edge of just not being worth trying. It was nice to be able to pull some photos from camera to phone over vacation when I had time to sit and fiddle with it for 15 or 20 minutes. But it is still very far from seamless. At least with my phone.
08-07-2021, 12:22 PM   #52
Loyal Site Supporter
Loyal Site Supporter




Join Date: Jul 2021
Location: Zuiderkempen - Grote Netewoud - Belgium
Photos: Gallery | Albums
Posts: 538
Interesting thread. Didn't realise image sync also sync'ed gps & time.
One of the reasons I did buy the K3 II was because of the GPS for travel logging. Before I took sometimes extra smartphone pictures alongside my dslr just to have gps data...

So I was bit disappointed that the newer bodies missed it.
For my needs a simple gps solution is sufficient, I don't need astrotracing accuracy...

---------- Post added 08-07-21 at 12:33 PM ----------

Interesting thread. Didn't realise image sync also sync'ed gps & time.
One of the reasons I did buy the K3 II was because of the GPS for travel logging. Before I took sometimes extra smartphone pictures alongside my dslr just to have gps data...

So I was bit disappointed that the newer bodies missed it.
For my needs a simple gps solution is sufficient, I don't need astrotracing accuracy...
Maybe a smaller, cheaper gps in the camera and an external o-gps for astrotracing would be more efficient in product positioning?
Or this image sync solution.
Probably cheaper but with drawbacks (battery, connection...)

08-07-2021, 04:31 PM   #53
Site Supporter
Site Supporter
RGlasel's Avatar

Join Date: Sep 2013
Location: Saskatoon
Photos: Gallery | Albums
Posts: 3,139
QuoteOriginally posted by mlag Quote
For my needs a simple gps solution is sufficient, I don't need astrotracing accuracy...Maybe a smaller, cheaper gps in the camera and an external o-gps for astrotracing would be more efficient in product positioning?Or this image sync solution.Probably cheaper but with drawbacks (battery, connection...)
Not only cheaper, but much, much easier to implement. Implementing the new optical viewfinder with a larger prism meant that the GPS unit couldn't be carried over from the K-3ii in the same place. Which meant that including a GPS unit in the K-3iii would require several changes to the overall design of the camera and a new APS-C "flagship" model was already 4 years late. The cost of a GPS module is insignificant compared to the cost of a major redesign to incorporate it, especially for a complex product that might not reach 250,000 units in sales before it is obsolete. Conversely, implementing an existing feature in software is relatively cheap and easy to incorporate, so any Pentax model with IBIS and a built-in GPS module is certain to include the astrotracing function.
10-26-2021, 07:22 AM   #54
Junior Member




Join Date: Nov 2019
Posts: 27
Another one having problems. Only getting GPS on the first few photos, and the same lat/lon on them all.

To try to fix it I've flashed the firmware in the K3 iii, unpaired it from my phone, deleted the app from the Android 11 phone and reinstalled it. I've set the transmission time to 'unlimited' and turned off battery optimisation for Image Sync.

I've re-paired the camera & phone, need to go for a short walk to test but right now it's drizzling and nasty outside.

Image Sync (or maybe the K3 iii firmware or even both!) seems horribly flaky software. Also I have a feeling it *was* OK some time back once I'd set the transmission time, but since then there have of course been some Android updates and I didn't do much photography over the summer.
10-26-2021, 08:08 AM   #55
Site Supporter
Site Supporter




Join Date: Dec 2012
Photos: Gallery | Albums
Posts: 2,531
I'm upgrading my phone for the first time in five years this week, getting a new Pixel 6. Interested to see if the phone pairing and sync works any better than with the Pixel 1. With some of the recent updates to ImageSync I can usually get it to work with the old phone, but it's still fiddly and a multi-step process, often requiring re-tries. All I usually want to do it tag the photos with the location of the soccer field I'm shooting from, but at least half the time I don't bother unless I have some time to kill before kickoff.
10-28-2021, 03:32 AM   #56
Junior Member




Join Date: Nov 2019
Posts: 27
QuoteOriginally posted by fifescapes Quote
Another one having problems. Only getting GPS on the first few photos, and the same lat/lon on them all.

To try to fix it I've flashed the firmware in the K3 iii, unpaired it from my phone, deleted the app from the Android 11 phone and reinstalled it. I've set the transmission time to 'unlimited' and turned off battery optimisation for Image Sync.

I've re-paired the camera & phone, need to go for a short walk to test but right now it's drizzling and nasty outside.

Image Sync (or maybe the K3 iii firmware or even both!) seems horribly flaky software. Also I have a feeling it *was* OK some time back once I'd set the transmission time, but since then there have of course been some Android updates and I didn't do much photography over the summer.

Right I *think* I have fixed this:
  1. Updated the camera's firmware
  2. Deleted & reinstalled phone app
  3. Set transmission time & no battery optimisation for the app
  4. Re-paired camera & phone

I suspect deleting & reinstalling the app was the crucial step.

I need to do a better test but as it's decidedly dreich here that will have to wait.
10-31-2021, 03:37 AM   #57
Pentaxian
angerdan's Avatar

Join Date: Feb 2015
Photos: Gallery | Albums
Posts: 2,303
QuoteOriginally posted by ThorSanchez Quote
Hmmm... I suppose this is good. I need to remember all the steps it took to get here and write a work instruction.
User tomcook did write an Image Sync Instruction and uploaded it as PDF here
K-3 III and Image Sync Instructions - PentaxForums.com
12-24-2021, 08:55 AM   #58
Site Supporter
Site Supporter
jerryleejr's Avatar

Join Date: Aug 2011
Location: TN
Posts: 772
Original Poster
Glad to see such great info... I appreciate it
12-24-2021, 08:25 PM   #59
Pentaxian
Weevil's Avatar

Join Date: May 2012
Location: Near Montréal, Québec
Photos: Gallery
Posts: 4,039
in my case, i paired in Image sync with bluetooth on a Samsung SA8, now a A51, and it works flawlessly as long as I launch the app on the phone, and reconnect automatically the next time.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
android, app, aps-c, bluetooth, camera, connection, coordinates, dslr, gps, gps via phone, icon, image, information, k-3 iii, k-3 mark 3, location, minutes, pair, phone, screen, smartphone, sync, time, wifi, yes
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can Pentax camera connect a phone via micro-usb for monitoring with app ? Ransome Pentax DSLR Discussion 1 07-13-2020 09:57 PM
Night Via Lactea desde La Higuera / Via Lactea from La Higuera mauriciohr Post Your Photos! 11 01-08-2020 02:37 AM
Any suggestions for a light meter phone app? ismaelg General Photography 5 07-28-2019 02:49 PM
Pentax KP and GPS via phone? mgvh Pentax KP 5 03-28-2019 07:54 PM
NEW PRODUCT: Canon, Olympus, and Nikon unveil App-e-ture: the app store for your digi johnmflores Canon, Nikon, Sony, and Other Camera Brands 3 04-06-2010 10:58 PM



All times are GMT -7. The time now is 10:20 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top