Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-12-2010, 06:15 PM   #1
Pentaxian
amoringello's Avatar

Join Date: May 2008
Location: Virginia, USA
Photos: Gallery
Posts: 1,536
Remote trigger not working in K7/K5 hotshoe?

Anyone use a remote flash trigger and have it not respond or intermittently respond when in the hotshoe of the K7 or K5?

If I use a sync-cable the remote works 100% of the time.
In the hotshoe, I get as little as one out of ten working.

Specifically I have the Elinchrom Skyport remote triggers. I've tried with multiple triggers, and same issue with both my K7 and K5.
I also see this behavior with the cheap eBay Cactus trigger.

Never had an issue with the K10D.

Any ideas what Pentax changed and how the two options could behave differently? I would figure that the center post was connected to the sync port. But obviously it is on a separate circuit.

More importantly; Anyone else see this "problem" with other triggers such as Pocket Wizards?

11-14-2010, 05:53 PM   #2
Veteran Member
creampuff's Avatar

Join Date: May 2007
Location: Singapore
Photos: Gallery
Posts: 3,955
I'm using Elinchrom Skyports on my K-5 with no issues.
11-14-2010, 06:22 PM   #3
Site Supporter
Site Supporter
wizofoz's Avatar

Join Date: Apr 2009
Location: Melbourne, Outer east.
Photos: Gallery | Albums
Posts: 1,665
I occasionally have a problem with pocket wizards when attending workshops. I think the problem is a physical one. The Pentax hot-shoe seems to be very slightly 'tighter' than that of other makes. Sometimes the contacts on the trigger and HS are not making a circuit. A little wiggling of the trigger usually solves the problem.
12-09-2010, 08:16 AM   #4
Veteran Member




Join Date: Jan 2009
Location: London
Posts: 537
Same here

https://www.pentaxforums.com/forums/pentax-k-5-forum/125338-k5-metz-45-flash.html

12-09-2010, 10:33 AM   #5
Veteran Member




Join Date: Sep 2006
Location: WV
Posts: 1,495
No issues with CyberSyncs.
12-09-2010, 11:59 AM   #6
Pentaxian




Join Date: Feb 2009
Location: Alameda, CA
Posts: 3,205
I have no problem with K7 or K10D + Yongnuo 602.
12-09-2010, 05:47 PM   #7
Pentaxian
eccs19's Avatar

Join Date: Jul 2008
Location: Lisle, Ontario
Photos: Gallery
Posts: 1,500
I use cheapo E-bay ones on my K7, and so far no issues. (knock on wood) I would suggest playing around with where is sits in the shoe. Maybe the contacts are just not quite aligned very well. Maybe with it NOT seated in all the way, you will have better luck. Something to try regardless.
12-09-2010, 06:31 PM   #8
Veteran Member
pop4's Avatar

Join Date: Aug 2007
Location: YMML
Photos: Gallery
Posts: 1,877
I use the Yongnuo RF-602 wireless triggers with by my K10D and K-7, and have never noticed an issue either...

12-14-2010, 03:50 AM   #9
Veteran Member




Join Date: Jan 2009
Location: London
Posts: 537
Is that at 1/180?
12-14-2010, 06:55 AM   #10
Veteran Member
pop4's Avatar

Join Date: Aug 2007
Location: YMML
Photos: Gallery
Posts: 1,877
QuoteOriginally posted by peterh337 Quote
Is that at 1/180?
Whoops, I meant in terms of triggering. I get 100% at 1/125th. I've got a detailed results of my testing with the RF-602s here: https://www.pentaxforums.com/forums/pentax-camera-field-accessories/69648-rf-...ml#post1123488
12-14-2010, 08:02 AM   #11
Veteran Member




Join Date: Jan 2009
Location: London
Posts: 537
OK, I have now read that - thank you.

Completely bizzare work-arounds.

And none of these solutions provide TTL flash, do they? The only way to get TTL is with one of the two (pricey) Pentax units, or a 3rd party flash (Metz, etc) whose firmware needs updating every 2 weeks

I just want a solution for triggering my old Metz 45 CL-something. It worked fine with this radio trigger, with the *ist and K200D but doesn't work with the K5.
12-14-2010, 04:46 PM   #12
Veteran Member
pop4's Avatar

Join Date: Aug 2007
Location: YMML
Photos: Gallery
Posts: 1,877
QuoteOriginally posted by peterh337 Quote
And none of these solutions provide TTL flash, do they? The only way to get TTL is with one of the two (pricey) Pentax units, or a 3rd party flash (Metz, etc) whose firmware needs updating every 2 weeks
I can't speak for the Elinchroms or the Cybersyncs, but the RF-602 triggers don't do TTL, they basically send a "trigger" signal.

QuoteOriginally posted by peterh337 Quote
I just want a solution for triggering my old Metz 45 CL-something.
Do you know the triggering voltage of your old flash? I read on the other thread that you ordered RF-602s, just note that the RF-602s do not like high trigger voltages and you could possibly fry the receivers.
12-15-2010, 02:28 AM   #13
Veteran Member




Join Date: Jan 2009
Location: London
Posts: 537
There was a particular (early) version of the Metz 45 which used a high voltage for the trigger circuit, and this would damage most cameras today. It worked OK with the old mechanical cameras which used a simple switch contact for the trigger.

That is not the version I have though, and mine works fine with a direct cable (no radio) connection to all other cameras I have, including the K5.

It's just that a radio link is less hassle than a cable if the flash is remotely located, obviously. My son does a lot of action photography and he can't really use cables.
12-16-2010, 01:03 PM   #14
Veteran Member




Join Date: Jan 2009
Location: London
Posts: 537
I've tested the RF602 here.
09-02-2011, 03:46 PM   #15
New Member




Join Date: Dec 2009
Location: Toronto
Posts: 8
I have the same issue with k7 but K10 is just fine
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
hotshoe, issue, k5, k7, triggers, tripod
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K7 maximum allowed hotshoe trigger voltage Sakura Pentax DSLR Discussion 16 08-15-2010 07:55 AM
K7 - Max external flash hotshoe trigger voltage mppuser Pentax DSLR Discussion 1 08-14-2010 09:14 AM
K-m remote trigger! PentaxPZ Pentax DSLR Discussion 3 09-26-2009 12:21 PM
Radio Trigger and AF540FGZ - Not working Peacekeeper Flashes, Lighting, and Studio 5 07-02-2009 05:54 PM
Hotshoe flash trigger. Amund Pentax DSLR Discussion 3 11-25-2006 07:13 PM



All times are GMT -7. The time now is 09:31 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top