Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-04-2008, 05:17 PM   #1
Forum Member




Join Date: Aug 2007
Location: Sydney Australia
Photos: Gallery
Posts: 73
AF-54FGZ Missing TTL Mode

Suddenly I seem to be missing the second mode on the flash gun.

All I can see in the LCD as I cycle through the modes are:
P-TTL
A
M
SB

I used to see TTL as the second choice.

Anyone else have this problem?

Rusty

02-04-2008, 06:28 PM   #2
New Member




Join Date: Nov 2007
Location: Canada
Posts: 4
QuoteOriginally posted by Rusty Quote
Suddenly I seem to be missing the second mode on the flash gun.

All I can see in the LCD as I cycle through the modes are:
P-TTL
A
M
SB

I used to see TTL as the second choice.

Anyone else have this problem?

Rusty
I just bought the AF-540FGZ, received it yesterday - it has the same cycle as you are describing - no TTL.
02-04-2008, 06:44 PM   #3
Veteran Member




Join Date: Jun 2007
Photos: Gallery
Posts: 597
I see the same when I cycle throug the modes, however TTL comes out when the flash is not inserted properly...
02-04-2008, 06:50 PM   #4
Forum Member
wiseman's Avatar

Join Date: May 2007
Location: Peachtree City, Georgia
Photos: Gallery | Albums
Posts: 94
I have just gotten the AF360FGZ but they should be fairly similar.

I believe that on a K10D there is no TTL. It uses the "more advanced (?)" P-TTL mode. When you manually place the flash in TTL it will revert to P-TTL when the camera meter is activated. Refer to footnote *1 below table 2 on page 21 of the manual.

If you were to put it on an older camera ( I have a ZX-5n this works on) you will see the mode switch automatically to the TTL mode.

The AF360FGZ manual is tough reading. It does not even refer to the K10D. I am assuming that wherever the *ist is mentioned the K10D also applies.

Hope this is of some help to you.

02-04-2008, 07:10 PM   #5
Forum Member




Join Date: Aug 2007
Location: Sydney Australia
Photos: Gallery
Posts: 73
Original Poster
I found the answer in the online brochure.

TTL Auto Flash (A-TTL)

The fl ash is controlled by the amount of light refl ected off
the fi lm surface during fl ash exposure, automatically
controlling the fl ash output to assure correct exposure.
This mode of operation functions with all PENTAX autofocus
cameras (excluded MZ-S and digital SLR),

Now why didn't the manual spell that out?

Rusty
02-05-2008, 07:35 AM   #6
Site Supporter
Site Supporter
dave kitson's Avatar

Join Date: Sep 2006
Location: Lichfield, UK
Photos: Gallery | Albums
Posts: 481
QuoteOriginally posted by Rusty Quote
Suddenly I seem to be missing the second mode on the flash gun.

All I can see in the LCD as I cycle through the modes are:
P-TTL
A
M
SB

I used to see TTL as the second choice.

Anyone else have this problem?

Rusty
I think it's normal.

Mine does the same on a *istD or K10 but if I mount it on an older camera (Z1P or LX) it shows TTL instead of P-TTL.

dave
02-05-2008, 11:17 AM   #7
Inactive Account




Join Date: Jul 2007
Location: London
Posts: 1,067
Hi Rusty

Re your observation:
QuoteQuote:
Now why didn't the manual spell that out?
If only I had a for every time I've read that phase, I'd be a VERY rich man !! It seems incumbent upon those geniuses who compile such instruction booklets, to make them as dense and impenetrable as humanly possible !

Best regards
Richard
02-07-2008, 06:29 PM   #8
Pentaxian
Lowell Goudge's Avatar

Join Date: Jan 2007
Location: Toronto
Photos: Gallery | Albums
Posts: 15,450
QuoteOriginally posted by Rusty Quote
Suddenly I seem to be missing the second mode on the flash gun.

All I can see in the LCD as I cycle through the modes are:
P-TTL
A
M
SB

I used to see TTL as the second choice.

Anyone else have this problem?

Rusty
Rusty

The answer is simple, and the answer you found on the internet is incorrect.

The flash is capable of functioning in TTL mode on camera bodies that support TTL, AND are using lenses which do NOT have AE setrting, or lenses which have had the apature ring taken out of AE. This includes the *istD and *istDS.

I have both a K10D and *istD, and both AF500FTZ and AF540FGZ flashes.

The AF540FGZ automatically switches from P-TTL to TTL mode on kmy *istD when I put a Kmount lens on the camera. The flash mode is controlled by the camera not the flash.

If you have any other DSLR since there is no exposure sensor to read reflected light off the CCD TTL is not available.

The AF540 FGZ is an excellent flash because it will work in any mode any pentax camera supports, and does so automatically

The AF500FTZ is also an excellent flash, but will only work on the *istD and DS because the flash does not support P-TTL, on any other DSLR, the AF500FTZ flash will only work in manual mode

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
mode, tripod, ttl
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there a way I can turn p-TTL off or manually override it in a mode other than M? ismaelg Pentax DSLR Discussion 10 04-15-2010 10:51 AM
AF540FGZ in TTL mode Nick SD Flashes, Lighting, and Studio 6 11-09-2009 09:15 PM
TTL mode with AF-540FGZ flash gun tsmself Flashes, Lighting, and Studio 3 05-12-2009 07:24 PM
P-TTL in M mode stanjo Pentax DSLR Discussion 5 12-15-2007 02:34 AM
underexposed shots at P-TTL mode feiron Pentax Camera and Field Accessories 10 06-28-2007 09:05 PM



All times are GMT -7. The time now is 08:09 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top