Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-13-2016, 06:56 PM   #1
Pentaxian
Thagomizer's Avatar

Join Date: Jun 2014
Location: London Ontario
Posts: 1,926
Anyone use a Snapshot Tech Aus remote?

Hi all;

I've come across this aftermarket remote on the 'bay, and was wondering about it:

Wireless Remote Control FOR Pentax K 3 K 5 K 30 Q K 50 K 7 K R K X K20D O RC1 F | eBay


I can't find anything about this. Has anyone had any experience with one of these? How does it care with other remotes, OEM and otherwise?

Thanks,

Bruce

05-13-2016, 08:38 PM   #2
Site Supporter
Site Supporter




Join Date: Mar 2013
Location: Sth West Western Australia
Posts: 688
I have been using one of these for the last couple of years and it has done the job for me. I also have a Pentax remote E but I use this one as it is easier to hold
and operate. Good cheap remote.
05-13-2016, 09:13 PM   #3
Pentaxian
Thagomizer's Avatar

Join Date: Jun 2014
Location: London Ontario
Posts: 1,926
Original Poster
Thanks!
05-13-2016, 11:53 PM   #4
Veteran Member
p38arover's Avatar

Join Date: Mar 2012
Location: Western Sydney, Australia
Photos: Gallery | Albums
Posts: 3,084
Hmm, never heard of them. I'll buy one.

Edit: bought one.


Last edited by p38arover; 05-14-2016 at 04:01 AM.
05-14-2016, 03:52 AM   #5
Senior Member




Join Date: May 2012
Location: Sunshine Coast
Photos: Gallery
Posts: 113
Yep looks good, me too.
05-26-2016, 01:11 AM   #6
Loyal Site Supporter
Loyal Site Supporter




Join Date: Jan 2009
Location: Perth, Western Australia
Posts: 918
I've just bought one of these for my K30/50 and have been testing it to make sure it works. Firing the shutter is fine but when I press the blue AF button, nothing happens. I assume if it was working correctly I'd hear the whirring of the screw drive in the lens as it focussed like it would normally. I've set the menu to yes for AF with remote control. Do I need to do something else or could I have a dud unit?
05-30-2016, 03:57 PM   #7
Veteran Member
p38arover's Avatar

Join Date: Mar 2012
Location: Western Sydney, Australia
Photos: Gallery | Albums
Posts: 3,084
Mine operates the AF.

Is the camera set to MF?

05-30-2016, 05:07 PM   #8
Loyal Site Supporter
Loyal Site Supporter




Join Date: Jan 2009
Location: Perth, Western Australia
Posts: 918
QuoteOriginally posted by p38arover Quote
Mine operates the AF.

Is the camera set to MF?
The camera settings were all fine and I tested it with a couple of bodies and got the same result each time. I've been in touch with the seller and they are sending another one no questions asked.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
snapshot tech aus, tripod
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cheapest, easiest, simplest way to use a remote flash? Dewman Flashes, Lighting, and Studio 18 02-11-2016 09:50 AM
does anyone ever use a LCD screen protector? lgbalfa Pentax K-30 & K-50 20 10-03-2015 12:48 PM
Anyone recommend a cheap remote? chiane Pentax K-01 9 01-24-2013 06:55 PM
Anyone use a HEPA blower? GibbyTheMole Pentax Camera and Field Accessories 5 01-03-2013 03:29 PM
Anyone use a Pentax LX for professional use ? lesmore49 Pentax Film SLR Discussion 26 04-14-2010 08:49 PM



All times are GMT -7. The time now is 05:11 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top