Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-24-2016, 10:11 AM   #1
Pentaxian
zman's Avatar

Join Date: Sep 2009
Location: Western NY
Photos: Albums
Posts: 489
freeze up with this combination ...

Maybe someone can help me with this concern. I have a Sigma 120-400mm F4.5-5.6 DG APO OS HSM lens. When I mount it on my K5 it works perfectly. My problem is that when I add a Sigma APO x1.4 or x2 EX teleconverter the combination locks up and freezes my K5. No controls work and I have to remove the battery to get the camera going again.

The Sigma site states the lens and tele combo is compatible with the exception of the loss of AF. If it matters, the K5 is set to aperture priority. This has happened the three times I have attempted this combo, and fear to play around because I may cause permanent damage to something.

Thanks again for any suggestions.

11-24-2016, 10:13 AM   #2
Site Supporter
Site Supporter
sergysergy's Avatar

Join Date: Jan 2011
Posts: 2,782
What about other combos? Are the contacts clean?
11-24-2016, 10:26 AM   #3
Pentaxian
zman's Avatar

Join Date: Sep 2009
Location: Western NY
Photos: Albums
Posts: 489
Original Poster
QuoteOriginally posted by sergysergy Quote
What about other combos? Are the contacts clean?
The K5 and Sigma teles work perfectly with my Sigma 70-200mm f2.8 APO EX lens. The contacts all look great on all the equipment.
11-24-2016, 10:31 AM   #4
Site Supporter
Site Supporter
sergysergy's Avatar

Join Date: Jan 2011
Posts: 2,782
That is weird. The only thing I can think of is that either the HSM or the OS are making something fail.

11-24-2016, 11:20 AM   #5
Pentaxian
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 11,189
Hm, did you search the forums for threads about Sigma TC problems? I never used one, but I seem to remember that some people had problems with certain combos before.

But yeah, only advice I can give is to make sure contacts are clean and undamaged (and that SD card slot, battery slot are free of dust), that battery is full, that firmware is updated to latest one. Disable SR and any optical stabilizations (and never use both at the same time; it is one or the other). Hope someone else can chime in. Maybe you can edit the thread title so it mentions Sigma TC?
11-24-2016, 11:41 AM   #6
Tas
Site Supporter
Site Supporter




Join Date: Aug 2013
Location: Brisbane, QLD
Photos: Gallery | Albums
Posts: 1,848
I've not used my K5 in a few months but I recall it would not release the shutter for manual focus lenses when the AF/MF switch was set to either of the AF settings. The fact that you don't have the problem when using the TC with the 70-200 suggests this is not the issue but thought I'd mention it in case it is.

Tas
11-25-2016, 03:59 AM   #7
Pentaxian
zman's Avatar

Join Date: Sep 2009
Location: Western NY
Photos: Albums
Posts: 489
Original Poster
Thanks for all suggestions. I emailed Sigma technical support and will post their reply in case anyone is curious.
11-28-2016, 01:20 PM   #8
Pentaxian
zman's Avatar

Join Date: Sep 2009
Location: Western NY
Photos: Albums
Posts: 489
Original Poster
QuoteOriginally posted by zman Quote
Thanks for all suggestions. I emailed Sigma technical support and will post their reply in case anyone is curious.
Well, I received my email response from Sigma Technical Services. Certainly direct and to the point. "Thank you for contacting Sigma USA. The tele converter should not be used with your lens. " OK then, I guess that's it.

11-28-2016, 03:43 PM   #9
Pentaxian
zman's Avatar

Join Date: Sep 2009
Location: Western NY
Photos: Albums
Posts: 489
Original Poster
QuoteOriginally posted by zman Quote
Well, I received my email response from Sigma Technical Services. Certainly direct and to the point. "Thank you for contacting Sigma USA. The tele converter should not be used with your lens. " OK then, I guess that's it.
Hmm, just received a second email from Sigma Technical Support with much more of a detailed answer :

" Sigma never made an “HSM” compatible Tele-converter for HSM lenses. Your Tele-converters are most probably made for “Screw drive AF”( Non-motorized ) lenses.

Makes sense now.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
apo, combination, combo, k5, lens, sigma, tripod
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
645Z Freeze Up Requiring A Battery Pull r2studios Pentax Medium Format 13 03-22-2015 12:46 PM
Setting up K30 User modes - is this combination possible? carlb Pentax K-30 & K-50 2 11-08-2014 09:53 PM
Sony A7R + Canon glass combination, killer combination LFLee Non-Pentax Cameras: Canon, Nikon, etc. 15 02-26-2014 03:36 PM
K-5 fix for shutter freeze up. garyk Pentax K-5 4 05-28-2011 04:02 AM
November 2008 Runner-Up: Freeze Frame mtnbearhug Winners' Showcase 4 12-31-2008 02:32 PM



All times are GMT -7. The time now is 06:55 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top