Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-26-2011, 10:13 PM   #1
New Member




Join Date: Mar 2011
Posts: 5
Hello!

Hey everyone,

I'm a new Pentax user from Pittsburgh, PA after snagging one of the deals from Buydig.com. I bought the K-x with the 2 lens kit. However, the first one came with the LCD screen not working. They were able to exchange it but I just found out that this new one does not have a working macro mode, meaning I cannot select it, it just goes to moving object mode immediately. I know that this feature is irrelevant with aperture control mode, but what do you guys think, should I go for another RMA and exchange it, return it, or just live with it?

03-26-2011, 10:45 PM   #2
Arn
Loyal Site Supporter
Arn's Avatar

Join Date: Feb 2011
Location: Vancouver
Photos: Gallery | Albums
Posts: 3,753
Hi, and welcome. I figure that since you paid the money, make sure you are happy with what you got. So, what would make you happy? (I'd ask for one that works as it should.) Other than that, get out there and take pictures - we'd love to see some shots of Pittsburgh.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
exchange, mode
Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -7. The time now is 12:32 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top