Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
04-05-2011, 02:03 AM   #1
New Member




Join Date: Apr 2011
Location: Beaumont, NSW
Posts: 8
Hi from Kangaroo Valley

Have a K10D and just purchased Pentax DA 18-135mm. The AF mode doesn't seem to work. Anyone have suggestions as to why?

04-05-2011, 02:39 AM   #2
Site Supporter
goddo31's Avatar

Join Date: Feb 2009
Location: Perth, Western Australia
Photos: Gallery | Albums
Posts: 2,295
QuoteOriginally posted by Davo Quote
Have a K10D and just purchased Pentax DA 18-135mm. The AF mode doesn't seem to work. Anyone have suggestions as to why?
Hi Davo and welcome.

Ideally your question belongs in the beginners section, but I have an idea so I'll try and help

Do you know what the firmware version of your K10 is? You can find this out by holding down the menu button as you turn the camera on (I don't actually have a K10 but I think this should be universal).
Anyway, apparently support for the silent focusing motors on some of the newer lenses was implemented by firmware part way through the K10's life. Check on the Pentax.jp website to see if there is a newer firmware version and give it a go.

I'm also saying this because I don't think the new 18-135 has support for the 'screw drive' motor. Don't take my words as 100% truth please, I'm just relaying what I have read. But maybe it will get you started.

cheers,
Jason
04-05-2011, 03:37 AM   #3
New Member




Join Date: Apr 2011
Location: Beaumont, NSW
Posts: 8
Original Poster
Thanks Jason. Got it all sorted with an update of the firmware and all working. Davo
04-05-2011, 04:17 AM   #4
Ash
Community Manager
Loyal Site Supporter
Ash's Avatar

Join Date: Mar 2007
Location: Toowoomba, Queensland
Photos: Gallery | Albums
Posts: 22,679
G'day mate and welcome here.
Good to see you were sorted out pretty quickly with your issue.
Hope you stick around with us. Lots of Aussies here you know.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nature Willy Wagtail riding Kangaroo bubblesT Post Your Photos! 10 04-16-2010 11:54 PM
Cityscape Kangaroo Point - Troubled Skies dosdan Post Your Photos! 5 12-15-2009 11:48 AM
Nature Eastern Grey Kangaroo - last with the K10D kev.pride Post Your Photos! 3 12-09-2009 07:58 AM
Kangaroo Point - Sunrise over the City dosdan Post Your Photos! 7 06-13-2008 03:37 PM
G'day from Kangaroo Island Wombat Welcomes and Introductions 9 05-26-2008 09:26 AM



All times are GMT -7. The time now is 04:26 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top