Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-26-2012, 10:00 AM   #1
New Member




Join Date: Oct 2012
Photos: Albums
Posts: 5
battery problem

Hi can anyone help me i have a Pentax K Super 100 and sometimes usually at an important shoot the batteries which are new keep saying deleted and they are new ones then if i turn the camera off i can grt another one or two pictures but it drives me mad any ideas whats causing this problem
Sue

10-26-2012, 10:45 AM   #2
Veteran Member
westmill's Avatar

Join Date: Jan 2012
Location: Stoke on Trent
Photos: Gallery | Albums
Posts: 1,146
It may sound silly.... but.... are you sure they are charging ? Ive known this happen once when I used a none genuine battery. The battery simply was not charging even though I got a green charged indicator !
10-26-2012, 11:40 AM   #3
Arn
Loyal Site Supporter
Arn's Avatar

Join Date: Feb 2011
Location: Vancouver
Photos: Gallery | Albums
Posts: 3,739
Welcome to the forum, Sue. You may get more response if you post your question in the troubleshooting section - General Technical Troubleshooting - PentaxForums.com. Good luck!
10-26-2012, 11:46 AM   #4
Loyal Site Supporter
paulh's Avatar

Join Date: Sep 2010
Location: DFW Texas
Photos: Gallery | Albums
Posts: 12,900
Welcome to the forums. What kind of batteries are you using? I use Eneloop rechargeable AAs in my K100D & they work very well. I would recommend those or similar for yours as well. Regular alkalines don't work very well, or last very long. Good luck.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K5 battery problem? TylerD Troubleshooting and Beginner Help 10 09-08-2012 12:05 PM
Help with battery problem on K-x photolady95 Pentax DSLR Discussion 19 04-04-2012 04:26 PM
K-x Battery Depletion Problem gut1kor Pentax K-r 22 07-19-2011 08:05 AM
Battery Grip AA problem! Blanco Pentax K-5 10 12-02-2010 02:29 PM
K-5 battery problem? camera problem? user problem? imtheguy Pentax K-5 39 11-03-2010 06:02 PM



All times are GMT -7. The time now is 03:07 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top