Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-02-2013, 10:30 PM   #1
Site Supporter




Join Date: Jan 2013
Photos: Gallery
Posts: 7
Hi, this is 4karats from Calgary, Canada

Hi, I am new.

02-02-2013, 11:51 PM   #2
Loyal Site Supporter
eaglem's Avatar

Join Date: Feb 2009
Location: Perth Western Australia
Photos: Gallery
Posts: 27,073
Welcome to the forum ,happy you could join us here.
02-03-2013, 01:18 AM   #3
Site Supporter




Join Date: Jan 2013
Photos: Gallery
Posts: 7
Original Poster
Two Pentax FA* lens died within 1 hour apart when connected to K5 II

I was so happy with my Pentax K-5 II which I bought for myself in Christmas, 2012. Looked into Google; found lots of good comments about Pentax FA* 85mm f1.4, so I looked for it and found one from Japan. I used it for one month. Beautiful pictures. Then I bought another FA* lens; this one is FA* 28-70mm f2.8. Used it for several weeks, no problem, the power zoom is noisy but fast.

Tonight, suddenly the FA* 28-70 2.8 could not auto focus. The indicator in the camera only shows MF not AF-C. Nomatter what I do, I got only MF indication. So I replaced the lens with FA* 85 1.4, took one shot, no problem with auto. Then replaced the FA* 85 1.4 with the FA* 28-70 2.8, the MF didn't go away. So I replaced it with FA* 85 1.4 a second time. You know what. The FA* 85 1.4 died the same way as the FA* 28-80 2.8. No auto focusing any more. Only MF indication comes up, nomatter what I do.

I am sad. Please help.
02-03-2013, 01:46 AM   #4
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 42,392
QuoteOriginally posted by 4karats Quote
I was so happy with my Pentax K-5 II which I bought for myself in Christmas, 2012. Looked into Google; found lots of good comments about Pentax FA* 85mm f1.4, so I looked for it and found one from Japan. I used it for one month. Beautiful pictures. Then I bought another FA* lens; this one is FA* 28-70mm f2.8. Used it for several weeks, no problem, the power zoom is noisy but fast.

Tonight, suddenly the FA* 28-70 2.8 could not auto focus. The indicator in the camera only shows MF not AF-C. Nomatter what I do, I got only MF indication. So I replaced the lens with FA* 85 1.4, took one shot, no problem with auto. Then replaced the FA* 85 1.4 with the FA* 28-70 2.8, the MF didn't go away. So I replaced it with FA* 85 1.4 a second time. You know what. The FA* 85 1.4 died the same way as the FA* 28-80 2.8. No auto focusing any more. Only MF indication comes up, nomatter what I do.

I am sad. Please help.
Luckily, screwdrive AF doesn't just "die" like SDM does There's probably a loose connection between the camera and the lens. Try cleaning the contacts and see if that helps. If you have another Pentax body, try testing both lenses as I bet they'll work!

I have the 85mm also and it's definitely a great lens!


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

02-03-2013, 02:39 AM   #5
Site Supporter




Join Date: Jan 2013
Photos: Gallery
Posts: 7
Original Poster
Adam, thank you for your reply. I have 2 other lens: (1) a Pentax FA 50mm f1.4 (2) a Tokina AT-X AF 400mm f5.6 with Pentax mount. I tried both before I posted for help an hour ago. They worked like a charm in auto, and I can see the AF-C indication that showed up in the camera. But when I mounted the FA* 85 1.4, only MF indication shows up. Same with the FA* 28-70 2.8 lens. Tomorrow, I am going to bring the faulty (?) lens to a Pentax dealer at London Drugs, to try mounting on a Pentax camera of a different model, say K-30, and see if the lens can give me auto function. BTW, please read my comments on K5 II at Amazon.ca. The camera is so new that I was the only one posting comments there.
02-03-2013, 12:42 PM   #6
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 32,225
Welcome to the forum, that sounds just too much of a coincidence to have two lenses fail in such a short time frame.

Let us hope it's something along the lines of what Adam has said, let us know how you get on, once again welcome.
02-03-2013, 01:17 PM   #7
Site Supporter




Join Date: Jan 2013
Photos: Gallery
Posts: 7
Original Poster
Two FA* lens die in 1 hour when mounted on K5 II camera

I brought my FA* 85mm f1.2 to a Pentax retailer this morning. Tried it on K-30. No go. No auto focusing function at all. Tried it on K5. No go either. I am pretty sure that the electronics in my two FA* lenses were cooked by my K5 II last night.

A word of caution to all Pentax friends having FA* lenses. If they work nice in your K5 II, leave it there. Don'T change lens, otherwise electronic damage can occur to the lens.

Please read this: I also ordered a Pentax FA* 80-200mm f2.8. The auto focusing function was found dead on arrival (last week). I returned it to the supplier immediately. He gave my full refund and returned shipping cost. This lens has beautiful glass, and delivered beautiful pictures in manual mode.

I love my Pentax SMC A 50mm f1.2 lens. It is manual. But the picture quality is stunning. I will not sell my FA* 85 mm f1.4 because the pictures it delivers even in manual mode are excellent for portrait. Both lenses perform excellently especially in aperture priority mode at wide open aperture with normal room day light.

Last edited by 4karats; 02-03-2013 at 01:19 PM. Reason: Typo
02-03-2013, 01:20 PM   #8
Site Supporter




Join Date: Jan 2013
Photos: Gallery
Posts: 7
Original Poster
Typo: FA* 85 mm f1.4 not f1.2. My apology.

02-04-2013, 03:51 PM   #9
Site Supporter




Join Date: Jan 2013
Photos: Gallery
Posts: 7
Original Poster
For those who own a Pentax FA* lens, please read this and please forgive my stupidity:

Dear xxxxxxx,

Please accept my thousands of apologies.

Two night ago, I found that both my other two FA* lenses (Pentax FA* 85mm f1.4 and Pentax FA* 28-70mm f2.8) lost their auto functions just like the above lens (Pentax AF* 80-200mm f2.8) that has been sent back to you for a repair report. I was so sad. Two days later, I accidentally discovered that these lenses have a push-in-push-out auto/manual focus ring (which I am not familiar with). By locking the lens hood into the lens, one could accidentally push this focus ring into the manual position. In my two lenses (Pentax FA* 85mm f1.4 and Pentax FA* 28-70mm f2.8), I can now resume their automatic functions.

If this is the case with the Pentax lens I returned to you last week, please examine if the focus ring is in the push-in manual position. If so, please pull it out and try on a K-5 or K-5 II camera. One should be able to re-gain the automatic function. And if this is the case, I would like to send you the US$xxxx back to you, plus whatever shipping cost I owed you.

Please accept my ignorance and apology .

Yours sincerely,

4karats
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hi from Calgary (Ab, Canada) Exoticar.geo Welcomes and Introductions 1 01-21-2013 12:44 AM
Hi there from Calgary, Alberta Stefanyshyn Welcomes and Introductions 3 08-30-2012 11:00 AM
Hi from Calgary caledonian Welcomes and Introductions 5 02-15-2012 05:24 PM
Hello from Calgary, Alberta, Canada redrab Welcomes and Introductions 9 10-19-2011 02:05 PM
Hi from Calgary, Canada Raycj Welcomes and Introductions 2 09-18-2007 08:15 PM



All times are GMT -7. The time now is 02:32 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top