Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-05-2014, 06:13 AM   #1
New Member




Join Date: Jul 2013
Posts: 5
k-r built in flash not working and k-r starting to be slow

hi i have a pentax k-r and b4 the built in flash was working properly but now it doesnt work and camera becomes slow sometimes i cannot get a shot when taking photos. my warranty already expired. pls give advice what to do? thanks

01-05-2014, 07:47 AM   #2
Pentaxian
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 10,325
Hey, welcome!
Make sure your battery is not faulty. Another reason for slower photography might be SD card (you should format it in-camera from time to time, this deletes all (invisible) info on it. It is not the same as "delete all" option. A very slow SD card, like class 4, can also make write times longer). If these two things are okay, I would suggest you charge up the battery, leave it outside for a day, then put it back in and update the firmware to the latest one, if you haven't already. And then reset to factory defaults. Make sure you loaded all the photos from your SD card before you start doing these things.

Next there are some settings that can slow down the camera, like Shadow correction, lens distortion correction, CA correction, and digital filters (disable these for more speed). Make sure you dont accidentally have timer or bracketing enabled. Things like focus priority (instead of release shutter priority) can also make the camera seem "slower" because it will not allow you to take the shot before it locks and confirms focus. Also, maybe you just got used to the camera after using it so long and now you are impatient with it. It happens. Every computer seems super fast when you first buy it, but after a couple years, we get spoiled and it feels very slow. (though, some electronics do slow down a little bit after years of use, digital cameras might not be an exception)

Regarding the onboard flash not working - did you use it often? Did you ever use an external flash on the hotshoe?

Last edited by Na Horuk; 01-05-2014 at 07:52 AM.
01-05-2014, 09:04 AM   #3
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 30,626
Welcome, definitely check the battery as already suggested.
01-05-2014, 09:32 AM   #4
New Member




Join Date: Jul 2013
Posts: 5
Original Poster
QuoteOriginally posted by Na Horuk Quote
Hey, welcome!
Make sure your battery is not faulty. Another reason for slower photography might be SD card (you should format it in-camera from time to time, this deletes all (invisible) info on it. It is not the same as "delete all" option. A very slow SD card, like class 4, can also make write times longer). If these two things are okay, I would suggest you charge up the battery, leave it outside for a day, then put it back in and update the firmware to the latest one, if you haven't already. And then reset to factory defaults. Make sure you loaded all the photos from your SD card before you start doing these things.

Next there are some settings that can slow down the camera, like Shadow correction, lens distortion correction, CA correction, and digital filters (disable these for more speed). Make sure you dont accidentally have timer or bracketing enabled. Things like focus priority (instead of release shutter priority) can also make the camera seem "slower" because it will not allow you to take the shot before it locks and confirms focus. Also, maybe you just got used to the camera after using it so long and now you are impatient with it. It happens. Every computer seems super fast when you first buy it, but after a couple years, we get spoiled and it feels very slow. (though, some electronics do slow down a little bit after years of use, digital cameras might not be an exception)

Regarding the onboard flash not working - did you use it often? Did you ever use an external flash on the hotshoe?
hi thanks for the tip , i dont use it much only as needed for thethe built in flash and i havent use an external flash

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
flash, k-r
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-r: built-in flash stopped working after using external flash wedge Troubleshooting and Beginner Help 7 01-12-2014 07:57 PM
How to use built in k-r flash with old lenses Afrikaners Pentax DSLR Discussion 7 06-06-2013 10:12 AM
AP Priority seems to be not working K-R melliemag Troubleshooting and Beginner Help 5 08-23-2012 08:34 AM
Kalimar K/PK Mount not working on K-r pdxfive Pentax K-r 2 08-25-2011 11:23 AM
K-r will not take photos, shutter button not working - HELP! seattledotcom Troubleshooting and Beginner Help 8 06-08-2011 04:19 PM



All times are GMT -7. The time now is 08:22 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top