Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-20-2014, 04:19 AM   #1
New Member




Join Date: May 2014
Posts: 3
Hello from Bolton UK

Hi, Urban Spaceman here. I shoot with a K-m DSLR for my Urbex stuff, but also use a brilliant little Pentax auto 110 when I can find the film (I just used some Kodak 100asa which expired in 1979! and it worked!!). Also I have a 35mm ME Super which I am presently fixing up. I have done the light seals, freed the jammed shutter and winder mechanism and am now chasing down the electrical gremlins. I have no lights in my viewfinder and the circuit is dead. Keep moving forward...

05-20-2014, 07:39 AM   #2
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,783
Welcome! I'm surprised that you still can find 110 film, and even get it developed!
05-20-2014, 09:21 AM   #3
Veteran Member




Join Date: Jul 2009
Location: London
Posts: 856
Welcome, and look here for 110 film> Film ? Lomography Shop
05-20-2014, 01:33 PM   #4
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 30,585
Welcome and good luck with the electrical issues.

05-21-2014, 01:21 PM   #5
Site Supporter
Jean Poitiers's Avatar

Join Date: Apr 2011
Location: Lost in translation ...
Photos: Gallery | Albums
Posts: 16,376
Welcome to PF and bonjour from France, urbanspaceman ... please post us some 110 images soon ... Salut, J
05-22-2014, 01:28 AM   #6
New Member




Join Date: May 2014
Posts: 3
Original Poster
QuoteOriginally posted by JohnX Quote
Welcome, and look here for 110 film> Film ? Lomography Shop
Thanks for that. I'll be in touch!
05-22-2014, 01:37 AM   #7
New Member




Join Date: May 2014
Posts: 3
Original Poster
110auto pics

Link to the pics is here- https://www.flickr.com/photos/124159153@N07/

The film I used expired 30 years ago, so the images have a rather 'Lomo' quality to them. They also came out rather dark which I believe to be due to the age of the film. The camera itself is a fine piece of engineering and is in full working order. The lens quality is remarkable and unusual in that the aperture is in the front of the camera body rather than in the lenses. I'm not sure why, but I am guessing it was to keep the lenses as small as possible. Mine also has a Pentax flash and winder, and a suite of 3 lenses.
Presently these are cheap and available on Ebay. Very much worth grabbing one if only for curiosity.
05-22-2014, 05:11 AM   #8
Site Supporter
Jean Poitiers's Avatar

Join Date: Apr 2011
Location: Lost in translation ...
Photos: Gallery | Albums
Posts: 16,376
QuoteOriginally posted by urbanspaceman Quote
Link to the pics is here- https://www.flickr.com/photos/124159153@N07/ ...
Thanks and quite nice ... I would like to shoot the 110 system just once for fun, J

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
110, auto, k-m, me, repair, super
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello from uk Imageman Welcomes and Introductions 3 12-19-2013 07:17 PM
Hello from UK pcchoon Welcomes and Introductions 4 05-11-2013 12:53 AM
Hello from UK broose Welcomes and Introductions 2 02-12-2013 12:31 PM
Hello from UK Quinton Welcomes and Introductions 3 12-09-2012 08:19 AM
Hello from UK tomart Welcomes and Introductions 4 09-21-2012 11:56 AM



All times are GMT -7. The time now is 09:36 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top