Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-31-2014, 08:23 PM   #1
New Member




Join Date: Sep 2012
Posts: 6
Pentax K-r focus red square missing

Hello everyone,

I'm wondering whether someone can help me with my issue. I have a K-r and recently I have upgraded the firmware from 1.0 to 1.15. Though the camera appears to be working fine after the upgrade, I have noticed that the autofocus red square is missing now. When the camera focuses I still hear the beep, but no red square. Does anybody know if there is an option in the menu to turn the red square back on? Or maybe an explanation for this?

Thank you and happy Halloween!

S

10-31-2014, 09:52 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 43,128
I believe a custom function called "superimpose af area" controls the red LEDs. See if you can find it in the menu and then you should be good to go

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com's high server and development costs are user-supported. You can help cover those costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

11-01-2014, 01:29 AM   #3
Site Supporter
Jean Poitiers's Avatar

Join Date: Apr 2011
Location: Lost in translation ...
Photos: Gallery | Albums
Posts: 16,545
Bonjour from France and welcome to PF, S ... Hope to see some K-r images soon! Salut, J
11-01-2014, 02:31 AM   #4
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 32,707
Welcome to the forum, Adam beat me to it, I was going to say it must an option hiding somewhere in the menus allow you to toggle this on and off.

11-01-2014, 03:25 AM   #5
Pentaxian
Na Horuk's Avatar

Join Date: Feb 2012
Location: Slovenia, probably
Photos: Gallery | Albums
Posts: 10,863
Hey, welcome!
I hope Adam's post resolves the issue. Here are other possible causes:
a) sometimes when the background is bright and busy, the LED overlays are harder to notice
b) which AF point is selected? If you have only centre point, the other ones will not light up. If you have auto 11, others might light up, but the ones on the sides still light up rather rarely
c) which AF mode? AF.S, AF.C behave slightly differently. With AF.C the overlays sort of blink in and out, staying on while focus is locked. In AF.S they just show up for a split second
If all else fails, make sure the battery is charged up, leave it out of the camera overnight, put it back in, and press the "return to defaults" in the Menu. This might invalidate your personal settings, but it would reset all the options.
11-01-2014, 08:27 AM   #6
New Member




Join Date: Sep 2012
Posts: 6
Original Poster
Thank you all for your responses. I have found "superimpose AF area" option. It was OFF for some reason. Switched back to ON and problem solved.

Thanks again!

S
11-01-2014, 09:59 AM   #7
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 32,707
QuoteOriginally posted by srdjanmax Quote
Switched back to ON and problem solved
Happy days, a good result, that Adam knows his stuff.
11-03-2014, 02:22 PM   #8
Pentaxian
ChristianRock's Avatar

Join Date: Jul 2013
Location: Woodstock, GA
Photos: Gallery | Albums
Posts: 4,528
Welcome and I'm glad the problem is solved!

The K-r is a good camera, there's a few quirks but it's a good camera. At current prices, it's a LOT of bang for the buck.

11-04-2014, 12:49 AM   #9
Veteran Member




Join Date: Jan 2012
Location: Балашиха
Photos: Albums
Posts: 595
Welcome, here otloichnye people who can help you solve many problems associated with the camera. Actively participate in the forum, there is a very friendly atmosphere!
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
autofocus, camera, focus red square, k-r, pentax k-r focus, red dot, square
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K-01 missing focus with a particular lens. ripit Pentax K-01 6 06-02-2013 06:28 PM
pentax k-r focus calibration Enkhbayar Troubleshooting and Beginner Help 11 12-04-2012 05:50 AM
Pentax K-R Broken Flash/Auto Focus omegawolf Troubleshooting and Beginner Help 6 11-27-2012 09:25 AM
Pentax K-R - Red Dot in Video marlonf Pentax K-r 15 11-12-2010 10:53 AM



All times are GMT -7. The time now is 05:29 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top