Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-28-2015, 05:29 PM   #1
New Member




Join Date: Jan 2015
Posts: 2
Hello

I am Script, I have K3 that's not working so I thought I would take advantage of this forum to see if i can fix it myself.

01-28-2015, 05:36 PM   #2
Junior Member




Join Date: Jan 2015
Posts: 29
welcome
01-29-2015, 10:07 AM   #3
Site Supporter
savoche's Avatar

Join Date: Jun 2011
Posts: 7,712
Welcome aboard! Sorry about your camera. Doesn't sound like that hotshoe is easily repairable
01-29-2015, 01:08 PM   #4
Senior Member
jack002's Avatar

Join Date: Sep 2014
Location: Missouri
Photos: Albums
Posts: 189
Welcome! Sorry the K3 isn't working. Good luck with it.

01-31-2015, 03:07 PM   #5
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 30,608
Welcome to the forum, lets hope it can be fixed under warranty...
Reply
« I'm new here | Hi »

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello SonOfMerope Welcomes and Introductions 7 11-19-2014 07:19 AM
Hello everyone zhaijq90 Welcomes and Introductions 3 09-04-2014 12:25 AM
Hello jonojono Welcomes and Introductions 6 05-22-2014 11:10 PM
Newbie says hello wlq Welcomes and Introductions 4 12-18-2013 02:37 PM
Hello JOHNBIGGAM Welcomes and Introductions 2 08-12-2013 02:08 PM



All times are GMT -7. The time now is 11:44 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top