Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-17-2015, 02:08 PM   #1
New Member
coenonympha's Avatar

Join Date: Feb 2015
Posts: 5
Frenchy

Hi,

My name is Cyril, I'm 38, and I'm french (no one is perfect)
I don't own a Pentax camera and don't want to
I use a Fuji X-M1 and... old lenses. And to choose them I used the forum and its reviews a lot. So I come here, to give my opinion on the lenses I own, and some are not yet into the database


Last edited by coenonympha; 02-17-2015 at 02:15 PM.
02-17-2015, 03:58 PM   #2
Pentaxian
Rimfiredude's Avatar

Join Date: Oct 2014
Location: Washington
Photos: Gallery
Posts: 2,177
Hmmmmm...interesting. I was French at one time, when they tossed my family out of England for religious reasons many, many years ago.
02-18-2015, 02:57 AM   #3
New Member
coenonympha's Avatar

Join Date: Feb 2015
Posts: 5
Original Poster
QuoteOriginally posted by Rimfiredude Quote
Hmmmmm...interesting. I was French at one time, when they tossed my family out of England for religious reasons many, many years ago.
what a weird welcoming, especially when we know that France is one of the very few nations to have no religion or God.
You're the first to accuse me of something happened 1300 years ago...
02-18-2015, 06:02 AM   #4
Pentaxian
Rimfiredude's Avatar

Join Date: Oct 2014
Location: Washington
Photos: Gallery
Posts: 2,177
QuoteOriginally posted by coenonympha Quote
what a weird welcoming, especially when we know that France is one of the very few nations to have no religion or God.
You're the first to accuse me of something happened 1300 years ago...
You misunderstood. We were thrown out of England and France took us in. Therefore my family was French. No we are Americans. No offense please.

02-18-2015, 06:25 AM   #5
Loyal Site Supporter
TER-OR's Avatar

Join Date: Apr 2009
Location: Dundee, IL
Photos: Gallery | Albums
Posts: 5,834
Welcome!
One side of my family were from the Alsace region, I've always wanted to visit as it sounds beautiful.
02-18-2015, 12:43 PM   #6
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 32,749
QuoteOriginally posted by coenonympha Quote
and I'm french (no one is perfect)
Welcome, but remember the "Auld Alliance" back then we were the best of buddies, the French and the Scots I mean.
02-19-2015, 12:17 AM   #7
New Member
coenonympha's Avatar

Join Date: Feb 2015
Posts: 5
Original Poster
thx all, sorry Rimfiredude for the misunderstanding
02-19-2015, 03:33 AM   #8
Veteran Member
zoolander's Avatar

Join Date: Dec 2012
Location: Gold Coast
Photos: Albums
Posts: 337
QuoteOriginally posted by coenonympha Quote
Hi,

My name is Cyril, I'm 38, and I'm french (no one is perfect)
I don't own a Pentax camera and don't want to
I use a Fuji X-M1 and... old lenses. And to choose them I used the forum and its reviews a lot. So I come here, to give my opinion on the lenses I own, and some are not yet into the database
Hi Cyril, or should I say Bonjour ! welcome to the forum !

I started with a Nikon DSLR (gone), then Sony SLT(gone), then a K-5 (soon to be gone) and now a K-3 Prestige ......... plus a Fujifilm X-A1.

How do you find the old Fuji lenses ? I've got the kit 16-50 and 50-230 and they're great, but the body is a bit shoddy. The menu system is glitchy as heck, and when its one mode, and you switch it back, it still has incorrect data in the RAM, and you loose the flash or something else. Like tonight, the flash would not work because I had it in silent mode (press and hold the "Back" button), so I switch it back and still the flash won't work. So I spent 5 minutes going through the menus and trying other settings, but it turned out to be a RAM glitch. You gotta take out the battery, and let the electricity dissipate from the RAM chip after 10 minutes, and then things go back to normal.

Though I've upgraded the firmware, its still glitchy. I took it and the K-3 to the beach, and the X-A1 was over exposing in A mode, and just a dog to use. Some of the shots were great, but a real pain to use. I switched over to the K-3, and shot in A mode without a single worry.

But the low light/high ISO performance, plus lenses are awesome ! Just a real pity about the horribly incompetent firmware and average menu system.

So is the X-M1 a pain to use ? because sometimes this X-A1 glitches just as bad as my old Nikon. My Pentax cameras have hardly had any operating glitches - 3 over 2 years with the K-5, and 2 with the K-3 in 4 or 5 months. Glitches are a daily occurrence with the X-A1, so I hope your X-M1 is better.

If its as bad as mine, then you WILL invest in a Pentax !

02-19-2015, 05:20 AM   #9
Loyal Site Supporter




Join Date: Mar 2012
Location: Rochester, NY
Photos: Gallery
Posts: 2,187
Welcome Aboard!

From what I have gathered I have French, German, English, Scottish, Irish and even Belgian blood in me. The next time that National Geographic puts their human genome DNA test kit on sale I am going to get it so I can see what percentage Neanderthal and I am running around with. As to our 4 kids, my wife brings at least Russian and Italian into the mix.
02-19-2015, 02:35 PM   #10
New Member
coenonympha's Avatar

Join Date: Feb 2015
Posts: 5
Original Poster
Hi Zoolander, I didn't choose the XA1 because it doesn't own the awesome xtrans
The big lack of the XM1 is the eyefinder
I didn't own old fuji.
I have :
- PENTACON 29 2.8 --> awesome
- RICOH 55 2.8 --> not as good as the 50 2 seems to be
- RICOH 50 2 --> I'm waiting for the adapter, it seems to be very good, regarding to the reviews on the forum
- my old minolta 100 macro 2.8 AF --> still waiting for the adapter too, but I really like this lens
02-20-2015, 10:06 AM   #11
Loyal Site Supporter
TER-OR's Avatar

Join Date: Apr 2009
Location: Dundee, IL
Photos: Gallery | Albums
Posts: 5,834
Keep an eye open for a Pentax M50 f1.7 or f1.4 those are great glass. You might want to buy a rubber lens hood, though, since they don't handle reflections as well as new lenses. The color and depth rendering is really good with the old glass, though.
02-20-2015, 08:20 PM   #12
Veteran Member
zoolander's Avatar

Join Date: Dec 2012
Location: Gold Coast
Photos: Albums
Posts: 337
QuoteOriginally posted by coenonympha Quote
Hi Zoolander, I didn't choose the XA1 because it doesn't own the awesome xtrans
The big lack of the XM1 is the eyefinder
I didn't own old fuji.
I have :
- PENTACON 29 2.8 --> awesome
- RICOH 55 2.8 --> not as good as the 50 2 seems to be
- RICOH 50 2 --> I'm waiting for the adapter, it seems to be very good, regarding to the reviews on the forum
- my old minolta 100 macro 2.8 AF --> still waiting for the adapter too, but I really like this lens
I got the X-A1 because of the low light performance, as opposed to the Xtrans set up. But I really like it and have to just manage with the glitching problem. Its my back up camera and something I just wanted to play around with, and to try the Fuji lenses. The fuji lenses are quite something, not sure whether there are awesome as my DA*50-135mm, but pretty darn good for kit lenses. I've got a M 50 1.7 and FA 50 1.4, Sigma 50mm 1.4 and I prefer modern lenses and modern coatings, so I've tried both and won't bother buying a k to X mount adapter.

An electronic viewfinder would be better, plus faster af, but you can't have everything !

So does your X-M1 have glitches? Because I gotta keep the battery out of the body when I'm not using it to prevent glitches. Every time I use it and switch modes there's a glitch ! I might just have to keep it in one mode and never change it ! lol
02-21-2015, 12:36 AM   #13
New Member
coenonympha's Avatar

Join Date: Feb 2015
Posts: 5
Original Poster
QuoteOriginally posted by zoolander Quote
I got the X-A1 because of the low light performance, as opposed to the Xtrans set up. But I really like it and have to just manage with the glitching problem. Its my back up camera and something I just wanted to play around with, and to try the Fuji lenses. The fuji lenses are quite something, not sure whether there are awesome as my DA*50-135mm, but pretty darn good for kit lenses. I've got a M 50 1.7 and FA 50 1.4, Sigma 50mm 1.4 and I prefer modern lenses and modern coatings, so I've tried both and won't bother buying a k to X mount adapter.

An electronic viewfinder would be better, plus faster af, but you can't have everything !

So does your X-M1 have glitches? Because I gotta keep the battery out of the body when I'm not using it to prevent glitches. Every time I use it and switch modes there's a glitch ! I might just have to keep it in one mode and never change it ! lol
No, I don't have any glitching problem with the xm1. Fuji lenses are very good. This is the first time I keep the kit lenses. Poor aperture but very sharp.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
lenses
Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -7. The time now is 10:17 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top