Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
05-15-2015, 12:21 PM   #1
New Member
Photoliv41's Avatar

Join Date: May 2015
Location: Southern Maine
Posts: 9
Hello from Maine


I bought my K30 in April 2013 after reading & viewing multiple positive reviews and having had an introductory point & shoot which took fantastic macro images.

After taking many dazzlingly crisp & clear images over the past 2 years, my camera now refuses to take any images with proper exposures, unless I manually increase the exposure to it's maximum setting. I am so very sad & disappointed that I've invested close to $700. in a camera which only lasted just under 2 yrs.

I had formerly only used Nikon cameras, but fell in love with the quality of the Pentax macro feature. That was the selling point for this camera. First noticed that the video seemed to produce greatly overexposed video images about June of last year (about 1 yr after purchase), but otherwise it still took great images. Now it will not take any recognizable images without deliberately over-exposing manually.

I've tried resetting to factory default settings, as well as updating to the most recent firmware. Neither appears to have helped. If anyone can offer me any help, I'd greatly appreciate it. I am out of work at the moment & I was trying to begin selling my images online to help with finances, but without a camera to take new images, my business may begin to falter. Please help.

05-15-2015, 03:25 PM   #2
Loyal Site Supporter
eaglem's Avatar

Join Date: Feb 2009
Location: Perth Western Australia
Photos: Gallery
Posts: 25,700
Welcome to the forum. Could one of the moderators this post to the appropriate forum so this member can get the help needed?
05-17-2015, 05:35 AM   #3
Moderator PEG Judges
Kerrowdown's Avatar

Join Date: Aug 2008
Location: Highlands of Scotland.
Photos: Gallery
Posts: 30,701
Welcome aboard, you may get a faster response if you re post your question here.

Pentax DSLR Discussion - PentaxForums.com
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, dark images, disappointed, help, images, k30, macro, out of warranty, under exposure, video
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello from Maine... daveyohill Welcomes and Introductions 4 10-13-2013 07:53 AM
Hello From Maine PJGPix Welcomes and Introductions 7 11-25-2011 08:27 PM
Hello from Maine Boydmaine Welcomes and Introductions 2 05-23-2011 04:58 PM
Hello from Maine shadowraven Welcomes and Introductions 5 12-19-2008 09:03 AM
Hello from Maine.... Suzu Welcomes and Introductions 11 12-01-2008 04:41 PM



All times are GMT -7. The time now is 04:06 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top