Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-05-2015, 08:39 PM   #1
Veteran Member
NicoleC's Avatar

Join Date: Oct 2013
Location: Madison, AL
Posts: 448
Minor touch incompatibility issue

This falls under the category of 'annoyance' more than bug, and occurs when you are using the site on a touch screen. When you click on the drop down menus it registers as a 'search,' I think. So, immediately after selecting your submenu item (for example, Browse New Posts), you get an error saying you have to wait 3 seconds between searches instead of seeing the requested page. Immediately reloading the page then works.


I don't experience this on a non-touch device using the same browser.

01-05-2015, 10:55 PM   #2
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 47,571
Can you be more specific- which menus are you referring to?

Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

01-06-2015, 05:56 AM   #3
Veteran Member
NicoleC's Avatar

Join Date: Oct 2013
Location: Madison, AL
Posts: 448
Original Poster
The only one I ever do is the Forum -> Browse New Posts option.
01-06-2015, 06:39 AM   #4
Pentaxian
Arjay Bee's Avatar

Join Date: Sep 2006
Location: Bamaga, QLD
Photos: Gallery | Albums
Posts: 3,308
Adam, I get the same on my windows tablet if I tap on the notification for a liked post. I get the warning that I need to wait for 3secs between searches. If I go to the my activity drop down and tap on my liked posts the liked post opens no problem.... as op says a minor annoyance.

01-06-2015, 10:47 AM   #5
Site Supporter
Site Supporter
Tom S.'s Avatar

Join Date: May 2008
Location: S.E. Michigan
Photos: Albums
Posts: 4,277
Are you both using Windows based tablets? I ask because I have a Android tablet that works fine, so it might be a Windows problem.
01-06-2015, 04:30 PM   #6
Veteran Member
NicoleC's Avatar

Join Date: Oct 2013
Location: Madison, AL
Posts: 448
Original Poster
WebKit browsers handle touch events differently than the (relatively new) W3C standard. IE 10/11 uses the standard. So if the site has touch coding specific to WebKit, it will work on Chrome and Safari, but not 100% on IE. Until WebKit browsers incorporate the standards, coding for both is required.


None of which is unusual; code in-the-wild is always ahead whatever the final standard will be, there's a mess and eventually it gets straightened out, but developers and QA tester get gray hairs trying to make it all work.


I am so glad I'm a RETIRED web programmer. I have enough gray hair.


Touch Events
01-06-2015, 05:31 PM   #7
Pentaxian
Arjay Bee's Avatar

Join Date: Sep 2006
Location: Bamaga, QLD
Photos: Gallery | Albums
Posts: 3,308
Yup, I'm on a windows 8.1 HP Elite Pad.
I suspected it was a code handling glitch so I just use the workaround as above.
01-06-2015, 11:05 PM   #8
Administrator
Site Webmaster
Adam's Avatar

Join Date: Sep 2006
Location: Arizona
Photos: Gallery | Albums
Posts: 47,571
I tested this using a windows 8.1 touchscreen laptop and found the issue to only occur in IE (11). I've now fixed it- let me know if you guys are still having the problem in other browsers.


Adam
PentaxForums.com Webmaster (Site Usage Guide | Site Help | My Photography)



PentaxForums.com server and development costs are user-supported. You can help cover these costs by donating. Or, buy your photo gear from our affiliates, Adorama, B&H Photo, or Topaz Labs, and get FREE Marketplace access - click here to see how! Trusted Pentax retailers:

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
page, touch
Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -7. The time now is 11:44 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top