Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-02-2012, 01:52 PM   #1
Veteran Member
Pablom's Avatar

Join Date: Feb 2010
Location: Jerusalem
Posts: 1,940
Corrupted raw files on SD card

After a nice outing, I got home and as I usually do, I browsed today's photos on FastStone, deleted any duplicates and sub par photos with the intention of importing them into Lightroom and backing up to two HDDs. but something had to go wrong...
I wanted to delay the deleting process to later so I pressed the 'safely remove hardware' icon and might or might not got the 'it is now safe...' message before pulling out the card reader from the USB port (FastStone was probably closed at that point). What happened next is certain: I inserted the card (SDHC sandisk extreme) back into the camera and I got a message 'card is not formatted'. same thing when I put it back to the PC. Damn.
I tried about half a dozen recovery programs, including RescuePRO that came with the card and otherwise costs $40. I got nothing. well, actually I did get one perfectly good JPG (interesting because I shoot RAW only) and 90 PEF files, of which all are corrupted and thus cannot be edited (I see proper thumbnails but when viewing it just becomes a bunch of colored horizontal lines).
So now I turn to you guys, is there hope for my precious photos?


Last edited by Pablom; 03-02-2012 at 01:59 PM.
03-02-2012, 02:07 PM   #2
Veteran Member
mark lj's Avatar

Join Date: Sep 2011
Photos: Gallery
Posts: 983
No. At least not in my honest opinion. You could have recovered the jpeg as it may have been a smaller jpeg embedded within the RAW file (at least there is in DNG iirc). I had a similar situation recently and try as I might I could not get anything to recover the RAW files. I had access to very strong computer forensic software and made some changes to the search parameters to try and carve out the RAW files from the headers and footers. Huge number of false positives but nothing doing. PEF is an even rarer file ext and I really can't see you having any success. The best software you could try is Access Data. Ridiculously expensive law enforcement tool but the demo version has full capability on drives with less than 5,000 files. You would need the FTK imager to make a bit for bit copy of the card and then load it into the forensic toolkit version 1.81 (iirc - there is a newer version but not sure about the functionality of the demo version) and see how you get on. Very powerful image recovery tool that I used professionally on a daily basis.
03-02-2012, 02:11 PM   #3
Veteran Member
Pablom's Avatar

Join Date: Feb 2010
Location: Jerusalem
Posts: 1,940
Original Poster
thanks for the tip mark lj, I'll look into it.
btw the JPG I got is full sized (12MP) and was from the middle of the batch so I have no idea how that got in.
03-02-2012, 04:13 PM   #4
Veteran Member




Join Date: Apr 2010
Location: California
Photos: Albums
Posts: 484
I've had great success with this freeware tool in the past. It was able to recover all jpg files from an SD card after accidentally hitting 'delete all' in a point and shoot camera. This can work because when you delete a file, the data is usually not overwritten (takes too long), its sectors are only removed from the content list. I'm not sure it will help in your case (especially since the tool you tried already manipulated the tables), but you might want to give it a shot.


Last edited by Ikarus; 03-02-2012 at 04:20 PM.
03-02-2012, 05:43 PM   #5
Veteran Member
Pablom's Avatar

Join Date: Feb 2010
Location: Jerusalem
Posts: 1,940
Original Poster
already tried that, didn't help. I tried also Recuva, CardRecovery, ImageRescue, Zero Assumption Recovery, Stellar Phoenix Photo Recovery, and maybe one or two more. the latter gave the best results but still not remotely satisfying,
03-03-2012, 01:51 PM   #6
Veteran Member
Pablom's Avatar

Join Date: Feb 2010
Location: Jerusalem
Posts: 1,940
Original Poster
last resort advice before I format the card? anyone...?
03-03-2012, 03:34 PM   #7
Senior Member
pencilnink's Avatar

Join Date: Jan 2011
Location: San Jose, CA
Posts: 192
I actually just had this dilemma yesterday. After a few hours of testing out different programs, the only program that worked was testDisk from CGSecurity.
My memory stick had 400 DNG files from my NYC trip which I haven't imported into lightroom and was corrupted to the point where it wouldn't even let me format it; although every I plugged it into my pc it wanted me to format it. Also got the same message when I inserted it back in the camera about it not being formatted.
After using that program though, my memory stick was no longer corrupted and I was able to access it and recover every DNG file in it as well as some videos and edit them in LR as well.
Luck maybe? I don't know, but it's worth a shot.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
card, faststone, files, files on sd, message, photography, photos, photoshop
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
memory card storage with RAW files Tonylj Visitors' Center 4 11-09-2011 12:39 AM
corrupted raw files due to sd card mtkang Troubleshooting and Beginner Help 11 11-01-2011 05:38 AM
Weird Corrupted Files on Memory Card krp Troubleshooting and Beginner Help 10 08-02-2011 07:27 PM
Corrupted Pentax RAW Files wadedesk Pentax Camera and Field Accessories 3 07-09-2009 04:03 AM
Opening bad, corrupted, or unreadable RAW files bdavis Digital Processing, Software, and Printing 3 04-04-2007 02:54 PM



All times are GMT -7. The time now is 06:10 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top