Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-05-2015, 04:20 PM   #1
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,712
Crashes with Digital Camera Utility 5.4.2

Hello, I have updated DCU 5.4.2 from 5.4.1. Since DCU 5 has been slow and crashed several times. I am now unable start DCU 5: when I start it, it opens and than the software closes automatically.

I tried the usual tricks:
-shut down Windows 7 Pro 64 bits
-clean registries (with Ccleaner)
-repair DCU 5.4.2
-remove DCU and reinstall completely DCU 5.42.

No success after each try.

Does anyone know where to find the installer for DCU 5.4.1? Unfortunately I did not save it at the time.

Thank you in advance.


Last edited by hcc; 12-05-2015 at 04:30 PM.
12-05-2015, 08:26 PM   #2
New Member




Join Date: Nov 2015
Location: Walnut Creek, California
Posts: 23
I have similar problem running Windows 7. The application opens, but crashes as soon as I select an image. Tried removing and reinstalling a number of times but no luck


Went back and installed the version on the CD that came with my 645Z - which is 5.1.0 - certainly dated but at least it works without crashing.
.
12-05-2015, 11:58 PM - 1 Like   #3
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 7,216
Downloads & Literature - RICOH Imaging
Download Pentax Digital Camera Utility 5.4.1 Update for Windows Vista/7/8/8.1 x86/x64
12-06-2015, 01:02 AM - 1 Like   #4
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,712
Original Poster
Thank you. For the benefits of others, I recommend to remove first DCU 5.4.2. Then use the 'old trick' of mounting an SD card, renaming it to "S-SW140", the name on the original install disk which came with the K-3, before running the installer.

Lastly it seems that I am at least the 3rd Pentaxian reporting some major error (ie crashes) with DCU 5.4.2. I would surge everyone with some issue with the new version to report it, for the benefits the community as well as for Ricoh/Pentax.


12-06-2015, 08:46 AM   #5
Loyal Site Supporter
Loyal Site Supporter
Mikesul's Avatar

Join Date: Sep 2009
Location: Phoenix, AZ
Posts: 6,450
Can you tell us under what circumstances you have had the problems? I do not use DCU a lot but I have used the new version for a dozen or so photos without problems. Perhaps I have not tried the features which have given you difficulty.
12-06-2015, 09:36 AM   #6
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 7,216
I wonder if it is the old checkmark problem?

https://www.pentaxforums.com/forums/58-troubleshooting-beginner-help/170095-p...ml#post1761773
12-06-2015, 03:43 PM   #7
hcc
Pentaxian
hcc's Avatar

Join Date: Nov 2009
Location: Brisbane, Australia
Photos: Gallery | Albums
Posts: 3,712
Original Poster
QuoteOriginally posted by Mikesul Quote
Can you tell us under what circumstances you have had the problems? I do not use DCU a lot but I have used the new version for a dozen or so photos without problems. Perhaps I have not tried the features which have given you difficulty.
I was processing a batch of recently taken photographs (JPEG [***]) with my K-3.
I had issues (long delays) to delete shots.
When post-processing (eg applying parameters), DCU was very slow, sometimes not responding.
When doing batch processing, no file was output to the output directory.
....

I doubt that I experienced the 'old checkmark problem' suggested by Not a number. I read the thread and problem, and my experience was different,


For the benefit of everyone: I add that I have un-installed DCU 5.4.2 and re-installed DCU 5.4.1. Since the re-installation, I have process over 350 shots and I has had no single issue with DCU 5.4.1.

Last edited by hcc; 12-06-2015 at 07:50 PM.
02-03-2016, 09:14 PM   #8
Senior Member




Join Date: Mar 2013
Posts: 143
Today I upgraded to 5.4.2 and it crashed!...

Well, I notice that a file in my Pictures folder made PDCU crash: a .DNG file created by DXO Optics Pro 10.
I deleted that file and it run perfectly.
Anyway, I'm going back to 5.4.1 which didn't have that problem.

---------- Post added 02-03-16 at 11:41 PM ----------





Last edited by Amoon; 02-03-2016 at 09:41 PM.
03-20-2016, 08:05 PM   #9
Site Supporter
Site Supporter
jpzk's Avatar

Join Date: Jan 2009
Location: Québec
Photos: Gallery | Albums
Posts: 7,862
So, I am using the old 5.0 version that came with the K3 ... should I (or not) update with 5.4.1 ?
And where is this update available?

Thanks for the posts !
03-20-2016, 08:10 PM   #10
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 7,216
The main reason to update is to support later bodies or lenses. Links to downloads are in post #3 above.
03-20-2016, 09:19 PM   #11
Forum Member




Join Date: Mar 2010
Location: Adelaide
Photos: Albums
Posts: 68
Had similar crash with Version 4.4. I found that even after uninstalling and registry cleaning it still had a file called checkinfo.ini in the folder username\localsettings\applications\PENTAX\PENTAX Digital camera utiliy 4. Once checkinfo.ini was deleted and software resinstalled it worked fine! It may work for the V5's.
03-21-2016, 08:08 AM   #12
Site Supporter
Site Supporter
microlight's Avatar

Join Date: Sep 2011
Location: Hampshire, UK
Posts: 1,674
I upgraded from 5.4.1 to 5.4.2 yesterday to get the switchable pixel-shift button, and it has been working fine so far with Windows 7 64-bit; it seems to be working faster than 5.4.1. Don't forget that there are two updaters in the provided zip file, one each for 32 and 64 bit, so make sure that you use the correct one for your OS.
06-15-2016, 09:40 PM   #13
Pentaxian
joergens.mi's Avatar

Join Date: Jan 2012
Posts: 405
The same problems with 5.4.1, 5.4.2 and K3 and with 5.5.0 and 5.5.1 k3 and K1 on two PC's with windows 7 64/bit and 6 GB of Ram.

The support can't help.

I did follow there ideas about deaktivating antivirus and security software, no change.
07-02-2016, 11:33 PM   #14
Pentaxian
calsan's Avatar

Join Date: Nov 2008
Location: Perth, Australia
Photos: Gallery
Posts: 1,462
Using 5.5.1 with K3 and was never going to finish making simple adjustments of 100 RAW files in this lifetime. So came here and followed HCC's advice.
Rolled back to version 5.4.1 and have acceptable speed once more.
Luckily, I keep old versions of Pentax software and firmware 'just in case'!
07-03-2016, 06:47 AM   #15
Moderator
Not a Number's Avatar

Join Date: Mar 2012
Location: Venice, CA
Posts: 7,216
DCU 5.x and 4.x uses the graphics card for hardware acceleration, where possible. Both System Explorer and several GPU utilities show this to be the case. DCU 4 was running extremely slow on my XP system until I updated the graphics drivers. Try updating your graphics drivers or even going to an earlier version.

There doesn't seem to be a way for the end user to downgrade the firmware on Pentax cameras.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera utility, crash, dcu, dxo, file, folder, notice, optics, pdcu, perfectly, photography, photoshop, pictures
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
PENTAX Digital Camera Utility 5.4.2 Update calsan Pentax News and Rumors 40 02-04-2016 02:06 PM
Pentax Digital Camera Utility 4 with K-7 Mjason Troubleshooting and Beginner Help 2 07-17-2014 01:41 AM
Problems with Digital Camera Utility 5 EagleEye Digital Processing, Software, and Printing 3 02-13-2014 09:48 PM
Digital camera utility crashes derekandrews Digital Processing, Software, and Printing 4 07-30-2011 06:56 PM
Pentax Digital Camera Utility 4 tryout (with images) creampuff Digital Processing, Software, and Printing 4 07-10-2009 10:42 AM



All times are GMT -7. The time now is 05:25 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top