Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
12-26-2021, 11:19 AM   #1
Junior Member




Join Date: Nov 2019
Posts: 27
Lightroom puts wrong lens into metadata

I have a Sigma 50-150mm APO lens which gets into the metadata as a Sigma 70-200mm, despite 1) being in the list of supported lenses and 2) Lightroom being bang up to date. I don't know if it worked correctly before the latest update as that happened before I got the lens.

Has anyone else had this problem? I have reported it as a bug on the relevent Adobe forum.

12-26-2021, 01:00 PM   #2
Pentaxian
photoptimist's Avatar

Join Date: Jul 2016
Photos: Albums
Posts: 4,909
This seems to be a problem with some Sigma lenses caused by Sigma using the same lens code for several different lenses. Sadly, it cannot be fixed by either Adobe or Pentax.
12-26-2021, 04:11 PM   #3
-
Loyal Site Supporter




Join Date: Mar 2010
Posts: 18,745
QuoteOriginally posted by photoptimist Quote
This seems to be a problem with some Sigma lenses caused by Sigma using the same lens code for several different lenses. Sadly, it cannot be fixed by either Adobe or Pentax.
Yep, I seem to recall my Sigma 50mm f/2.8 EX DG - a lens that's been around for some years now - appears as a Pentax SMC D FA50/2.8 Macro in Lightroom. It's Sigma's fault entirely for using the same lens codes. Easy enough to change the lens setting and then apply to a batch of images, but a tad frustrating. Ah, the joy of third-party lenses...
12-26-2021, 05:04 PM   #4
Pentaxian
swanlefitte's Avatar

Join Date: May 2015
Location: Minneapolis
Photos: Gallery
Posts: 3,978
My sigma 70 comes up wrong and I think it comes up different again for others. If it does it is probably camera or age related.

12-27-2021, 06:00 AM   #5
Junior Member




Join Date: Nov 2019
Posts: 27
Original Poster
I hate Sigma now!

---------- Post added 27th Dec 2021 at 06:25 ----------

Hmmm after some thought - I wondered if it's possible to remove the incorrect lens profile from LR, given it's a lens I will never have. But although I can find the correct entry for a Pentax in pscache.dat I can't find the incorrect one for Pentax - I can only find a similar one for Nikon, Sigma & Canon cameras! I can't find anything for a Sigma 70-200mm F2.8 EX DG Macro HSM II which is what Lightroom shows it as. (I can only find Lens Profiles in the CameraRaw fold)

Code:
               <rdf:li rdf:parseType="Resource">
<stCamera:DocumentID>6FFDE367ECB96E98B910300D5E7FB1D9</stCamera:DocumentID>
<stCamera:Make>Canon</stCamera:Make>
<stCamera:Lens>70-200mm F2.8 DG OS HSM | Sports 018</stCamera:Lens>
<stCamera:LensInfo>70/1 200/1 0/0 0/0</stCamera:LensInfo>
<stCamera:LensPrettyName>SIGMA 70-200mm F2.8 DG OS HSM S018</stCamera:LensPrettyName>
<stCamera:CameraPrettyName>Canon</stCamera:CameraPrettyName>
<stCamera:CameraRawProfile>True</stCamera:CameraRawProfile>
<stCamera:SensorFormatFactor>1.000000</stCamera:SensorFormatFactor>
<stCamera:ModifyDate>132725946520000000</stCamera:ModifyDate>
<stCamera:FishEyeLens>False</stCamera:FishEyeLens>
</rdf:li>
Also, I found the following in the ExifTools website (https://exiftool.org/TagNames/Pentax.html#LensType)

Code:
'8 255'	= Sigma Lens (8 255)
'8 255.1' = Sigma 70-200mm F2.8 EX DG Macro HSM II
'8 255.2' = Sigma 150-500mm F5-6.3 DG APO [OS] HSM
'8 255.3' = Sigma 50-150mm F2.8 II APO EX DC HSM
'8 255.4' = Sigma 4.5mm F2.8 EX DC HSM Circular Fisheye
'8 255.5' = Sigma 50-200mm F4-5.6 DC OS
'8 255.6' = Sigma 24-70mm F2.8 EX DG HSM
So it's using the first lens type in this group, instead of the correct one. So I wonder where the problem is? In the metadata from the camera? Or in Lightroom? Or is this info from ExifTool leading me astray?

Last edited by fifescapes; 12-27-2021 at 07:09 AM.
12-27-2021, 07:31 AM   #6
Junior Member




Join Date: Nov 2019
Posts: 27
Original Poster
Right now my feeling is it's a firmware bug, and I can see no way of reporting it on the Pentax website. As it's a new model I would have thought they could fix this.

Any offers for how to report it?
12-27-2021, 11:41 AM   #7
Pentaxian
photoptimist's Avatar

Join Date: Jul 2016
Photos: Albums
Posts: 4,909
Hmmm... It might be worse/different than it first appears.

The ExifTools website states that LensType is int8u[2]. That is, this data is two 8-bit unsigned integers. If so, the decimal part of the lens code may never be reported if it even exists.

Is there any evidence that these lenses actually report a decimal value? That would be very strange because digital decimal values are very different types of data (e.g., floats, multi-byte fixed-point, or BCD character strings) compared to 8-bit integers.

12-27-2021, 01:40 PM   #8
Junior Member




Join Date: Nov 2019
Posts: 27
Original Poster
QuoteOriginally posted by photoptimist Quote
Hmmm... It might be worse/different than it first appears.

The ExifTools website states that LensType is int8u[2]. That is, this data is two 8-bit unsigned integers. If so, the decimal part of the lens code may never be reported if it even exists.

Is there any evidence that these lenses actually report a decimal value? That would be very strange because digital decimal values are very different types of data (e.g., floats, multi-byte fixed-point, or BCD character strings) compared to 8-bit integers.
Ah - again from ExifTools website:

QuoteQuote:
Decimal values have been added to differentiate lenses which would otherwise have the same LensType, and are used by the Composite LensID tag when attempting to identify the specific lens model.
And if in ExifTool I export the metadata for my test image I get a Composite section at the end which includes:

QuoteQuote:
Lens ID : Sigma 70-200mm F2.8 EX DG Macro HSM II or Sigma 50-150mm F2.8 II APO EX DC HSM or Sigma 50-200mm F4-5.6 DC OS
Horrible.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
70-200mm, canon, dg, f2.8, hsm, lens, lightroom, metadata, os, pentax, photography, photoshop, sigma
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lens focal length wrong in metadata Marcus Rowland Pentax SLR Lens Discussion 5 01-16-2020 09:57 AM
Adobe Lightroom 5.7 doesn't show lens in metadata OldChE Digital Processing, Software, and Printing 7 12-16-2015 10:47 AM
Correct lens not shown in lightroom 5.7 metadata - only pentax OldChE Digital Processing, Software, and Printing 2 01-03-2015 08:57 AM
Wrong Lens Profiles / names in Metadata Omege_Matze Digital Processing, Software, and Printing 9 11-08-2014 03:53 AM
Nature Wrong Lens, Wrong time, Wrong…………. lukulele Post Your Photos! 4 05-08-2014 03:11 AM



All times are GMT -7. The time now is 06:31 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top