Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-14-2022, 09:32 AM - 3 Likes   #1
Reboot before calling IT
Loyal Site Supporter
madison_wi_gal's Avatar

Join Date: Sep 2016
Location: Madison WI
Photos: Gallery | Albums
Posts: 516
Found a DxO PL bug! (No free T-shirt though)

Passing stuff through DxO PL 5.2.3.66 (latest) Mac OS caused this:

RAW file taken at (example) EXIF says:
DateTimeOriginal : 2022:06:04 16:42:01
CreateDate : 2022:06:04 16:42:01

When exported as DNG or sent to DCU, this happens:

DateTimeOriginal : 2022:06:04 21:42:01
CreateDate : 2022:06:04 16:42:01

DxO is adding 5 hours to the export.
Opened case, sent to DxO.

They responded:

"We have heard back from our development team. They thank you for the file you sent to us, and they can confirm that this issue is due to an incorrect timezone of +00:00 being incorrectly added to exported files. This issue has been fixed recently and will be available in the upcoming PL 5.3 release."


I am not aware if this happens with Windows version, Windows users should check.

I had to fix dates with exiftool "-DateTimeOriginal<CreateDate"

06-14-2022, 09:53 AM - 1 Like   #2
Loyal Site Supporter
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 23,958
I only export jpg from DXO and I havenít been looking for this but I will in the future. Thanks. I use windows so when I have time I can check the jpg export.
06-14-2022, 09:57 AM   #3
Reboot before calling IT
Loyal Site Supporter
madison_wi_gal's Avatar

Join Date: Sep 2016
Location: Madison WI
Photos: Gallery | Albums
Posts: 516
Original Poster
QuoteOriginally posted by UncleVanya Quote
I only export jpg from DXO and I havenít been looking for this but I will in the future. Thanks. I use windows so when I have time I can check the jpg export.
Just checked and JPG does the same. I asked them about DNG since that is what I was using


DateTimeOriginal : 2022:06:08 15:15:08
CreateDate : 2022:06:08 10:15:08
OffsetTime : -05:00
OffsetTimeOriginal : -00:00
06-14-2022, 10:13 AM - 1 Like   #4
Loyal Site Supporter
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 23,958
Interesting. Is it every export or just those to DCU? Or do you export to a file system? Do you ever export directly to Flickr?

06-14-2022, 10:41 AM   #5
Reboot before calling IT
Loyal Site Supporter
madison_wi_gal's Avatar

Join Date: Sep 2016
Location: Madison WI
Photos: Gallery | Albums
Posts: 516
Original Poster
QuoteOriginally posted by UncleVanya Quote
Interesting. Is it every export or just those to DCU? Or do you export to a file system? Do you ever export directly to Flickr?
It is every export from DxO to [whatever else, but I did not test TIFF]. Normally I just export the DNG with all corrections either as a file to the file system or directly into DCU. They needed the original SD card file plus the sidecar (.dop file) to rule out any DCU silliness. I happened to have an exported .jpg from my test and exiftool confirmed the +5 hour thing.

I'm used to using exiftool to get lenses into a place where Flickr can see them, so it was not a hardship to change the dates, but since I am in IT I tend to want to know WHY things happen and not just kludge a fix.
06-14-2022, 10:57 AM   #6
Loyal Site Supporter
Loyal Site Supporter




Join Date: May 2007
Location: Flagstaff, Arizona
Posts: 1,324
QuoteOriginally posted by madison_wi_gal Quote
DxO is adding 5 hours to the export.
Opened case, sent to DxO.
Sounds like a bug of some kind, but ...

What time (zone) do you have your computer set for? I have sometimes seen dates on photo files with 3 hour offsets from what they should be, which I have ascribed to (perhaps) an EDT versus MST difference (not sure why!). This makes various file comparison programs useless, it they want include the time in their comparions.
06-14-2022, 11:48 AM   #7
Reboot before calling IT
Loyal Site Supporter
madison_wi_gal's Avatar

Join Date: Sep 2016
Location: Madison WI
Photos: Gallery | Albums
Posts: 516
Original Poster
QuoteOriginally posted by AstroDave Quote
Sounds like a bug of some kind, but ...

What time (zone) do you have your computer set for? I have sometimes seen dates on photo files with 3 hour offsets from what they should be, which I have ascribed to (perhaps) an EDT versus MST difference (not sure why!). This makes various file comparison programs useless, it they want include the time in their comparions.
Time zone was fine. DxO verifies this is their bug.

06-14-2022, 01:25 PM - 1 Like   #8
Loyal Site Supporter
Loyal Site Supporter
Madaboutpix's Avatar

Join Date: Dec 2011
Location: North Rhine-Westphalia
Posts: 1,227
No EXIF irregularities found in my recent exports from Pentax DNG to full-size JPEG in Central European Summer Time. I'm running PL5 Elite v5.2.1 on a Windows 10 machine. If there was a problem, image info should be wrong on SmugMug as well, but all displays correctly. Interesting though that there seems to be a bug in the Mac version.
06-14-2022, 02:05 PM   #9
Reboot before calling IT
Loyal Site Supporter
madison_wi_gal's Avatar

Join Date: Sep 2016
Location: Madison WI
Photos: Gallery | Albums
Posts: 516
Original Poster
QuoteOriginally posted by Madaboutpix Quote
No EXIF irregularities found in my recent exports from Pentax DNG to full-size JPEG in Central European Summer Time. I'm running PL5 Elite v5.2.1 on a Windows 10 machine. If there was a problem, image info should be wrong on SmugMug as well, but all displays correctly. Interesting though that there seems to be a bug in the Mac version.

Ok, good to know, thanks for checking.
06-14-2022, 04:11 PM   #10
Site Supporter
Site Supporter
Larrymc's Avatar

Join Date: Jun 2014
Location: Mississippi, USA
Posts: 4,927
QuoteOriginally posted by madison_wi_gal Quote
Passing stuff through DxO PL 5.2.3.66 (latest) Mac OS caused this:

RAW file taken at (example) EXIF says:
DateTimeOriginal : 2022:06:04 16:42:01
CreateDate : 2022:06:04 16:42:01

When exported as DNG or sent to DCU, this happens:

DateTimeOriginal : 2022:06:04 21:42:01
CreateDate : 2022:06:04 16:42:01

DxO is adding 5 hours to the export.
Opened case, sent to DxO.

They responded:

"We have heard back from our development team. They thank you for the file you sent to us, and they can confirm that this issue is due to an incorrect timezone of +00:00 being incorrectly added to exported files. This issue has been fixed recently and will be available in the upcoming PL 5.3 release."


I am not aware if this happens with Windows version, Windows users should check.

I had to fix dates with exiftool "-DateTimeOriginal<CreateDate"
Just curious, why are you exporting any DNG file from PhotoLab 5 Elite to any other editing program, especially DCU? You should be able to do 95 or more percent of your edits in PhotoLab 5 Elite. Oh and BTW, my EXIF data is correct. I use Windows 10.
06-14-2022, 05:17 PM   #11
Reboot before calling IT
Loyal Site Supporter
madison_wi_gal's Avatar

Join Date: Sep 2016
Location: Madison WI
Photos: Gallery | Albums
Posts: 516
Original Poster
QuoteOriginally posted by Larrymc Quote
Just curious, why are you exporting any DNG file from PhotoLab 5 Elite to any other editing program, especially DCU? You should be able to do 95 or more percent of your edits in PhotoLab 5 Elite. Oh and BTW, my EXIF data is correct. I use Windows 10.
1 - was using DCU before I bought DxO so I am used to it, and I have low expectations.
2 - I like Satobi.
3 - Yes, the bug appears to only be for MacOS
06-15-2022, 08:03 PM - 1 Like   #12
Site Supporter
Site Supporter
Larrymc's Avatar

Join Date: Jun 2014
Location: Mississippi, USA
Posts: 4,927
QuoteOriginally posted by madison_wi_gal Quote
1 - was using DCU before I bought DxO so I am used to it, and I have low expectations.
2 - I like Satobi.
3 - Yes, the bug appears to only be for MacOS
Since you like SATOBI I just posted a comparison of my PhotoLab version of SATOBI and the DCU Custom image SATOBI. I can supply the PL Preset if anyone cares to use it just let me know.
06-16-2022, 05:27 AM - 1 Like   #13
Loyal Site Supporter
Loyal Site Supporter
UncleVanya's Avatar

Join Date: Jul 2014
Photos: Gallery | Albums
Posts: 23,958
QuoteOriginally posted by Larrymc Quote
Since you like SATOBI I just posted a comparison of my PhotoLab version of SATOBI and the DCU Custom image SATOBI. I can supply the PL Preset if anyone cares to use it just let me know.
Yes please. Maybe an article showing how to create one and save it would also be good?
06-16-2022, 09:33 AM - 1 Like   #14
Site Supporter
Site Supporter
Larrymc's Avatar

Join Date: Jun 2014
Location: Mississippi, USA
Posts: 4,927
QuoteOriginally posted by UncleVanya Quote
Yes please. Maybe an article showing how to create one and save it would also be good?
I'll have to give the article some thought but the best way is to load the preset on a DNG file and check the settings that show in the develop module palettes. Once the preset is imported into PL all that need to be done is click on the "Apply Preset button at the top right of the PhotoLab screen and scroll down to select the preset.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
dxo, dxo pl, file, issue, photography, photoshop, pl, windows
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
DxO Pure RAW vs DxO Photo Lab 5 madison_wi_gal Digital Processing, Software, and Printing 14 06-06-2022 09:54 AM
No Camera yet. Set on a K-50 though Smokinthunder1 Welcomes and Introductions 13 11-21-2013 07:42 PM
Landscape A series of Anglesey photographs - No Kate Middleton or Prince William though !! simonkit Post Your Photos! 3 01-02-2013 04:52 AM
Marumi DHG PL or Helipan Linear PL crontax Troubleshooting and Beginner Help 9 06-13-2012 07:13 AM
Leaf...? No, Bird...? No, Bug...? No... Michaelina2 Post Your Photos! 3 04-21-2009 10:19 PM



All times are GMT -7. The time now is 09:02 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top