Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-25-2008, 07:50 AM   #1
New Member




Join Date: Mar 2008
Location: England
Posts: 2
Problems with lenses for K10D

I have a K10D and have just got hold of a SAKAR Auto 2 x teleconverter. Obviously this teleconverter is completely manual and I am happy to use the camera in Manual focus mode in order to utilise this lens along with the other lenses I have for the camera.

When I connect the teleconverter and another lens to the camera on the F setting it shows F-- which I expected.

However if I choose M on the mode dial, no matter what speed I set the camera to, I get very dark images and appear to be unable to rectify this. Can anyone suggest anything??I am a bit of an amateur when it comes to photography, but love the camera and hope to get the most out of it. The other lenses I have are the standar 18-55 that came with the camera and two lenses that I had from my previous MZ-7 (80-320mm and standard 18-80mm)

Many Thanks

03-25-2008, 08:46 AM   #2
Pentaxian




Join Date: Apr 2007
Location: Sweden
Posts: 2,102
Since it will be fully manual (I guess the converter doesn’t have any electrical contacts) only lenses with a manual aperture ring will work. And to use these you will have to change a setting in the camera (it’s a change once and forget about it setting), something like “allow aperture ring” or something similar. Then it will work with the camera in Manual mode. Use the green button to stop down the lens before shooting.
03-25-2008, 11:44 AM   #3
New Member




Join Date: Mar 2008
Location: England
Posts: 2
Original Poster
Took a look at the camera and tried out what you said - it all worked so many thanks.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, k10d, lens, lenses, mode, photography, teleconverter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone with K10D problems? uchesn Troubleshooting and Beginner Help 3 09-27-2010 11:08 PM
What are problems with old lenses? jeryst Pentax SLR Lens Discussion 13 01-31-2010 10:23 PM
Other Pentax lenses with AF problems? seacapt Pentax SLR Lens Discussion 1 01-19-2009 08:19 AM
K10d problems- please help Bokeh Pentax DSLR Discussion 4 05-11-2008 07:58 AM
K10D Problems Toonahfish Pentax DSLR Discussion 3 06-26-2007 04:41 AM



All times are GMT -7. The time now is 07:43 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top