Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-01-2011, 01:03 PM   #1
Site Supporter




Join Date: Apr 2009
Location: Hilo, HI
Posts: 70
Help! Pentax 67 blank frames/shutter issue

Hi,

I recently acquired a new (to me, anyway) 67 body from eBay, and I'm having an issue where I get a number of totally blank frames on a roll of film.

On the first roll, there was only one such blank frame, so I attributed it to user error (exposing with the lens cap on, etc). But on the second roll, there were four totally blank frames, and one partially blank frame! I shot that one in the span of about half an hour, and I can say with confidence that I didn't take photos of the lens cap four and a half times.




The cause that immediately comes to mind is the 2nd shutter being out of sync with the first shutter.

Before I send this one off to Eric for a CLA, has anybody had a similar issue/know any possible fixes?

03-02-2011, 05:19 AM   #2
Veteran Member




Join Date: Feb 2008
Photos: Gallery | Albums
Posts: 419
Try a fresh battery; I've had missed frames caused by a weak battery
03-02-2011, 09:53 AM   #3
Pentaxian




Join Date: Jul 2009
Location: Seattle
Posts: 7,068
QuoteOriginally posted by kkado Quote
Hi,

The cause that immediately comes to mind is the 2nd shutter being out of sync with the first shutter.
Are you using a leaf shutter lens? It looks like there is only one large fabric shutter.
03-02-2011, 05:35 PM   #4
Site Supporter




Join Date: Apr 2009
Location: Hilo, HI
Posts: 70
Original Poster
I haven't been using a leaf shutter lens, just the 105/2.4. What I mean is, I think the second shutter curtain is sticking to the first shutter curtain.

The thing that puzzles me is that I'm using a brand new PX28L! I will do more testing tonight to figure out if cold temperatures are causing the shutter/battery to fail.

03-02-2011, 06:42 PM   #5
Pentaxian




Join Date: Jul 2009
Location: Seattle
Posts: 7,068
Are you familiar with the process setting the camera to fire without film in it? Set that way, you maybe could remove the lens, lock up the mirror, put your thumb in place to keep the mirror up and fire the camera watching the shutter. It all happens so fast though.

My 67 only has one shutter curtain. A large fabric shutter that opens left to right when viewed with the back open. So I'm a little confused when you say the second shutter.
03-02-2011, 07:53 PM   #6
Site Supporter




Join Date: Apr 2009
Location: Hilo, HI
Posts: 70
Original Poster
Yes, I've tried dry firing the camera to observe the shutter, and I think I've isolated the cause. It seems to happen when the camera body is cold (I stuck it in the refrigerator, so about 35-40F). In this case, the 1/1000th and 1/500th speeds do not work consistently. It does not matter whether the battery is warm or cold. Here's a screengrab from video I took of the shutter, when it's working at 1/1000th:



When it isn't working, you cannot anything through the shutter.

The shutter does not really have a diagonal opening, it is just an artifact of the video camera's "rolling shutter." Most focal plane shutters are designed with 2 curtains; with faster speeds, the second curtain follows the first curtain so that only a small slit of light exposes the image:

03-02-2011, 08:04 PM   #7
Pentaxian




Join Date: Jul 2009
Location: Seattle
Posts: 7,068
Interesting. Are you generically saying 67 or do you mean the 67 generation of the camera given there are a non-MLU 6x7, 6x7, 67 and 67II versions of the camera?
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, cap, frame, frames, half, issue, lens, medium format, roll, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
K10D shutter issue - easy to fix? Christine Tham Pentax DSLR Discussion 18 02-12-2011 07:16 PM
Shutter release half-press issue? dcshooter Pentax K-5 15 01-19-2011 03:33 PM
Pentax K-X Shutter or Sensor Issue Due to Moisture Adam B Pentax DSLR Discussion 4 11-10-2010 12:19 PM
K10D corrupted/blank images issue Mart Pentax DSLR Discussion 6 10-31-2009 12:42 PM
ME super Shutter issue, help winglik Pentax Film SLR Discussion 0 03-01-2009 01:38 PM



All times are GMT -7. The time now is 11:27 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top