Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-08-2011, 06:31 AM   #1
New Member




Join Date: Mar 2011
Location: Shelbyville, Indiana
Posts: 2
6x7II Film Advance Lever Wont Wind

Greetings Pentax people... I have a 6x7II with several lenses that I've enjoyed for about six years. Love the large negs. Had to buy a medium format neg scanner to go digital with it. Have had an issue of late... can't advance the film lever. Have replaced the batteries, everything shows up in the window and in the viewfinder so I believe it's not electrical. Have put on and taken off the lens that I keep on it (45mm wide angle) and still no advance. Have put film into camera in case it won't wind because of lack of film... still not winding. Lever seems to be locked in position. Just wondering if anyone has any ideas about what I should check before i have to bring it in for service. Any help will be greatly appreciated. Marty

03-08-2011, 07:22 AM   #2
Forum Member




Join Date: Jan 2008
Location: MONTREAL, QUÉBEC, CANADA
Photos: Albums
Posts: 79
Hello adprousa,
I had a similar problem with my 67II in 2009. I send it to Pentax Canada for repair. It was an electronical piece that was not working. No advance, no shutter without this. It cost me around 500$ Canadian but I did accept the repair. Everything is working fine now. Best luck with your's. If you need more help, send me a PM. GB
03-08-2011, 07:43 AM   #3
Pentaxian




Join Date: Jan 2011
Location: 5th floor
Posts: 1,327
I am sorry about your recent travel. It is a travesty.

But, could this be the divine intervention that you might have been waiting for so that you can finally move on to 645D???

Just trying to be half full.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
advance, camera, film, film advance lever, lever, medium format, wind
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
P30 Wind Lever Doesn't Wind Complete Cycle - Any ideas? pengam Pentax Film SLR Discussion 14 08-31-2015 06:08 AM
ME Super advance lever not returning darrenleow Pentax Film SLR Discussion 2 01-25-2010 01:10 PM
LX Wind Lever Cap SOldBear Pentax Film SLR Discussion 4 07-15-2009 08:27 PM
Me-super rapid wind lever not returning properly Heldur Pentax Film SLR Discussion 13 10-10-2008 12:45 AM
ME Super film advance lever problem! Thursday Pentax Film SLR Discussion 8 09-12-2007 12:07 AM



All times are GMT -7. The time now is 11:02 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top