Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-05-2011, 08:46 PM   #1
Inactive Account




Join Date: May 2011
Location: Burbank CA
Posts: 9
645 Meter Issue

I posted about a week ago about how I was having problems with my new to me 645.

I now have new batteries in the handle and the CR1220 in the base of the camera.
It seems to do more things but it still doesn't do what it's supposed to.

Do these need to be flashed or have their memories reset in some way? I've followed the manual but I've had no luck.

What I guess I need is someone local to me in Burbank Calif. to either show how to set this up correctly or recommend a tech in the area that can give the camera a once over for me and figure out what's wrong.

Any suggestions?

Thanks

Eric

06-06-2011, 03:51 AM   #2
Pentaxian




Join Date: Sep 2009
Location: Southern California
Photos: Gallery | Albums
Posts: 3,181
Contact Fontan on the forum here. He's got a 645D and lives in So. Cal., so see if he knows anything. I know he really likes his 645D - I'm not sure if he's back from Ireland with it yet, but he's a good guy.
06-08-2011, 02:08 PM   #3
Senior Member
klaus123's Avatar

Join Date: Apr 2011
Location: Germany
Posts: 210
Have you tried to put a film in? W/o my 645 does not measure the right way!
06-09-2011, 05:22 AM   #4
Inactive Account




Join Date: May 2011
Location: Burbank CA
Posts: 9
Original Poster
I haven't put a roll in as I didn't want to burn up a roll.

Is there any way to trick it into thinking it has a roll in?

Thanks

Eric

06-10-2011, 12:04 AM   #5
Senior Member
klaus123's Avatar

Join Date: Apr 2011
Location: Germany
Posts: 210
QuoteOriginally posted by 62sunbeam Quote
I haven't put a roll in as I didn't want to burn up a roll.

Is there any way to trick it into thinking it has a roll in?

Thanks

Eric
There is a test cover available to cheat tha cam - with that you can operate it w/o film
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
camera, medium format
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax Spotmatic light meter issue kcobain1992 Pentax Film SLR Discussion 18 02-27-2017 06:01 AM
Issue with my Pentax Analog Spot Meter V Bogie Troubleshooting and Beginner Help 2 03-12-2011 06:51 AM
Pentax Spotmatic F issue with light meter LosHollyBeach Pentax Film SLR Discussion 7 12-30-2010 05:57 PM
Original 645 Meter Halco Pentax Medium Format 2 05-05-2010 04:23 PM
645 Issue Halco Pentax Medium Format 4 03-18-2010 08:18 PM



All times are GMT -7. The time now is 03:25 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top