Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-25-2011, 01:22 PM   #1
Pentaxian




Join Date: Feb 2009
Location: Arizona
Posts: 867
P67 Zoom Base Plate Issue--90-180

Recently I noticed a really bad flare on several of my slides and just attributed it to my not using the lens hood. Then I noticed, when using the 90-180 with tubes, there was a gap between the tube and lens. I thought it was a tube problem but that was not the case. The base plate at the rear of this lens was loose and believe it was the cause of the flare. All 6 screws were loose. If you have this lens, it is probably a good idea to check the rear plate.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
base, base plate, camera, flare, lens, medium format, plate, tube
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
anyone know where i can get MX base plate screws? JDaughtry Pentax Film SLR Discussion 5 08-08-2011 08:34 AM
Lost Base Plate For Manfrotto Head Ira Pentax Camera and Field Accessories 11 09-10-2010 12:46 PM
Reversing ring for P67 alfa Pentax Medium Format 3 04-02-2010 06:06 PM
Optical cross section for 90-180 Zoom? desertscape Pentax Medium Format 2 04-26-2009 01:22 PM
AF540FGZ flash issue - M. Zoom all the time dugrant153 Flashes, Lighting, and Studio 6 11-10-2007 12:36 AM



All times are GMT -7. The time now is 10:02 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top