Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
10-18-2011, 05:39 PM   #1
New Member




Join Date: Oct 2011
Posts: 2
Pentax 67ii service manual

Does anybody have a copy of Pentax 67ii service manual? The only one I managed to find on the web belongs to older 6x7. Got a strange problem with the shutter, gathering up courage to disassemble the body.

Thanks in advance.

02-18-2012, 09:27 AM   #2
New Member
iczek's Avatar

Join Date: Feb 2012
Posts: 5
Still need one? I have a copy.
02-18-2012, 04:38 PM   #3
Inactive Account




Join Date: Dec 2010
Location: Stockholm
Posts: 224
QuoteOriginally posted by iczek Quote
Still need one? I have a copy.
I'd really want one! My metering prism is dead. PM?
02-20-2012, 09:06 AM   #4
Senior Member




Join Date: Jun 2010
Location: Hamburg
Posts: 267
what happened to the prism, Makten?

02-20-2012, 10:08 PM   #5
Inactive Account




Join Date: Dec 2010
Location: Stockholm
Posts: 224
QuoteOriginally posted by phonoline Quote
what happened to the prism, Makten?
I don't know if it is the prism, but suddenly an error message ("PErr") appeared in the display and then the camera was stuck. This happened once before, but fixed itself after a while, but not so the last time.
Now I have to isolate the contacts between the prism and the body, and I can only use the camera with manual shutter speeds (full stops) without metering. This seems to be a fairly common problem with no solution.
02-21-2012, 03:08 AM   #6
New Member
iczek's Avatar

Join Date: Feb 2012
Posts: 5
Makten,
I have the same problem with my camera that I purchased from one of internet B&S list
After checking in local authorized Pentax service I know that my case is called: T100
Main board is failure.

Firstly, you should check the mechanism of the lens that push the aperture needle in the body. Than, check the electronic of the main board.
I do not know what is worst.... bad prism or bad main board
02-21-2012, 10:17 AM   #7
Inactive Account




Join Date: Dec 2010
Location: Stockholm
Posts: 224
QuoteOriginally posted by iczek Quote
Makten,
I have the same problem with my camera that I purchased from one of internet B&S list
After checking in local authorized Pentax service I know that my case is called: T100
Main board is failure.

Firstly, you should check the mechanism of the lens that push the aperture needle in the body. Than, check the electronic of the main board.
I do not know what is worst.... bad prism or bad main board
Ah! Failure of the aperture mechanism would make a lot of sense, because the problem came when I attached my extension tube, which doesn't have a coupling for the aperture. So maybe something went wrong there. But still, the aperture works fine in manual mode.
02-21-2012, 10:28 AM   #8
New Member
iczek's Avatar

Join Date: Feb 2012
Posts: 5
QuoteOriginally posted by Makten Quote
Ah! Failure of the aperture mechanism would make a lot of sense, because the problem came when I attached my extension tube, which doesn't have a coupling for the aperture. So maybe something went wrong there. But still, the aperture works fine in manual mode.
My prism also works with manual mode one the lens. I think that your prism is ok as well as mine. The problem could be the mechanic only.
Please, let me know one thing... could you switch the meter mode on prism to multi-matrix and check if you can see the correct icon displayed in viefinder?
In ma case there is a problem with this icon displaying.

03-16-2012, 08:22 AM   #9
New Member
EdoNork's Avatar

Join Date: Mar 2012
Posts: 7
I'm interested in a copy too.
03-16-2012, 01:13 PM   #10
New Member




Join Date: Sep 2010
Location: NYC
Posts: 2
Me three. If electronic, I'd be happy to host it.
03-21-2012, 04:04 PM   #11
New Member




Join Date: Mar 2012
Location: Ogden, Utah, USA
Posts: 10
I would really like a copy too, please. I'm a new owner of a Pentax 67ii. Any help would be welcome.
03-23-2012, 05:46 PM   #12
New Member




Join Date: Oct 2011
Posts: 2
Original Poster
Here it is:
Pentax67iiSM.pdf
03-24-2012, 01:29 AM   #13
New Member




Join Date: Mar 2012
Location: Ogden, Utah, USA
Posts: 10
iczek, would you shoot me a copy of the repair manual please?
03-24-2012, 12:54 PM   #14
New Member
EdoNork's Avatar

Join Date: Mar 2012
Posts: 7
Thank you vary much swilf!
09-24-2012, 03:21 AM   #15
New Member




Join Date: Sep 2012
Posts: 3
hi to all

anyone can reupload the file ? in advance, many thanks
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
67ii, camera, medium format, pentax, pentax 67ii service, service
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone have a K20D Service manual please? JohnX Pentax DSLR Discussion 5 10-05-2011 01:44 AM
ME Super Service Manual pandarocket Pentax Film SLR Discussion 20 03-17-2010 12:32 PM
Pentax digital spotmeter - service manual SquintyEyes Pentax Camera and Field Accessories 5 12-08-2009 04:23 PM
Need service manual for a PZ-1p. Bob 256 Pentax Film SLR Discussion 6 07-17-2008 07:47 AM



All times are GMT -7. The time now is 06:57 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top