Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
01-10-2012, 04:40 PM   #1
New Member




Join Date: Nov 2011
Posts: 10
645D Shutter Jam?

Purchased a 645D in late October and have been very happy with it. Today however it appears that the shutter has jammed---eg: no images recorded, mirror goes up but shutter does not open. Have tried 3 sd card, fresh battery, reset to factory default, nothing worked. Took off the lens which I dont like doing due to dust to visually see if shutter would open during B setting or 1 sec and would shutter does not open. Am I missing something?

Thoughts? Would really prefer that the problem be a goofy error on my part. Am not wanting to send in for repair if possible.
Have been most happy with the camera--check images at www.markludak.com
Thanks
Mark

01-10-2012, 05:14 PM   #2
Veteran Member




Join Date: Oct 2008
Photos: Gallery
Posts: 351
Take a look and see if you've bumped the Mirror lock-up switch/dial, I'll bet that's it.

I've done ait a few times getting the camera out of the bag, with the shutter, click ...... nothing, what's it waiting for???? D'oh!!

Hope it's something simple like this.
01-10-2012, 06:08 PM   #3
New Member




Join Date: Nov 2011
Posts: 10
Original Poster
No such luck re: mirror. Will pack it up and ship it out tommorrow.
01-11-2012, 07:21 PM   #4
Junior Member
jimpurcell's Avatar

Join Date: Dec 2006
Location: Tucson
Photos: Albums
Posts: 45
Sorry to hear about that mludak! Warped, I can't tell you how many times I hit that mirror lack switch taking my camera out of the bag and couldn't get it to work. I think it took a good 5,6 times before I started to check that first.

01-12-2012, 02:19 AM   #5
Pentaxian




Join Date: May 2011
Location: All over the place
Posts: 2,562
QuoteOriginally posted by jimpurcell Quote
Sorry to hear about that mludak! Warped, I can't tell you how many times I hit that mirror lack switch taking my camera out of the bag and couldn't get it to work. I think it took a good 5,6 times before I started to check that first.
Me too!
01-12-2012, 09:07 AM   #6
New Member




Join Date: Nov 2011
Posts: 10
Original Poster
Thanks all. I shipped it for overnight delivery (ouch) and hopefully a speedy repair. Was working and then ----nothing image wise----. Have to say Ive never had a shutter fail before so did not suspect it but it definitely does not open when it should. Could be mechanical, electrical, hard to tell these days.
01-12-2012, 08:18 PM   #7
Veteran Member




Join Date: Oct 2008
Photos: Gallery
Posts: 351
QuoteOriginally posted by jimpurcell Quote
Sorry to hear about that mludak! Warped, I can't tell you how many times I hit that mirror lack switch taking my camera out of the bag and couldn't get it to work. I think it took a good 5,6 times before I started to check that first.
The bag/backpack I use has the camera at the top and a velco/elastic strap across the base of the lens, right over the top of the mirror lock up switch. It's so easy to get the strap caught and flick the switch when grabbing the camera out of the bag quickly.

Still catches me out on occasions, but only takes that first "shot" not working to go "D'oh!!" and realise what I've done now.
01-12-2012, 10:03 PM   #8
Pentaxian




Join Date: Jan 2011
Location: 5th floor
Posts: 1,327
You should be able to utilize their "pro" service, no?

01-13-2012, 03:06 PM   #9
New Member




Join Date: Nov 2011
Posts: 10
Original Poster
Yes, the camera qualifies for an expedited service repair, which is really necessary in this case.
01-13-2012, 04:37 PM   #10
Pentaxian




Join Date: Jan 2011
Location: 5th floor
Posts: 1,327
QuoteOriginally posted by mludak Quote
Yes, the camera qualifies for an expedited service repair, which is really necessary in this case.
Or, perhaps they can give you a loaner too? Hopefully the repair will not take long . . . . It just worries me because of all the stupid horror stories with K-5 saga. I would very much be interested in your experience with this process to see how "professional" it really is. Thankfully, I have not had any issues with mine so far.. Again, I hope you get your "D" back soon.
01-14-2012, 07:05 AM   #11
New Member




Join Date: Nov 2011
Posts: 10
Original Poster
It's "in repair" status right now, and I am hoping it is nothing really problematic. Ive been using the camera for 8 weeks and can't imagine its been much of a workout for the camera by real world standards. Not sure why it would fail. Will let you know when I hear more.
01-17-2012, 02:35 PM   #12
Site Supporter
jackinkc's Avatar

Join Date: Dec 2011
Location: Kansas City, Missouri
Posts: 118
QuoteOriginally posted by mludak Quote
Thanks all. I shipped it for overnight delivery (ouch) and hopefully a speedy repair. Was working and then ----nothing image wise----. Have to say Ive never had a shutter fail before so did not suspect it but it definitely does not open when it should. Could be mechanical, electrical, hard to tell these days.
Tell us how this works out.
01-23-2012, 01:50 PM   #13
New Member




Join Date: Nov 2011
Posts: 10
Original Poster
Update on 645D---They are replacing the shutter. Could take two weeks--though read today that the shutter is back ordered. A loaner was offered and will probably take them up on the offer.
Regards
01-23-2012, 03:52 PM   #14
Forum Member




Join Date: Dec 2011
Posts: 90
Where did you read about the shutter being back-ordered?
01-24-2012, 07:58 AM   #15
New Member




Join Date: Nov 2011
Posts: 10
Original Poster
When the camera is in for repair there is a link to the Criscam (?) site which does repair work for Pentax in the United States. When you put in your work order number and your PPS number you are given information regarding the repair status.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
645d, 645d shutter, camera, images, medium format, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fault with ME Super, winder and shutter jam. lab rat Pentax Film SLR Discussion 10 01-28-2013 11:11 AM
100% compatible shutter release for 645d spacevoid8 Pentax Medium Format 9 07-14-2011 03:13 AM
Streets A tram jam RBullCZ Post Your Photos! 5 06-13-2011 09:55 AM
Rear curtain and slow shutter speed flash sync question for the 645D Warped Pentax Medium Format 9 01-28-2011 11:36 AM
K10D Mirror Jam winglik Pentax DSLR Discussion 3 03-27-2010 09:58 AM



All times are GMT -7. The time now is 11:28 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top