Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-25-2012, 04:24 PM   #1
New Member




Join Date: Nov 2012
Posts: 3
Help with 645 malfunction

Hi! My account is new here, but I've been using my Pentax 645 (the original) for a while and the resources on this forum have always helped out.

I'm hoping that someone's able to help out with a new malfunction in my camera. What happens is that every shot, the camera acts as if the batteries are dead. When it first happened, I manually advanced the camera and replaced the batteries, but the problem happened again.

Now, for every shot, the film doesn't advance and the mirror stays flipped up until manually advanced. It sounds like the shutter speeds are accurate, and the metering and other features are all working, only the film advance and mirror flip-up are failing.

If anyone has any help, it would be very appreciated! I hope it's just me doing something wrong. Thanks

11-26-2012, 06:36 AM - 1 Like   #2
Site Supporter
germar's Avatar

Join Date: Apr 2007
Location: Austin Texas
Photos: Gallery
Posts: 728
Branden, does the LCD stay on and show you your settings on top, or does it go blank as well? It sounds a lot like a low voltage issue, perhaps caused by dirty contacts in the battery compartment. Check for corrosion on any contacts and make sure that none of the metal contact tabs are bent. Good luck.
11-26-2012, 09:01 AM   #3
New Member




Join Date: Nov 2012
Posts: 3
Original Poster
Thank you, I will try that and report back
11-26-2012, 08:12 PM   #4
New Member




Join Date: Nov 2012
Posts: 3
Original Poster
QuoteOriginally posted by germar Quote
Branden, does the LCD stay on and show you your settings on top, or does it go blank as well? It sounds a lot like a low voltage issue, perhaps caused by dirty contacts in the battery compartment. Check for corrosion on any contacts and make sure that none of the metal contact tabs are bent. Good luck.
I agree, this sounds exactly like a low voltage issue, just like when the batteries are nearly dead. Yes, the LCD on top stays on, and the metering in the viewfinder works as well.

Ok, I removed the grip and battery compartment, and cleaned all the contacts with isopropanol. Nothing inside looked bent. Replaced it all, same error. If this is a wiring issue internal to the camera, what are my options? Does anyone offer repair/rebuild services for these cameras any more? Or is it cheaper just to get another?

Thanks for your help!

11-30-2012, 10:04 PM   #5
Inactive Account




Join Date: Jun 2012
Location: Winnipeg, Canada
Posts: 10
I had one battery holder start that and still doing the same thing after cleaning, I slightly sprung/stretched out the contacts in the holder and the problem disappeared.
12-07-2012, 02:24 PM   #6
Veteran Member
revdocjim's Avatar

Join Date: Jan 2011
Location: Mt. Akagi, Gunma Prefecture
Posts: 374
If you can't fix it easily by cleaning or bending the contacts I would just get another one. i've owned 4 of them and never paid more than $50. No one will do a repair for that price.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
advance, batteries, camera, film, help, malfunction, medium format, mirror, shot
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
[HELP] PROBLEMS 645 lens with K-5 !!! Omnis Pentax Medium Format 14 11-04-2012 12:26 PM
help with K-5 malfunction sholtzma Pentax K-5 4 06-23-2012 04:31 PM
help with a 645 Prox-iee Pentax Medium Format 2 01-13-2010 07:37 AM
help with 645 or compatable lenses edwardian Pentax Medium Format 4 07-31-2009 07:35 PM
Help with a new -old 645 spartan Pentax Medium Format 5 03-25-2009 06:57 PM



All times are GMT -7. The time now is 10:09 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top