Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-20-2013, 02:24 PM   #1
New Member




Join Date: Aug 2013
Posts: 16
645D shutter speed weirdness

I've been shooting with my 645D for about a month now and love the camera. I looked for every reason I could find to send it back but I'm blown away at how amazing a camera it is for the money. But there's one strange thing that the camera does every so often that makes me think there's something wrong with it. When changing the shutter speed, the camera will cycle through 4 stops and then loop back through the same 4 stops. For instance, if I'm at 1/15 and want to go to 1/125 I'll roll the dial and it will cycle through to 1/125 and then back to 1/15 while turning the wheel the same direction. I'm thinking this is some sort of "feature, not a bug" thing but I'm at a loss of why it does this. If I continue to roll the wheel in the same direction it will cycle through the shutter speeds again and then act normally.

Anyone else see this when using their 645D?

Thanks,

Bob

09-20-2013, 03:24 PM   #2
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,881
I assume you don't accidentally press the green button which in some modes resets the speed to the program line?

I didn't notice such behavior on any of the two cameras I have had the opportunity to use. Since the 645D is Weather Resistant the classic first attempt fix of spraying contact cleaner into the gaps around the e-dial won't work.
09-21-2013, 09:37 AM   #3
New Member




Join Date: Aug 2013
Posts: 16
Original Poster
QuoteOriginally posted by Ole Quote
I assume you don't accidentally press the green button which in some modes resets the speed to the program line?
I bet that's exactly what I'm doing. I had no idea the green button did that. Any way to turn that "feature" off?
09-21-2013, 03:02 PM   #4
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,881
You can customize what the green button does, it's probably done in the custom menu. I do not, however, have the manual for the menu system, so I can't help you any further.

09-24-2013, 07:55 AM   #5
New Member




Join Date: Aug 2013
Posts: 16
Original Poster
Custom function 29 turns off the green button. I was inadvertently hitting the green button while dialing the shutter speed dial and that was creating the "jumpy" speeds. Turned it off and no problems.

Thanks,

Bob
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
645d, camera, cycle, direction, medium format, roll, shutter, wheel
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
645D write speed jackinkc Pentax Medium Format 28 08-01-2012 03:39 AM
645D Slow Shutter Speed NR and really long exposures Ryan Tischer Pentax Medium Format 29 05-12-2012 11:30 PM
shutter speed Unregistered Visitors' Center 3 09-26-2011 01:25 PM
Pentax KX Shutter starting to stuck at slow shutter speed. Spirit722 Pentax Film SLR Discussion 7 03-03-2011 09:49 PM
Rear curtain and slow shutter speed flash sync question for the 645D Warped Pentax Medium Format 9 01-28-2011 11:36 AM



All times are GMT -7. The time now is 10:54 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top