Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
02-10-2014, 11:07 AM   #1
Veteran Member
eurostar's Avatar

Join Date: Dec 2006
Location: Albareto, Italy
Photos: Gallery
Posts: 813
Error E-20 (67II)

Having suggested to a friend of mine to buy the used 645D I wasn't enabled to, he gave me his old 67II that he hasn't used for many months. When we put a new set of battery on, the camera began to show E-20 in the display, and the shutter doesn't work at all, whatever time is set, including bulb.

Any idea wath the error means? Another friend of mine has said that could be a battery problem, but mine were new, plus I took them out and reinserted afterward, but nothing changed.

02-13-2014, 01:07 AM   #2
Loyal Site Supporter




Join Date: Nov 2013
Location: Alabama
Posts: 2,450
Maybe remove the battery, clean the contacts & reinstall?
02-13-2014, 03:33 PM   #3
Veteran Member
Silent Street's Avatar

Join Date: Nov 2011
Location: Snobsville & Hipsterville, Vic AUS
Posts: 445
Inspect the contacts in the battery chamber and clean them clean them with alcohol even if they look OK.
If there is any variation in the message like E20-1-2-3 you probably have an internal fault for service. I would think that if the message persists a check-up on the bench would be the wisest action.
02-19-2014, 08:06 AM   #4
New Member
EdoNork's Avatar

Join Date: Mar 2012
Posts: 7
Try cleaning the viewfinder contacts and reattach it.

Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
battery, camera, error, error e-20, friend, medium format, mine
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
"PErr" on 67II (metering error) Makten Pentax Medium Format 7 08-02-2011 12:16 PM
The E-P3 is here! Along with the E-PL3, E-PM1, and new lenses! jct us101 Non-Pentax Cameras: Canon, Nikon, etc. 35 07-25-2011 05:37 PM
E-10 Error on a Pentax 67 II rickbehl Pentax Medium Format 7 08-01-2010 05:12 PM
Olympus E-420 ($299) and E-520 ($399) kits on sale @ newegg today deadwolfbones General Talk 5 04-10-2009 05:49 AM



All times are GMT -7. The time now is 09:47 PM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top