Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-21-2014, 08:45 AM   #1
Senior Member




Join Date: Nov 2010
Location: Calgary, Alberta
Posts: 270
Odd aperture situation with 645Z

So, unless I'm doing something stupid (which is possible), the 645Z is presenting me with some speed bumps. As mentioned elsewhere I'm on my second Z body, having exchanged the first one out of the gate with a DOA phase detect autofocus system. (Contrast detect AF worked fine in Live View with all lenses, but phase detect AF would not function with all lenses.)

Unfortunately my second Z is doing something that I can't explain, but which appears wrong in any scenario I can think of. I've got a pretty varied kit of lenses from 67 to A to FA to new DA, but my workhorses really are a core set of FA 645 lenses -- the 45-85mm, 80-160mm, 150-300mm, 35mm and 400mm. Right now with all of these lenses, putting the Z in manual mode (where I shoot 98% of the time), the body will not accurately read the aperture I manually dial into the lens. Depending on which FA lens is mounted, the aperture I set on the lens reads somewhere betwen 0.5 and 2 stops lower on the body's digital readouts. E.g. I set f/11 on the 45-85mm, and the body reads f/8 instead. With the FA 400mm, I set f/11 on the lens and it reads f/5.6 on the body.

For whichever lens I mount, the disconnect between lens & body aperture is consistent for the whole aperture range on that lens. It's just that each lens may be out by a different amount. Note that putting all of these lenses on my 645D works fine; likewise on another D body I have access to. I've shot these lenses heavily for years, and they work. I'm 100% confident it's not the lenses.

As far as I can tell, my Z is doing this with all of my FA lenses including others like the FA* 300mm, FA 200mm, etc. It does not do this with my A lenses such as the A 35mm or 120mm macro -- setting aperture there agrees between lens and body. So to me that rules out a simple mechanical linkage problem between the lenses and the body, which was my first thought. With the single DA lens I have (the 25mm) it's really impossible to know what's going on without some rigorous test shots & exposure evaluations, because of the electronic aperture.

This problem was not present when I picked up this Z body. It happened after having it for a few days and shooting it successfully with a variety of lenses. When the problem came up the first time last week, I took it back to my local shop to sanity check what I was seeing. I played around with the camera with the guys, swapping my lenses and theirs between a couple of bodies, trying various settings, and eventually just hitting factory reset on mine a few times to wipe everything back to default. Eventually my body started working properly again with all my lenses. I thought "good, that's sorted but it was weird that it happened" and I went out again. One informal shooting session at a kid's football game went fine, but then yesterday the problem resurfaced doing some landscape shooting.

Right now I've evaluated every setting and custom function to try to reverse engineer some combination in my head that could produce this behavior as some kind of "feature", but I can't see it. I've also hit factory reset several times last night and this morning, but the body has not reverted to correct aperture readings. So I think there's something going on with this body. Not that I'm shy to do it whatsoever, but obviously I'd rather not have to exchange this body for a third one. If it's something I'm doing I need to understand what's causing it.

I'm heading out on a week-long shooting road trip this AM where the 645Z was going to factor heavily in my plans, so this is a speed bump. I could potentially shoot only my A lenses, or try to find some other work-around, but that's not ideal. I will swing by my shop before I hit the road this morning and see if the guys there have any more thoughts. But I wanted to throw it out to the PF forum to see if anybody has seen this or has an idea of anything I might be screwing up. TIA...

07-21-2014, 09:22 AM   #2
Pentaxian
RonHendriks1966's Avatar

Join Date: Jan 2009
Photos: Gallery
Posts: 8,714
Why wouldn't you use the setting on the camera with the lens in A-setting?


Have you tried Aperture-mode setting on the camera instead off M-mode?
07-21-2014, 09:28 AM   #3
Senior Member
climit's Avatar

Join Date: Aug 2010
Location: Kalamata
Posts: 224
apart from the wrong reading, does it expose correct or the jpegs are underexposed?
07-21-2014, 10:29 AM   #4
Senior Member




Join Date: Nov 2010
Location: Calgary, Alberta
Posts: 270
Original Poster
QuoteOriginally posted by RonHendriks1966 Quote
Why wouldn't you use the setting on the camera with the lens in A-setting?
If I can't be sure the lens and camera are talking correctly in manual aperture mode on the lens, which should be the simplest & most foolproof mode, then equally I can't be sure they will talk correctly in auto aperture on the lens. I did put the lens to "A" and set an aperture on the camera body. It says f/11 on the body for example, but without a bit more testing it's not clear whether the body really stops the lens down to f/11 or f/16 (or something else) when the exposure is made. I will check it though.

QuoteQuote:
Have you tried Aperture-mode setting on the camera instead off M-mode?
Good question. The first time this happened, last week, the body would not read the correct aperture in both Av and M modes. I checked just now and the body is not reading aperture properly in M, but it is in Av (and TAv for that matter). So this odd behavior is slightly different than last week. This could be a fallback for my shooting this week, if Av will stay working for a few more days.

---------- Post added 07-21-14 at 11:42 AM ----------

QuoteOriginally posted by climit Quote
apart from the wrong reading, does it expose correct or the jpegs are underexposed?
When the lens aperture is set manually on FA and A lenses via the aperture ring, the camera in M mode can't make a wrong exposure. The aperture in the lens is what the ring says and the shutter speed is what I've dialed in. I haven't confirmed 100% what happens in Av mode where the shutter speed is free to float according to what the camera decides. In theory because I've manually set the aperture on the lens ring, exposure might still work if the camera ignores the body aperture reading. But the reason I finally tripped that something was going weird was last week shooting in Av mode with some street type work, and getting exposures that didn't seem to be coming out right. I was doing everything on the fly through the viewfinder and dialing the lens aperture ring without looking at it (just looking at the viewfinder reading).

Regardless, I've shot a pair of 645D's for years with all of these lenses and I'm pretty familiar with how the digital 645's work. This is something I've never seen before. I haven't sat down to test this rigorously because my main concern right now is whether the camera is operating properly with some kind of "feature" that I just don't understand, or some combination of settings I've done that has thrown it off. Or whether it's in fact broken and I need to exchange again.

If I manually set aperture on the lens in M mode, I'm having a hard time thinking of correct operating mode where the body would report something different. But with the warranty on the Z appearing to drop down to 1 year (rather than the 2 years the 645D had, at least in Canada), I'm not predisposed to sit here ticking off the weeks on the calendar when out-of-box behavior isn't right in the first few days. But I'm trying to double check anything I might be missing before I turn into that "problem customer" who's always coming into the shop to exchange stuff just because I haven't done my own homework. LOL.


Last edited by Royce Howland; 07-21-2014 at 10:42 AM.
07-21-2014, 10:51 AM   #5
Senior Member
climit's Avatar

Join Date: Aug 2010
Location: Kalamata
Posts: 224
I suppose that the answer to your problem is that the body has no idea what the aperture you manually set is, when you are out of A on FA lenses, only guesses, and always shoots at maximum aperture as if the lens is wide open when in Av.
At least this is how it does on my two aps-c bodies.

Last edited by climit; 07-21-2014 at 12:34 PM. Reason: add a definition, correction
07-21-2014, 12:20 PM   #6
Senior Member
climit's Avatar

Join Date: Aug 2010
Location: Kalamata
Posts: 224
...only if you press the AV button it takes a light measurement to estimate exposure... in Manual mode and in a random aperture
Are you sure the 645D could read the lens aperture correct when the FA lens out of A?

Last edited by climit; 07-21-2014 at 12:37 PM. Reason: additional comment
07-21-2014, 01:32 PM   #7
New Member




Join Date: Oct 2013
Posts: 6
Royce:

I never use M mode however based on your post I gave it a try with a few FA lenses and I get the same results as you, so it may be a software issue.
07-21-2014, 03:56 PM   #8
Site Supporter




Join Date: Feb 2010
Location: Saskatchewan
Posts: 248
same thing is happening on my camera - piece of junk. But then again, the number of times I shoot manual in a year can be counted with two fingers with their tips together.

07-21-2014, 04:37 PM   #9
Pentaxian




Join Date: May 2011
Location: All over the place
Posts: 2,579
Exactly the same for me. I have had the auto focus not do anything for a while as well - a soft reset (pulling the battery out while switched on, has solved this when it happens....I suspect the first firmware update is going to be a major one, but going by the D Pentax don't do too many of these.

I have a contact at Pentax UK at the high end, think I will drop her an email....which I have just done, he/she is the Service Coordinator for Pentax Ricoh UK.

I had an instance yesterday when in Av, the camera decided it would select f/32 on the 55-110 when I had it set to f/8 and gave me an exposure of 1/13 which left it totally overexposed. It only happened the once.

I have asked the Service Coordinator for Pentax Ricoh UK when we might expect a firmware update as there were only a few for the D in its whole product life.

Last edited by itshimitis; 07-21-2014 at 04:56 PM.
07-21-2014, 05:24 PM   #10
Ole
Administrator
Ole's Avatar

Join Date: Sep 2006
Location: Copenhagen, Denmark
Photos: Gallery | Albums
Posts: 3,879
The 645Z we have in for PF in-depth review behaves similarly with the FA 45-85mm zoom:
- In Av mode it correctly shows the F-stop set on the lens, i.e. you set F11, it shows F11
- in M and X mode it shows a wrong value, exactly one stop faster, i.e. you set F11, it shows F8, you set F8 and it shows F5.6. At the lower end of the scale it always shows F4.5 (you set F6.7, 5.6, or F4.5, and it shows F4.5)
- The other auto-exposure modes (P, TAv, etc) show the correct value set just like Av mode.

The camera behaves correctly with the A 55mm F2.8 prime, i.e. the F-stop set on the lens is reported correctly in all exposure modes.

It must be a bug in the firmware.
07-21-2014, 07:43 PM   #11
Veteran Member
Thomasbrowphoto's Avatar

Join Date: May 2014
Location: NSW, Australia
Posts: 335
I just check my 45-85 on the 645Z, and like you I do all of my shooting in Manual mode. Mine also says f8 when manually selected f11 on the lens. I guessing a firmware update should resolve this.
07-21-2014, 08:40 PM   #12
Site Supporter




Join Date: Feb 2010
Location: Saskatchewan
Posts: 248
what does the metadata agree with when you take the shot and is the exposure off? I haven't looked on mine and may not have time tomorrow.
07-21-2014, 11:46 PM   #13
Forum Member
jonojono's Avatar

Join Date: May 2014
Posts: 81
happens to me as well on M mode.

question, does any experience with their A lens that aperture selection from the dial does not work on any of the modes and you have to turn it manually? is it supposed to be like that? happens on my 35A
07-22-2014, 01:08 AM   #14
New Member




Join Date: Jul 2014
Posts: 8
Same here, 645Z when using my 120mm macro with M or B mode, the aperture setting is report incorrectly when changing the aperture from the lens instead of the wheel build into the camera.
07-22-2014, 06:31 AM   #15
Site Supporter




Join Date: Feb 2010
Location: Saskatchewan
Posts: 248
1. my 35A aperture will work off the camera dial;
2. so, at least with my 45-85FA, when in manual and using the lens to select the aperture, metering is based on the camera-indicated aperture. Like others, mine is 1 stop more open than what is on the lens so camera metering is off and underexposure is given.
3. like Royce, I found the different lenses gave different readings. Most of my lenses were 1 stop off but my 55-110 was 1.5 stops and my 35FA was .5 stops out. Did not try everything.

Its time for that class-action lawsuit ;-)

Last edited by hsteeves; 07-22-2014 at 06:42 AM. Reason: addition.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
645z, aperture, av, body, camera, exchange, exposure, f/11, fa, guys, lens, lenses, medium format, mode, pm, post, shop, shutter, times, week
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Africa with the Pentax 645Z jonojono Pentax Medium Format 25 07-30-2014 05:46 PM
Help with 645Z lens selection Haseebmunir Pentax Medium Format 3 07-15-2014 06:11 PM
Favorite Pentax marketing stunt with 645z i83N Pentax Medium Format 10 07-02-2014 06:14 AM
645Z with HD video? derekkite Pentax News and Rumors 20 04-12-2014 05:03 AM
Odd behaviour with Teleconverter fgaudet Troubleshooting and Beginner Help 11 03-03-2014 06:33 PM



All times are GMT -7. The time now is 08:01 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top