Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
08-16-2014, 07:11 AM   #1
New Member




Join Date: Jun 2014
Posts: 22
645Z mirror problems

Hello,

I donīt know if my problem is what some call "mirror flop", but today, during a shooting, the mirror suddenly doesnīt go back.
I checked in live view but the screen was dark. I had to turn the camera on and off for a couple of times and I managed to get some more shots but it didnīt disapear completely.
I drove home, which was like a 2hour drive and when I arrived, I turned the camera on and did some (50-70) test shots, changing the camera orientation from landscap to portrait, but nothing happend, it seems to be ok now.
BUT ... I donīt want it happen again during my next shooting! I have no idea if this is a mechanical or a software problem .... My 645Z is 4 weeks old and I took like 3000 shots with it.
Has anyone the same experience? Would you recommend to bring it to service? It is very annoying for a camera worth that much money ...
Any advice would be helpful! Thank you very much!

best regards
Andreas

08-16-2014, 08:00 AM   #2
Site Supporter




Join Date: Feb 2011
Posts: 4,892
Hmmm, first time I've seen this reported on the 645Z.

People with the K-5 or K-3 have had good luck removing the battery, so keep that in your bag of tricks.

Personally I would call or email Pentax and describe the situation and ask for their recommendation... but intermittent problems are tough to fix, so I don't know if they'll be able to help you.
08-16-2014, 09:49 AM   #3
Pentaxian
RonHendriks1966's Avatar

Join Date: Jan 2009
Photos: Gallery
Posts: 8,556
There is a MIRROR UP button on the camera, maybe it is set to up.
08-16-2014, 10:18 AM   #4
New Member




Join Date: Jun 2014
Posts: 22
Original Poster
Hm, removing the battery would mean an os error ...
I haven't used the MIRROR button yet, but when I had the problem, I tried it and it doesnt work ...
Try to contact pentax on monday ...

08-16-2014, 10:40 AM   #5
Senior Member




Join Date: Nov 2010
Location: Calgary, Alberta
Posts: 265
What do you mean by the original statement "the mirror suddenly doesnīt go back"? Do you mean the mirror is down (in the normal position) and will not go up to expose the sensor? Or do you mean it is locked up and will not go back down? If you tried Live View and LCD was black, that means the sensor can't see anything. But that could be either because the mirror will not move up to get clear, or the shutter is stuck closed.

Either way, if you have a problem with the mirror or shutter (or both), these are mechanical problems. I would send the camera in to Pentax immediately, along with a complete description and any blacked-out or improperly exposed test files that illustrate the problem. You need to get this looked at under warranty ASAP. It will not get better and could fail completely. I have had a failed shutter replaced twice on the earlier Pentax 645D; no problems yet on my 645Z after 4000+ frames on it so far, but I guarantee you do not want to wait to get this problem addressed.
08-16-2014, 11:29 AM   #6
New Member




Join Date: Jun 2014
Posts: 22
Original Poster
Royce, this is exeactly my problem, the raw files are very underexposed, no chance in camera raw. Itīs a bit difficult for me to explain this in english, I can take a normal photo but then you donīt hear the correct noise of the "mirror" ... I also tried different lenses, same problem. I will contact Pentax.
08-16-2014, 12:25 PM   #7
Senior Member




Join Date: Nov 2010
Location: Calgary, Alberta
Posts: 265
If you have shots that are severely under-exposed, but the aperture & shutter speed were correctly set, then it is most likely a shutter problem rather than a mirror problem. Either way, the camera will need to go to Pentax.
08-16-2014, 06:51 PM   #8
Junior Member




Join Date: Dec 2010
Location: Cailfornia
Posts: 27
P645z

Did the previouus thread speak of battery removal as a fix on the K3 and K5 as a fix to a mirror problem or a general camera lockup. I have had my 645Z freeze up such that the contols became inoperative and the top display would not turn off with the on-off switch. Removal of the battery restores all of the camera functions. Is this situation also true of the K3 and K5?

11-17-2014, 11:54 PM   #9
New Member
K10DK7's Avatar

Join Date: Oct 2010
Location: Baldivis
Photos: Albums
Posts: 10
Freeze

QuoteOriginally posted by fotophil Quote
Did the previouus thread speak of battery removal as a fix on the K3 and K5 as a fix to a mirror problem or a general camera lockup. I have had my 645Z freeze up such that the contols became inoperative and the top display would not turn off with the on-off switch. Removal of the battery restores all of the camera functions. Is this situation also true of the K3 and K5?
My 645Z froze last night and needed the battery to be removed as it did not respond to any of the controls. Let's hope it's a one off. 1st time I've had an issue with it.

Best regards
11-18-2014, 07:23 AM   #10
Senior Member




Join Date: Mar 2007
Location: Lower Left Coast, USA
Photos: Gallery
Posts: 251
QuoteOriginally posted by K10DK7 Quote
My 645Z froze last night and needed the battery to be removed as it did not respond to any of the controls. Let's hope it's a one off. 1st time I've had an issue with it.
I've had this happen, infrequently, on my K7, K5 and K3. Maybe once in a year on each. Don't recall it happening on my 645Z, yet. Might be related to battery capacity at the time. Just make sure you're using the latest firmware.
12-01-2014, 09:29 AM   #11
New Member




Join Date: Jan 2013
Posts: 6
645z mirror problems

I also had issues with the mirror not behaving properly.

I took the camera into the repair centre for Canada, in Toronto, and the camera was sent back to Japan for service. It was returned, in working order, with the notation "Repaired mirror mechanism." I was told it would take between 6 and 8 weeks, and it took 7 and a half! It has worked well since.
01-13-2015, 06:43 PM   #12
Pentaxian
Thomasbrowphoto's Avatar

Join Date: May 2014
Location: NSW, Australia
Posts: 335
I had this problem too, Was told by Pentax Service that it was the aperture leaver playing up. The Mirror sound was way off and the exposures were inconsistent, noticed at about 2800 shutter actuations. I ended up getting it exchanged for another body. My new one is going strong so far.
01-16-2015, 05:45 AM   #13
New Member




Join Date: Dec 2014
Posts: 13
Mine has also been experiencing what I can only assume to be power issues, I have shot less than 1000 frames so far but have experienced several "freezes" and black screens which usually force me to remove the battery to remedy. I have noticed it happens more often when i mirror lock up mode. I look forward to an update in the firmware to address these issues..
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
645z, camera, medium format, mirror, shots
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anybody with mirror problems with K30? Focus problems. simbon4o Pentax K-30 & K-50 14 08-28-2013 10:39 PM
Problems with mirror lens on K-01...red flashing F-- slackercruster Pentax K-01 2 07-11-2012 01:20 PM
Mirror flops and DOF preview problems? Neil Manson Pentax K-r 3 05-15-2012 02:46 PM
K100D Shutter/Mirror Problems dub_1211 Pentax DSLR Discussion 2 06-08-2010 06:06 AM
New Viewer - Mirror lens problems gumpa Pentax SLR Lens Discussion 2 01-26-2009 10:11 AM



All times are GMT -7. The time now is 08:42 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top