Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
11-20-2014, 06:37 AM   #1
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,600
645z Firmware v1.20 released

V1.20 of the firmware for the 645Z has been released:

645Z Downloads : Firmware Update

Changes to V1.20

- Added OFF mode on Slow Shutter Speed NR.
(Even OFF mode setting, It may takes a long time to processing depend on condition of ISO setting, exposure time and temperature etc.)
- Improved stability for performance when using IMAGE Transmitter2.
- Improved stability for general performance.

Looks like they listened to users about restoring the slow shutter speed NR OFF mode.

11-20-2014, 06:50 AM   #2
Inactive Account




Join Date: Oct 2014
Posts: 91
Too bad nothing yet of the horrendous lcd auto gain... Wonder how one make a complain directly to them. Would love to show them a side by side of the Canon / Sony / Pentax so they can see how their display sucks for studio use.
11-20-2014, 06:58 AM   #3
Pentaxian
JinDesu's Avatar

Join Date: Jun 2011
Location: New York City
Photos: Gallery
Posts: 5,624
At least they listened on the slow shutter NR. So just talk with other 645z users and post on PRIC's facebook, twitter, etc. Pentax has been surprisingly good about listening for updates with the exception of Movie SR (to which they have their own reason).
11-20-2014, 07:09 AM   #4
Pentaxian




Join Date: Jun 2009
Location: GMT +10
Photos: Albums
Posts: 10,600
Original Poster
QuoteOriginally posted by Victor Wolansky Quote
Too bad nothing yet of the horrendous lcd auto gain
Have you installed v1.20 yet?
Maybe the Auto Gain is fixed up under the cryptic 'Improved stability for general performance'.

11-20-2014, 02:11 PM   #5
Inactive Account




Join Date: Oct 2014
Posts: 91
I have not, I will tonight.... hopefully is :-)
11-20-2014, 02:15 PM   #6
New Member




Join Date: Sep 2014
Posts: 4
Very nice, NOW HOW ABOUT MAKING IMAGE TRANSMITTER 2 AVAILABLE !!!!!
11-21-2014, 10:52 AM   #7
Junior Member




Join Date: Mar 2011
Location: Bergen County,NJ
Posts: 30
Yippee!!
Long exposure noise reduction was number one on my list of the gripes with Pentax 645D and now Z.So happy they finally gave control to the photographers to make a decision when to turn it off or on.
11-21-2014, 06:24 PM   #8
Inactive Account




Join Date: Oct 2014
Posts: 91
live view still sucks....

12-05-2014, 08:11 AM   #9
Site Supporter




Join Date: Apr 2013
Posts: 206
Why am I having problems with this update?

I had no issues with the first firmware update but I keep trying to do this second update and can't get it done
Put a cleaned SD card in my reader, the download is going to the hard drive on my Mac, copying the file to the card in the reader, put it in my 645Z as instructed, turn on the Z while holding the Menu key and the download does not begin
Can anybody suggest what I might try?
Thanks,
Bob
12-05-2014, 10:20 AM   #10
Senior Member




Join Date: Nov 2010
Location: Calgary, Alberta
Posts: 265
Most likely you need to extract the firmware file from the ZIP file you downloaded before copying to the SD card; or copy the firmware file to the root of the SD card rather than a subfolder; or use the SD card in camera slot #1 rather than slot #2. These are the most common reasons why the update process doesn't run.
12-05-2014, 10:22 AM   #11
Loyal Site Supporter
unkipunki's Avatar

Join Date: Dec 2012
Location: South Lochaweside, Argyll
Photos: Gallery
Posts: 532
QuoteOriginally posted by uintaangler Quote
I had no issues with the first firmware update but I keep trying to do this second update and can't get it done
Put a cleaned SD card in my reader, the download is going to the hard drive on my Mac, copying the file to the card in the reader, put it in my 645Z as instructed, turn on the Z while holding the Menu key and the download does not begin
Can anybody suggest what I might try?
Thanks,
Bob
Not necessarily the right answer, but have you 'unzipped' the download file before copying/moving it to the SD card. Also make sure it's in the root directory of the card not any sub folder. Lastly the card should be freshly formatted in the camera before adding the 'unzipped' firmware. Hope it's one of these three things.
12-05-2014, 12:04 PM   #12
Site Supporter




Join Date: Apr 2013
Posts: 206
Royce and unkipunki, thanks for the responses
Firmware update successfully completed

Bob
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
645d, 645z, 645z firmware v1.20, camera, firmware, medium format, mode, nr, performance, shutter, stability, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax 645Z Firmware v1.10 Released PF Staff Homepage & Official Pentax News 0 09-25-2014 03:10 PM
Pentax K-3 Firmware v1.11 Released Adam Homepage & Official Pentax News 0 08-21-2014 11:16 PM
Firmware v1.12.23.20 GPE Pentax K-5 91 01-23-2012 10:50 AM
Comparison of K-5 low light focus accuracy with v1.01 and v1.03 of firmware tram57 Pentax K-5 3 03-20-2011 08:13 PM
Firmware V1.01 for K20D released reddream Pentax DSLR Discussion 6 06-16-2008 12:45 AM



All times are GMT -7. The time now is 06:36 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top