Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
03-16-2015, 03:19 PM   #1
New Member




Join Date: Mar 2015
Posts: 2
645z problems on updating firmware 1.20

I've just acquired the Pentax 645z and found that it is running on Firmware version 1.00. Obviously i would like to update the firmware to the latest version, and gave it a try. Here's what i did
  • Downloaded the firmware ver 1.20 to my laptop (Mac)
  • Extracted the bin file
  • Formatted a SanDisk 32Gb Extreme Pro SD Card in the camera
  • Copied the bin file to the root directory of the SD Card
  • Ejected the card from the laptop
  • Turned the camera off
  • entered the SD card into slot 1 (the manual said that only slot 1 will be able to read the firmware)
  • turn the camera on
  • ..... and then nothing happened
I have now tried with several other SanDisk SD cards - older and newer cards and same result every time - nothing happens.



Have anyone else had the same issue and found a resolution? Any clue or help would be highly appreciated.


My thanks


Nils Olsson
a very happy owner of the Pentax 645z

03-16-2015, 03:24 PM - 2 Likes   #2
Loyal Site Supporter
unkipunki's Avatar

Join Date: Dec 2012
Location: South Lochaweside, Argyll
Photos: Gallery
Posts: 532
Did you hold down the menu button when you turned it back on? You need to do that.
03-16-2015, 05:14 PM - 1 Like   #3
New Member




Join Date: Mar 2015
Posts: 2
Original Poster
QuoteOriginally posted by unkipunki Quote
Did you hold down the menu button when you turned it back on? You need to do that.
I didn't, wasn't aware of it. Just tried it, and right now the camera is updating. Thank you very much for your help :-)
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
645d, 645z, bin, camera, card, cards, firmware, firmware 1.20, medium format, pentax, sd, slot, version
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Updating Metz firmware on MacOSX Mavericks or Yosemite roblgs Flashes, Lighting, and Studio 2 03-13-2015 10:41 PM
645z Firmware v1.20 released rawr Pentax Medium Format 11 12-05-2014 12:04 PM
Problem updating firmware on Pentax K-7 wklopf Troubleshooting and Beginner Help 9 09-11-2013 09:17 AM
*ist D problems updating firmware GiorgioPentax Pentax DSLR Discussion 8 06-29-2013 03:33 PM
Problems extracting firmware 1.03 on Mac reasonosx Pentax K-01 7 04-02-2013 04:57 PM



All times are GMT -7. The time now is 05:45 AM. | See also: NikonForums.com, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top