Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
06-28-2015, 07:39 AM   #1
New Member




Join Date: Jun 2015
Posts: 2
Desperately seeking advice on a SLEW of Pentax 67 issues

Hi guys,

I've been using film cameras for the past 10 years and this is by far the weirdest thing that's ever happened to me. I just bought a second-hand Pentax 67 (not the old 6x7, a relatively recent 67 model) in Japan that was in excellent condition -- the shop owner test-fired it on the spot and the exposure meter was moving, no problem. Coupling chain all intact.

Then I brought it home and loaded a new film. Did the battery check, and the light went red. Good. Advanced the film lever, hit the mirror-up switch. Clack. Tried to press the shutter button. Nothing happened. At that point I thought the shutter had already fired -- maybe I'd mistaken the sound of the mirror slap for that -- and tried to advance the lever. It will not budge at all. I do a battery check. The light is dead.

I try the usual workaround -- hitting the reset button and pressing the shutter, nothing happens. I read somewhere that it helps to have fresh batteries while doing this, so I go out today and buy some. Load the batteries in, light goes red. I check the meter. It's not moving. Hit reset and the shutter. Nothing happens.

I take the lens off, then take the prism off, then put the prism back on, and take the lens on. What I see is that the shutter curtain is closed, but the mirror is NOT down. Still no reaction from the meter. At this point, I take the film out and tried to start the dry-fire process, i.e. open the back and try to move the exposure counter manually. Nothing budges.

Here's the weird thing -- less than 10 mins had passed since I loaded the fresh battery. I hit battery check again and the light is dead. It's definitely the right battery too, a 6V PX28.

Things that I'm 150% sure of:

1. Shutter lock is NOT on.
2. Pressure plate is on 120 as it should be.
3. The film advance lever was moving very smoothly when the camera back was still open and I was feeding the roll forward. It only became noticeably stiff after I closed the back and tried to advance to 1.
4. I have tried the reset button+shutter thing a zillion times, to no avail.

What on earth is going on??? I'm so heartsick and I feel I might have wrecked the camera irrevocably only I don't even know how. Any help or kind words of advice would be so greatly appreciated.

06-28-2015, 08:30 AM   #2
Site Supporter
Site Supporter
gofour3's Avatar

Join Date: Oct 2008
Location: Vancouver, Canada
Posts: 7,091
Welcome to the forum. Looks like the same issue in this recent thread:

https://www.pentaxforums.com/forums/48-pentax-medium-format/298108-hello-pent...ml#post3291468

Here is a copy of the Pentax 67 manual, see pages 10 & 11 for procedures on "shutter release with no film":

http://www.cameramanuals.org/pentax_pdf/pentax_67-1_c.pdf

Phil.
06-28-2015, 08:50 AM   #3
New Member




Join Date: Jun 2015
Posts: 2
Original Poster
QuoteOriginally posted by gofour3 Quote
Welcome to the forum. Looks like the same issue in this recent thread:

https://www.pentaxforums.com/forums/48-pentax-medium-format/298108-hello-pent...ml#post3291468

Here is a copy of the Pentax 67 manual, see pages 10 & 11 for procedures on "shutter release with no film":

http://www.cameramanuals.org/pentax_pdf/pentax_67-1_c.pdf

Phil.
Hi gofour, thanks for your reply! Unfortunately I've encountered the same issue as the poster from the last thread -- I can't seem to advance the exposure counter forward at all. I've tried placing my fingertip on the counter where the numbers are written as per the instruction manual, but it won't move. Then I've tried opening the camera back to jiggle at the exposure counter from the inside, only to encounter the spring mechanism that the other forum member mentioned. Are we doing something wrong? My fingertips actually hurt from how much pressure I've been applying trying to turn the counter and I'm afraid that any more force is going to result it (more!) things being broken. . .

At this point the advance lever has jammed completely and I can't see the mirror at all. The reset button seems to have no effect on any of the mechanisms in the camera whatsoever -- not the mirror, nor the lever nor the batteries, nothing.
06-28-2015, 08:58 AM   #4
Loyal Site Supporter
Loyal Site Supporter




Join Date: Jun 2009
Location: Tumbleweed, Arizona
Photos: Gallery | Albums
Posts: 5,564
If all else fails, then email Eric....... he has been repairing Pentax (especially film) since 1969. He is a legend here.



06-28-2015, 10:42 AM   #5
Pentaxian
Swift1's Avatar

Join Date: Sep 2009
Location: Oregon
Photos: Gallery | Albums
Posts: 4,947
Is your shutter speed dial set correctly?

Sounds a bit like a problem I ran into with my 67 about 6 years ago.
On my camera, there was something off in the wind/cocking mechanism. When I advanced the film, the cocking mechanism would cock the mirror, but the mechanism wouldn't go far enough to cock the shutter, so when I pressed the shutter button, the mirror would lift, but the shutter wouldn't fire. The mirror mechanism is built so that the mirror won't return unless the shutter fires.
IIRC, the issue was a gear timing problem, so the camera worked normally for 4 or 5 frames then the gearing would get slightly off.
Fortunately, Eric fixed it and it's worked perfectly ever since.
06-28-2015, 11:37 PM - 1 Like   #6
Veteran Member
K David's Avatar

Join Date: Oct 2012
Location: Colorado
Photos: Gallery
Posts: 1,433
Sounds to me like you bought a dead battery. I'd try it with a second one and see what happens. What you're describing sounds like the 67's behavior in the absence of power.

If you need some additional insight into the 6X7 (and 67 in many ways), here are some YT videos:





06-29-2015, 11:11 AM   #7
Site Supporter
Site Supporter




Join Date: May 2011
Posts: 32
With some kinds of lock-ups, I've found the reset button only works with the battery out. Have you tried that?
06-30-2015, 07:15 PM - 1 Like   #8
Pentaxian
Silent Street's Avatar

Join Date: Nov 2011
Location: NOOSA, QLD
Photos: Albums
Posts: 1,061
Try the reset procedure if the mirror jams in the upright position. Insert a pointed object into the recessed hole on the mirror box side below the shutter, then fire the shutter to reset. You must have film loaded in the Pentax 67 -- it is designed only to fire the shutter when film is loaded. Yes, people will seek to bypass this using the wind on mechanism but the camera isn't that easily fooled (despite its vintage!) and repeated interference can jam the wind-on and shutter mechanisms. The other thing to check out is the battery: mirror lockup is a battery drain and as little as 4 to 5 hours of mirror lockup will deplete the battery irrespective of what is causing the jam or incorrect mirror/shutter operation.

01-26-2021, 04:40 AM   #9
New Member




Join Date: Jan 2021
Posts: 1
QuoteOriginally posted by Silent Street Quote
Try the reset procedure if the mirror jams in the upright position. Insert a pointed object into the recessed hole on the mirror box side below the shutter, then fire the shutter to reset. You must have film loaded in the Pentax 67 -- it is designed only to fire the shutter when film is loaded. Yes, people will seek to bypass this using the wind on mechanism but the camera isn't that easily fooled (despite its vintage!) and repeated interference can jam the wind-on and shutter mechanisms. The other thing to check out is the battery: mirror lockup is a battery drain and as little as 4 to 5 hours of mirror lockup will deplete the battery irrespective of what is causing the jam or incorrect mirror/shutter operation.
Hello and greetings from London.

I have noticed your amazing imput across most of the 6x7 forums regarding the MLU/ Shutter/ advance lever seizure, and the reset procedures etc with great interest.
I too am experiencing this problem.
She dry fires without hindrance... but randomly seizes mid roll, mirror halfway up, advance lever siezed...no shutter???
The only remedy to this is to remove the battery, the lens..then manually release the mirror. (My reset button followed with shutter press doesn't work) then after reinstall of battery and lens...bingo!!! We dry fire again with no issues. Til I insert a next roll anyway, goddammit!!!!
So I ask... if I am to either get this repaired..or even follow the procedure of cleaning the magnet/contacts etc...would this just be a temp fix til more p67 problems arise down the line?
A tall ask im sure...so apologies, only i am just discovering that maybe the 6x7 is too unreliable moving forward and i seriously consider cutting my loses at this point?? Or is it possible a CLA could breathe some extra undaunted years into her..

Again apologies for my ramblings... just so desperate to get this beast working...reliably.

Warm regards

J
01-27-2021, 12:07 AM - 1 Like   #10
Pentaxian
Silent Street's Avatar

Join Date: Nov 2011
Location: NOOSA, QLD
Photos: Albums
Posts: 1,061
QuoteOriginally posted by J rago Quote
So I ask... if I am to either get this repaired..or even follow the procedure of cleaning the magnet/contacts etc...would this just be a temp fix til more p67 problems arise down the line?A tall ask im sure...so apologies, only i am just discovering that maybe the 6x7 is too unreliable moving forward and i seriously consider cutting my loses at this point?? Or is it possible a CLA could breathe some extra undaunted years into her..Again apologies for my ramblings... just so desperate to get this beast working...reliably.

G'day from sunny Queensland, Downunder...


Tut, tut. It is not a tall ask. I can feel your BP and your frustration rising, probably not helped by the chill gloom of London-town... Nice 'n warm here...


One thing I notice is the winding and seizure mid-roll; this is very often symptomatic of a slipped (or stripped) winding pawl in the advance lever: it will wind on 3 or 4 frames, then become vague, then stick, failing to wind on even after the shutter is pressed or the reset procedure is run. This is particularly prevalent among the very early Pentax 6x7 cameras that have seen sustained, brutal professional use (these cameras are well over half a century old, with the P67 cameras a lot younger by comparison). The but mechanism can also fail of its own volition — it is a known Achilles Heel, if you will.


Regarding the trick of removing and re-inserting the battery, has a check been run of the condition of the terminals in the battery compartment? There are no visible wires once the battery is removed; if something is expected, the entire battery compartment should be removed for inspection. That the system resets when the battery is removed and replaced may point to the shutter/mirror solenoid not completing a cycle and only doing so when power is interrupted/cut off, then restored. As you know, the MLU cannot be activated after an exposure and the film not wound on (exception: those 67 cameras with the factory-fitted multiple-exposure facility).


Can you explain why the reset button is not working? Assuming that you are using something like a toothpick (ideal) rather than a ballpoint pen which will not often reach the deeply recessed button below. This reset is often a last resort tactic to get a stubborn camera operational again. If it definitely is not working, I am very concerned.


Unless you are confident and patient, I wouldn't really recommend servicing the mirror magnet/solenoid as a DIY. Doubtless, instructions for doing so exist on the web (I can't look: I don't like camera porn!), but can you be absolutely sure it is the mirror solenoid magnet? As stated above, removing and replacing the battery seemingly resets the solenoid process, but I'm not 100% sure. Reported (and confirmed) problems with this part of the camera are much seldom seen than others concerning, for instance, the winding mechanism/film counter, shutter speed dial or latterly, TTL meter gremlins.

Repair can unfortunately involve cost, very much so if you are sending long-distance, when road freight, not post, is the way to go. And repair of the camera is what I would prefer be done. I have stated this many times before, and it won't harm to state it again: if the camera requires repairs, no news parts are available, and what parts are required for replacement are transplanted from a like-camera — a Pentax 6x7 for repair will have parts taken from another Pentax 6x7. Conversely, the more modern Pentax 67 will have parts taken from a donor Pentax 67. The mirror solenoid/magnet was not changed from the 6x7 to the 67, but many other parts were, including tiny components of the winding mechanism.

As you are based in the UK, I think it would be wholly impactical to send the camera to the USA for repair. If you really want to cut your losses and save more grief, bite the bullet and buy another camera; it's unpallatable, I know, and won't actually endear you to yourself in doing after another camera that could (but hopefully not!!) reward you with a whole new set of bugger-all problems.

Garyh
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
645d, 645z, advance won't move, battery, button, camera, check, film, lever, light, medium format, meter, mirror, pentax 67, reset, shutter
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Seeking advice on lenses for KR Cptn_Goodvibes Pentax SLR Lens Discussion 8 12-05-2011 03:44 PM
Seeking Advice on Slide to Digital Transfer Phil47 Film Processing, Scanning, and Darkroom 10 07-08-2010 12:17 AM
Seeking advice on scanning negatives ismaelg Digital Processing, Software, and Printing 10 06-05-2009 12:47 AM
Seeking advice on telephoto lenses ismaelg Pentax SLR Lens Discussion 15 04-29-2009 08:25 PM
Seeking advice: ideas on a zoom sought doggydude Pentax SLR Lens Discussion 16 08-09-2007 11:22 AM



All times are GMT -7. The time now is 12:39 AM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top