Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
07-10-2015, 07:27 AM   #16
New Member




Join Date: Mar 2015
Posts: 5
So far, I only use 90MB/s high-speed SD card from SANDISK for my PENTAX 645Z.

Never experienced any freezing.

07-10-2015, 08:06 AM   #17
Junior Member
Chris Giles's Avatar

Join Date: Jan 2015
Photos: Albums
Posts: 45
I get freezing quite a bit, well, not so much freezing but the camera refuses to AF unless I pull the battery or wiggle the lens in the mount. Usually happens when I'm shooting a lot in a short space of time so I'm trying my best to investigate what leads to the error and that I'm not just going faster than the camera can keep up with.

Update, happened again yesterday, buffer was empty, and it was with the 150mm - Wiggled the lens in the mount and it was fine again.

Last edited by Chris Giles; 07-13-2015 at 03:41 AM.
07-05-2016, 05:13 AM   #18
New Member




Join Date: Jul 2016
Location: Morocco
Posts: 10
Pentax 645z freeze

Hi Chris

I've had the same with my month old camera. Did you find out any more on this?
04-24-2017, 08:50 AM   #19
New Member




Join Date: Mar 2012
Location: Colorado
Posts: 23
I have owned the 645D and currently own the 645Z they both had / have the same problem. The cameras simply freeze up in the middle of a shoot, the conditions don't matter. I have had both cameras serviced by Precision camera as directed by Pentax to no avail. On top of being a couple of the most frustrating pointless experiences I have had when it comes to needing camera repair. Precision supposedly sent both cameras to Japan when they were not able to correct the problem. After months of waiting to get the cameras back only to find both cameras continue to have the same problems well what can you do. If Pentax / Ricoh is aware of this issue and I can't help but think they are they have not addressed the problem in the last several years. To say I am disappointed is an understatement. It's no fun being in the middle of a shoot only to loose a shot at a critical time due to this problem. Does the camera take good images yes is it reliable..............


Last edited by Whats_edoo; 04-24-2017 at 01:36 PM.
04-24-2017, 06:18 PM   #20
Pentaxian




Join Date: Apr 2014
Location: Baltimore
Posts: 559
QuoteOriginally posted by Whats_edoo Quote
I have owned the 645D and currently own the 645Z they both had / have the same problem. The cameras simply freeze up in the middle of a shoot, the conditions don't matter. I have had both cameras serviced by Precision camera as directed by Pentax to no avail. On top of being a couple of the most frustrating pointless experiences I have had when it comes to needing camera repair. Precision supposedly sent both cameras to Japan when they were not able to correct the problem. After months of waiting to get the cameras back only to find both cameras continue to have the same problems well what can you do. If Pentax / Ricoh is aware of this issue and I can't help but think they are they have not addressed the problem in the last several years. To say I am disappointed is an understatement. It's no fun being in the middle of a shoot only to loose a shot at a critical time due to this problem. Does the camera take good images yes is it reliable..............
What are the specific conditions of your freezing?
04-24-2017, 07:12 PM   #21
New Member




Join Date: Mar 2012
Location: Colorado
Posts: 23
QuoteOriginally posted by texandrews Quote
What are the specific conditions of your freezing?
The camera freezing is unpredictable. If there is a pattern I have not been able to identify it. I do shoot a lot with the mirror locked up and a 3 second delay on the shutter so I suppose that might meet your definition of conditions. As has been mentioned before the only way to clear the issue is to remove and reinstall the battery.
05-06-2017, 04:01 AM   #22
Veteran Member
MJKoski's Avatar

Join Date: Aug 2016
Posts: 778
K-1 either freezes or becomes unresponsive for a LONG time if I try to delete pixel shift file right after exposure. I suspect some I/O operations may cause these. Try a different card perhaps?
05-06-2017, 04:29 AM   #23
Senior Member




Join Date: Dec 2009
Location: Münsterland
Posts: 128
With my 645D it is always with a specific SD-Card while writing files.
My suggestion is to try another Card or clean at least the contacts and don't delete the corrupted file.

-Linus-

05-06-2017, 06:29 AM   #24
New Member




Join Date: Mar 2012
Location: Colorado
Posts: 23
QuoteOriginally posted by -Linus- Quote
With my 645D it is always with a specific SD-Card while writing files.
My suggestion is to try another Card or clean at least the contacts and don't delete the corrupted file.

-Linus-
Interesting. I use a variety of card sizes and speeds although they are all Sandisk cards. It certainly can't hurt to try another card I suppose. My gut suggests this is a software issue common to Pentax cameras in general but of course I have no proof. If the camera didn't capture such great images :-) I might try another manufacturers offerings. Even with this issue I could never go back to full frame or smaller.
05-06-2017, 10:36 AM   #25
Veteran Member




Join Date: Jul 2009
Posts: 359
It may be a common issue, what do I know. But my 645z is at 9980 actuations this weekend and I have never experienced problems like that.
05-06-2017, 11:21 AM   #26
Senior Member




Join Date: Apr 2016
Location: Los Angeles
Posts: 137
At the risk of tempting fate now, I'm at 2.5k actuations without ever experiencing a freeze, so I do wonder if it's possibly related to a particular card type. I use Kingston cards in mine.
05-06-2017, 05:55 PM   #27
New Member




Join Date: Mar 2012
Location: Colorado
Posts: 23
QuoteOriginally posted by paulster Quote
At the risk of tempting fate now, I'm at 2.5k actuations without ever experiencing a freeze, so I do wonder if it's possibly related to a particular card type. I use Kingston cards in mine.
Lucky guys I'm glad for you. I may try Kingston cards and see what happens.
05-06-2017, 06:22 PM   #28
Senior Member




Join Date: Apr 2016
Location: Los Angeles
Posts: 137
QuoteOriginally posted by Whats_edoo Quote
Lucky guys I'm glad for you. I may try Kingston cards and see what happens.

The ones I use are the burgundy coloured 256GB ones that are 90MB/s read and 80MB/s write. There may be faster cards now, but these were the fastest available when I got them and have been flawless with the 645Z.
05-08-2017, 09:19 AM   #29
New Member




Join Date: Mar 2012
Location: Colorado
Posts: 23
QuoteOriginally posted by CarlG Quote
It may be a common issue, what do I know. But my 645z is at 9980 actuations this weekend and I have never experienced problems like that.
What brand of cards do you use?
05-08-2017, 09:44 AM   #30
Veteran Member




Join Date: Jul 2009
Posts: 359
I am using 2 x 128GB Sandisk Extreme cards (90 MB/s)

Please note that if you have problems, it may be useful to format them with the SD Association own card formatter rather than these assorted pc programs (see SD Card Formatter - SD Association).

In the same vein, you should probably be strict at using the Windows remove tool when you are finished on the pc (or drop it into the garbage can if you're at a Mac).
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
645d, 645z, aperture, camera, freezing, locking up, medium format
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dream becomes reality: Sony officially unveils their curved sensor tech! jogiba Non-Pentax Cameras: Canon, Nikon, etc. 52 10-09-2014 01:39 PM
K5 IIs freezes up hjoseph7 Pentax K-5 4 09-01-2014 07:26 PM
k 5 freezes up marktn Troubleshooting and Beginner Help 4 04-17-2014 04:14 AM
Help for unresponsive 4 way controller jamarley Troubleshooting and Beginner Help 8 02-03-2014 01:34 PM
Adjustment wheels become unresponsive? Newtophotos Pentax DSLR Discussion 7 09-25-2013 02:32 AM



All times are GMT -7. The time now is 11:44 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top