Forgot Password
Pentax Camera Forums Home
 

Reply
Show Printable Version Search this Thread
09-13-2015, 04:09 AM   #1
Junior Member




Join Date: Sep 2015
Posts: 25
Pentax 67ii time process issue

Hi,
Thanks for your help.
I am having problem using time exposure mode.

I have the AE Prism finder attached to the camera body.

I am moving the time exposure lever out after
1) setting the aperture
2) winding the film lever (film is not loaded)

then I press the shutter fully ( is this right ? )

A) Do I set time by moving shutter speed dial to A(aperture) or time or B (bulb) ?

The shutter opens and it closes after the set time is over.

It happens even if I do not push the time exposure set lever back in.


Is this how the time exposure is supposed to work?

09-14-2015, 09:44 AM   #2
Junior Member




Join Date: Sep 2015
Posts: 25
Original Poster
Hi, thanks. I do have the pdf copy of the file and also the printed version. However, what is said in there does not work for me. I might also be not reading the implied stuff correctly.
09-23-2015, 09:58 AM   #3
Junior Member




Join Date: Sep 2015
Posts: 25
Original Poster
Sorry, I am just feeling lost on this.

I am trying to understand the Pentax 67ii timer , power saving mode for long time exposure.
I believe that the following steps need to be done:
1) One selects the aperture by turning the aperture ring on the lens .

Which position should the shutter speed dial button be in : A , B or duration required ?

2) slide out the timer process button
3) wind the film button
4) is AE prism finder or one of the prism finders required ?
5) press the shutter release button

The shutter opens and closes automatically when the time lapses ?
Is my understanding correct ?
09-24-2015, 07:58 AM   #4
Site Supporter
gofour3's Avatar

Join Date: Oct 2008
Location: Vancouver, Canada
Posts: 5,287
QuoteOriginally posted by csanjay Quote
Sorry, I am just feeling lost on this.

I am trying to understand the Pentax 67ii timer , power saving mode for long time exposure.
I believe that the following steps need to be done:
1) One selects the aperture by turning the aperture ring on the lens .

Which position should the shutter speed dial button be in : A , B or duration required ?

2) slide out the timer process button
3) wind the film button
4) is AE prism finder or one of the prism finders required ?
5) press the shutter release button

The shutter opens and closes automatically when the time lapses ?
Is my understanding correct ?
Yes the P67ii manual is a bit fuzzy when it comes to the power saving long exposure mode.

My take on it that when you move the lever out and press the shutter it will remain open until you move the lever back. Which means the shutter speed dial is not used and the AE prism is not required as no metering is done.

Phil.

10-14-2015, 09:24 AM   #5
Junior Member




Join Date: Sep 2015
Posts: 25
Original Poster
thanks for your reply
01-18-2016, 09:20 AM   #6
Junior Member




Join Date: Sep 2015
Posts: 25
Original Poster
Hi,
I got it serviced and it works. Updating here for anyone interested in this in future:
I got info from person on FB who saw my post and replied.
1) Set the aperture after switching on camera
2) wind the film
3) Prism finder is not needed
4) It works even without film
5) set exposure mode to B
6) push out time exposure ( PS time) lever button
7) press shutter button fully - shutter will open
8) push time exposure button back
9) shutter will close
Tested my camera and this is how it is working now.
Reply

Bookmarks
  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
645d, 645z, 67ii time process, ae prismfinder, camera, exposure, film, lever, long exposure, medium format, pentax 67ii time, pentax67ii, pentax6x7, shutter, time
Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pentax 67ii timer process query csanjay Troubleshooting and Beginner Help 1 01-18-2016 09:16 AM
Pentax K3 Time Lapse Issue! Korus Pentax DSLR Discussion 11 08-17-2015 01:37 AM
Pentax 67ii issue bigdaddyg Pentax Medium Format 4 11-03-2014 04:07 PM
Pentax 67II time exposure button question rustyair Pentax Medium Format 8 10-11-2013 07:17 AM
67II Frame Spacing Issue RawheaD Pentax Medium Format 10 05-05-2011 10:43 PM



All times are GMT -7. The time now is 06:12 PM. | See also: NikonForums.com, CanonForums.com part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
register
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]
Top