Forgot Password
Pentax Camera Forums Home

Show Printable Version Search this Thread
12-05-2015, 11:29 PM   #1
New Member

Join Date: Dec 2015
Posts: 2
Pentax 67II shutter release button problem

Hi everyone,

I've recently bought a used Pentax 67II. It seems to function properly, but I found an issue with shutter release button.
As per the user manual there should be 3 button positions: not pressed, pressed half the way and fully pressed.
Page from the user manual explaining how it should work.

Mine seems to be locked in halfway pressed. It does not go back to "not pressed" position, however it does press down to "fully pressed" and releases the shutter.
The indication and lightmeter are always on in the viewfinder. The manual suggests they should be off when the shutter release is not pressed.

It's not a major issue, however I found that it affects the bulb mode. When I switch the dial to "bulb" and release the shutter it flips up the mirror, opens the shutter curtain but when I unpress the button it does not close the shutter. I found the only way to do so - turn the body to "lock" position. But I don't think this is how it should operate.

I would appreciate any help on this matter. Is this a common issue? Is it easily fixable?
Thank you in advance.

12-07-2015, 09:03 AM   #2
Site Supporter
Site Supporter
gofour3's Avatar

Join Date: Oct 2008
Location: Vancouver, Canada
Posts: 7,208
Welcome to the forum!

Not sure with the shutter button, sounds like it's sticking.

Maybe email Eric to see if he knows:

Pentax Repairs Home Page

12-07-2015, 12:48 PM   #3
New Member

Join Date: Dec 2015
Posts: 2
Original Poster
Hi Phil, thank you very much!
Will try to contact Eric.
04-11-2017, 09:23 AM   #4
New Member

Join Date: Apr 2017
Posts: 1
Hi! Bringing this old thread back. I seem to have a similar problem. I've just got my 67ii in the mail and there's no way I can feel where the half-press position is. The trigger is very hairy. Is that how it's supposed to be? Mine came with the non-metered prism so I can't tell if the light meter is engaged. The bulb mode works however. Any local shops in Souther California that are able to assess/repair? Thanks!

02-22-2019, 04:03 PM   #5
New Member

Join Date: Feb 2019
Posts: 3
Iím having the exact same problem with the shutter release!
How did you guys ended up fixing it?

Thanks in advance.
02-23-2019, 12:33 AM   #6
New Member

Join Date: Feb 2019
Location: Novosibirsk
Photos: Albums
Posts: 2
I had the same trouble.

It is required to remove upper-right cover from camera (with shutter button) and make some adjustments. You could do it for yourself (take care and read service manual first!) or send camera to service center. Remember to remove screw inside battery compartment, you will need small and long screwdriver.

Underneath shutter button there are 3 latches in "E" pattern, a simple switch. Then upper 2 latches are in contact AE mode is engaged (a half-press). A slight bend of upper latch upwards (~1mm) was enough to solve this promblem for me.
If this will not help, do not disassemble further. P67II is a VERY complex camera (i admire it).
Attached Images
02-23-2019, 05:20 PM   #7
New Member

Join Date: Feb 2019
Posts: 3
Thank you very much for your reply and the picture! I really appreciate it. I left it at service and they are supposed to see it this next Monday. Iíll let them know about the battery compartment. I hope this fixes it!

02-26-2019, 09:51 AM - 1 Like   #8
New Member

Join Date: Feb 2019
Posts: 3
Fixed it! the instructions worked. I was worried it was gonna be an expensive fix or needed non available parts but it was a simple fix!

Thanks again.

  • Submit Thread to Facebook Facebook
  • Submit Thread to Twitter Twitter
  • Submit Thread to Digg Digg
Tags - Make this thread easier to find by adding keywords to it!
645d, 645z, button, camera, issue, medium format, pentax, position, release, shutter, shutter release button, user
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to clean shutter release button? gene4000 Ricoh GR 2 08-27-2015 04:33 AM
pentax KR shutter button problem muhammadzakaria Visitors' Center 3 12-15-2014 12:04 AM
Broken shutter-release button on Pentax K-x fashionista20100 Troubleshooting and Beginner Help 5 04-26-2011 06:25 PM
Pentax Me is missing its shutter release button iridescentstripes Pentax Film SLR Discussion 3 01-12-2010 05:37 PM
problem with spotmatic sp shutter release button cvsuave Pentax Film SLR Discussion 3 04-21-2009 04:41 AM

All times are GMT -7. The time now is 01:01 PM. | See also:, part of our network of photo forums!
  • Red (Default)
  • Green
  • Gray
  • Dark
  • Dark Yellow
  • Dark Blue
  • Old Red
  • Old Green
  • Old Gray
  • Dial-Up Style
Hello! It's great to see you back on the forum! Have you considered joining the community?
Creating a FREE ACCOUNT takes under a minute, removes ads, and lets you post! [Dismiss]